summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-27 21:54:26 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-27 21:54:26 +0000
commitd8f45757f2d755c6dbacd2265b3b62361ea7e4d3 (patch)
treef0a6feddb7e235a56a8709b6bcd4f2cdcfde11b4 /gnome-extra
parentremove old version (diff)
downloadgentoo-2-d8f45757f2d755c6dbacd2265b3b62361ea7e4d3.tar.gz
gentoo-2-d8f45757f2d755c6dbacd2265b3b62361ea7e4d3.tar.bz2
gentoo-2-d8f45757f2d755c6dbacd2265b3b62361ea7e4d3.zip
Add missing gconf-python dep (bug #401083, thanks to Ben Kohler for reporting); make cinnamon-settings respect /usr/lib64 and use python2.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cinnamon/ChangeLog9
-rw-r--r--gnome-extra/cinnamon/cinnamon-1.2-r1.ebuild (renamed from gnome-extra/cinnamon/cinnamon-1.2.ebuild)28
2 files changed, 32 insertions, 5 deletions
diff --git a/gnome-extra/cinnamon/ChangeLog b/gnome-extra/cinnamon/ChangeLog
index 842ff4ffff9f..8f40b53c58d0 100644
--- a/gnome-extra/cinnamon/ChangeLog
+++ b/gnome-extra/cinnamon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/cinnamon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/ChangeLog,v 1.3 2012/01/25 08:43:16 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/ChangeLog,v 1.4 2012/01/27 21:54:26 tetromino Exp $
+
+*cinnamon-1.2-r1 (27 Jan 2012)
+
+ 27 Jan 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -cinnamon-1.2.ebuild, +cinnamon-1.2-r1.ebuild:
+ Add missing gconf-python dep (bug #401083, thanks to Ben Kohler for
+ reporting); make cinnamon-settings respect /usr/lib64 and use python2.
*cinnamon-1.2 (25 Jan 2012)
diff --git a/gnome-extra/cinnamon/cinnamon-1.2.ebuild b/gnome-extra/cinnamon/cinnamon-1.2-r1.ebuild
index 216865818989..0679be78139d 100644
--- a/gnome-extra/cinnamon/cinnamon-1.2.ebuild
+++ b/gnome-extra/cinnamon/cinnamon-1.2-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/cinnamon-1.2.ebuild,v 1.1 2012/01/25 08:43:16 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/cinnamon-1.2-r1.ebuild,v 1.1 2012/01/27 21:54:26 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
PYTHON_DEPEND="2:2.5"
-inherit autotools eutils gnome2 pax-utils python
+inherit autotools eutils gnome2 multilib pax-utils python
DESCRIPTION="A fork of GNOME Shell with layout similar to GNOME 2"
HOMEPAGE="http://cinnamon.linuxmint.com/"
@@ -74,6 +74,7 @@ COMMON_DEPEND=">=dev-libs/glib-2.29.10:2
# user switching with gdm-3.1.x)
# 6. caribou needed for on-screen keyboard
# 7. xdg-utils needed for xdg-open, used by extension tool
+# 8. gconf-python needed for cinnamon-settings
RDEPEND="${COMMON_DEPEND}
>=gnome-base/dconf-0.4.1
>=gnome-base/libgnomekbd-2.91.4[introspection]
@@ -90,6 +91,8 @@ RDEPEND="${COMMON_DEPEND}
x11-misc/xdg-utils
+ dev-python/gconf-python:2
+
networkmanager? (
net-misc/mobile-broadband-provider-info
sys-libs/timezone-data )"
@@ -133,18 +136,28 @@ src_prepare() {
sed -e "s:/usr/lib/gnome-session/gnome-session-check-accelerated:${EPREFIX}/usr/libexec/gnome-session-check-accelerated:" \
-i "files/usr/share/gnome-session/sessions/cinnamon.session" || die "sed 1 failed"
+ # Gentoo uses /usr/$(get_libdir), not /usr/lib even for python
+ sed -e "s:/usr/lib/cinnamon-settings:/usr/$(get_libdir)/cinnamon-settings:" \
+ -i files/usr/lib/cinnamon-settings/cinnamon-settings.py \
+ files/usr/bin/cinnamon-settings \
+ files/cinnamon-settings.pot \
+ files/makepot || die "sed 2 failed"
+ mv files/usr/lib files/usr/$(get_libdir) || die "mv failed"
+
eautoreconf
gnome2_src_prepare
# Drop G_DISABLE_DEPRECATED for sanity on glib upgrades; bug #384765
# Note: sed Makefile.in because it is generated from several Makefile.ams
sed -e 's/-DG_DISABLE_DEPRECATED//g' \
- -i src/Makefile.in browser-plugin/Makefile.in || die "sed 2 failed"
+ -i src/Makefile.in browser-plugin/Makefile.in || die "sed 3 failed"
}
src_install() {
gnome2_src_install
- python_convert_shebangs 2 "${D}"/usr/bin/cinnamon-extension-tool
+ python_convert_shebangs 2 "${ED}usr/bin/cinnamon-extension-tool" \
+ "${ED}usr/bin/cinnamon-settings" \
+ "${ED}usr/$(get_libdir)/cinnamon-settings/cinnamon-settings.py"
# Required for gnome-shell on hardened/PaX, bug #398941
pax-mark mr "${ED}usr/bin/cinnamon"
@@ -152,6 +165,8 @@ src_install() {
pkg_postinst() {
gnome2_pkg_postinst
+ python_mod_optimize /usr/$(get_libdir)/cinnamon-settings
+
if ! has_version '>=media-libs/gst-plugins-good-0.10.23' || \
! has_version 'media-plugins/gst-plugins-vp8'; then
ewarn "To make use of Cinnamon's built-in screen recording utility,"
@@ -190,3 +205,8 @@ pkg_postinst() {
fi
fi
}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/cinnamon-settings
+}