summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-17 16:57:27 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-17 16:57:27 +0000
commit84ecdfa87939f1d76eeb8908ae13457af18291e1 (patch)
tree0c396dbe66b0d05534692411afe6438a431dad12 /gnome-extra
parentadd small fixed and bumped up ebuild version (diff)
downloadgentoo-2-84ecdfa87939f1d76eeb8908ae13457af18291e1.tar.gz
gentoo-2-84ecdfa87939f1d76eeb8908ae13457af18291e1.tar.bz2
gentoo-2-84ecdfa87939f1d76eeb8908ae13457af18291e1.zip
Version bump, added patch, and updated deps. (bug #3617)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/battstat/ChangeLog10
-rw-r--r--gnome-extra/battstat/battstat-2.0.13.ebuild47
-rw-r--r--gnome-extra/battstat/files/battstat-acpi.diff61
-rw-r--r--gnome-extra/battstat/files/digest-battstat-2.0.132
4 files changed, 119 insertions, 1 deletions
diff --git a/gnome-extra/battstat/ChangeLog b/gnome-extra/battstat/ChangeLog
index db4e8b8f0d6a..6b277667ab9c 100644
--- a/gnome-extra/battstat/ChangeLog
+++ b/gnome-extra/battstat/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/battstat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/battstat/ChangeLog,v 1.4 2002/06/11 00:38:41 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/battstat/ChangeLog,v 1.5 2002/06/17 16:57:27 stroke Exp $
+
+*battstat-2.0.13 (17 Jun 2002)
+
+ 17 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> ChangeLog :
+
+ Version bump, patch added, updated dependencies.
+ Thanks again to hanno@gmx.de (Hanno Boeck) bug #3617
+
*battstat-2.0.11 (10 Jun 2002)
diff --git a/gnome-extra/battstat/battstat-2.0.13.ebuild b/gnome-extra/battstat/battstat-2.0.13.ebuild
new file mode 100644
index 000000000000..53cfc740bfa9
--- /dev/null
+++ b/gnome-extra/battstat/battstat-2.0.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/battstat/battstat-2.0.13.ebuild,v 1.1 2002/06/17 16:57:27 stroke Exp $
+
+S=${WORKDIR}/battstat_applet-${PV}
+DESCRIPTION="Battstat Applet, GNOME battery status applet."
+SRC_URI="http://download.sourceforge.net/battstat/battstat_applet-${PV}.tar.gz
+http://download.sourceforge.net/sourceforge/battstat/acpi-linux.h"
+HOMEPAGE="http://battstat.sourceforge.net"
+
+DEPEND="virtual/glibc
+ >=gnome-base/gnome-libs-1.4.1.7
+ >=gnome-base/gnome-core-1.4.0.8
+ >=sys-apps/apmd-3.0.2-r2
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack battstat_applet-${PV}.tar.gz
+ cp ${DISTDIR}/acpi-linux.h battstat_applet-${PV}/src/
+ patch -p0 < ${FILESDIR}/battstat-acpi.diff
+}
+
+src_compile() {
+ local myconf
+
+ use nls \
+ || myconf="--disable-nls"
+# && myconf="--localedir=/usr/share/locale" \
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ gnomeconfdir=${D}/etc \
+ gnomedatadir=${D}/usr/share \
+ gnulocaledir=${D}/usr/share/locale \
+ install || die
+
+ rm ${D}/topic.dat
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
diff --git a/gnome-extra/battstat/files/battstat-acpi.diff b/gnome-extra/battstat/files/battstat-acpi.diff
new file mode 100644
index 000000000000..6ed6f3976bb8
--- /dev/null
+++ b/gnome-extra/battstat/files/battstat-acpi.diff
@@ -0,0 +1,61 @@
+--- battstat_applet-2.0.13-orig/src/acpi-linux.c Sun Nov 4 23:41:22
+2001
++++ battstat_applet-2.0.13/src/acpi-linux.c Tue May 7 12:28:31 2002
+@@ -49,7 +49,7 @@
+ if ((c = strchr(tmp, ':'))) // Is a colon separated line
+ {
+ *c = 0;
+- if (strcmp(tmp, field) == 0) // It is the right line
++ if (strcasecmp(tmp, field) == 0) // It is the right line
+ {
+ c++; // Find the beginning of the data
+ if (*c)
+@@ -106,11 +106,11 @@
+ low_capacity = 0;
+ critical_capacity = 0;
+
+- if ((f = fopen("/proc/acpi/battery/1/info", "r")))
++ if ((f = fopen("/proc/acpi/battery/BAT1/info", "r")))
+ {
+- max_capacity = al_get_field_int(f, "Design Capacity");
+- low_capacity = al_get_field_int(f, "Design Capacity Warning");
+- critical_capacity = al_get_field_int(f, "Design Capacity Low");
++ max_capacity = al_get_field_int(f, "design capacity");
++ low_capacity = al_get_field_int(f, "design capacity warning");
++ critical_capacity = al_get_field_int(f, "design capacity low");
+
+ fclose(f);
+ }
+@@ -121,27 +121,27 @@
+ charging = FALSE;
+ remain = 0;
+
+- if ((f = fopen("/proc/acpi/battery/1/status", "r")))
++ if ((f = fopen("/proc/acpi/battery/BAT1/state", "r")))
+ {
+ gchar *s;
+ gchar tmp[256];
+
+- if ((s = al_get_field(f, "State", tmp, sizeof(tmp))))
++ if ((s = al_get_field(f, "charging state", tmp, sizeof(tmp))))
+ charging = strcmp(s, "charging") == 0;
+
+- remain = al_get_field_int(f, "Remaining Capacity");
++ remain = al_get_field_int(f, "remaining capacity");
+
+ fclose(f);
+ }
+
+ ac_online = FALSE;
+
+- if ((f = fopen("/proc/acpi/ac_adapter/0/status", "r")))
++ if ((f = fopen("/proc/acpi/ac_adapter/ACAD/state", "r")))
+ {
+ gchar *s;
+ gchar tmp[256];
+
+- if ((s = al_get_field(f, "Status", tmp, sizeof(tmp))))
++ if ((s = al_get_field(f, "state", tmp, sizeof(tmp))))
+ ac_online = strcmp(s, "on-line") == 0;
+
+ fclose(f);
diff --git a/gnome-extra/battstat/files/digest-battstat-2.0.13 b/gnome-extra/battstat/files/digest-battstat-2.0.13
new file mode 100644
index 000000000000..5390d097a274
--- /dev/null
+++ b/gnome-extra/battstat/files/digest-battstat-2.0.13
@@ -0,0 +1,2 @@
+MD5 a6c704b14ab8b3911e18c8d44e6846c3 battstat_applet-2.0.13.tar.gz 823753
+MD5 83abe9b005c6c13ae1c88737636a14de acpi-linux.h 923