summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-06-27 16:55:35 +0000
committerPacho Ramos <pacho@gentoo.org>2015-06-27 16:55:35 +0000
commitdc77dcf233648b6c0fce79823ff567444b59f2ac (patch)
treec4d02596d95739beb31f47a6743296844d2787ff /gnome-extra/zenity
parentBuild system uses VALA_EXECUTABLE cmake variable instead of VALAC env variabl... (diff)
downloadgentoo-2-dc77dcf233648b6c0fce79823ff567444b59f2ac.tar.gz
gentoo-2-dc77dcf233648b6c0fce79823ff567444b59f2ac.tar.bz2
gentoo-2-dc77dcf233648b6c0fce79823ff567444b59f2ac.zip
Version bump, drop old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra/zenity')
-rw-r--r--gnome-extra/zenity/ChangeLog8
-rw-r--r--gnome-extra/zenity/metadata.xml2
-rw-r--r--gnome-extra/zenity/zenity-3.16.3.ebuild49
3 files changed, 57 insertions, 2 deletions
diff --git a/gnome-extra/zenity/ChangeLog b/gnome-extra/zenity/ChangeLog
index a352e4fe554b..34697ad211e9 100644
--- a/gnome-extra/zenity/ChangeLog
+++ b/gnome-extra/zenity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/zenity
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/ChangeLog,v 1.228 2015/06/09 14:30:39 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/ChangeLog,v 1.229 2015/06/27 16:55:35 pacho Exp $
+
+*zenity-3.16.3 (27 Jun 2015)
+
+ 27 Jun 2015; Pacho Ramos <pacho@gentoo.org> +zenity-3.16.3.ebuild,
+ metadata.xml:
+ Version bump, drop old
*zenity-3.16.2 (09 Jun 2015)
diff --git a/gnome-extra/zenity/metadata.xml b/gnome-extra/zenity/metadata.xml
index dad9001338dc..da6fd63d0085 100644
--- a/gnome-extra/zenity/metadata.xml
+++ b/gnome-extra/zenity/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>gnome</herd>
+<herd>gnome</herd>
</pkgmetadata>
diff --git a/gnome-extra/zenity/zenity-3.16.3.ebuild b/gnome-extra/zenity/zenity-3.16.3.ebuild
new file mode 100644
index 000000000000..c0e936e8e41a
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.16.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zenity/zenity-3.16.3.ebuild,v 1.1 2015/06/27 16:55:35 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="libnotify test +webkit"
+
+RDEPEND="
+ >=dev-libs/glib-2.8:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3:3
+ x11-libs/libX11
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4 )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+ test? ( app-text/yelp-tools )
+"
+# eautoreconf needs:
+# >=gnome-base/gnome-common-2.12
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+
+ gnome2_src_configure \
+ $(use_enable libnotify) \
+ $(use_enable webkit webkitgtk) \
+ PERL=$(type -P false)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}