summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2008-11-05 18:31:34 +0000
committerSerkan Kaba <serkan@gentoo.org>2008-11-05 18:31:34 +0000
commit2771b1aab5f2b68ba41ecaad5ad061e68230cc91 (patch)
treedd112db9f8bc75f1d1938192a3f89084313daca6 /gnome-extra/file-browser-applet
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-2771b1aab5f2b68ba41ecaad5ad061e68230cc91.tar.gz
gentoo-2-2771b1aab5f2b68ba41ecaad5ad061e68230cc91.tar.bz2
gentoo-2-2771b1aab5f2b68ba41ecaad5ad061e68230cc91.zip
Version bump that adds optional hotkey support via x11-libs/gtkhotkey.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'gnome-extra/file-browser-applet')
-rw-r--r--gnome-extra/file-browser-applet/ChangeLog9
-rw-r--r--gnome-extra/file-browser-applet/file-browser-applet-0.6.0.ebuild44
-rw-r--r--gnome-extra/file-browser-applet/files/file-browser-applet-0.6.0-fixautomagic-gtkhotkey.patch61
-rw-r--r--gnome-extra/file-browser-applet/metadata.xml3
4 files changed, 116 insertions, 1 deletions
diff --git a/gnome-extra/file-browser-applet/ChangeLog b/gnome-extra/file-browser-applet/ChangeLog
index 29c82a9bc12a..6b35366ace67 100644
--- a/gnome-extra/file-browser-applet/ChangeLog
+++ b/gnome-extra/file-browser-applet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/file-browser-applet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/file-browser-applet/ChangeLog,v 1.3 2008/10/29 22:11:07 serkan Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/file-browser-applet/ChangeLog,v 1.4 2008/11/05 18:31:33 serkan Exp $
+
+*file-browser-applet-0.6.0 (05 Nov 2008)
+
+ 05 Nov 2008; Serkan Kaba <serkan@gentoo.org>
+ +files/file-browser-applet-0.6.0-fixautomagic-gtkhotkey.patch,
+ metadata.xml, +file-browser-applet-0.6.0.ebuild:
+ Version bump that adds optional hotkey support via x11-libs/gtkhotkey.
*file-browser-applet-0.5.9 (29 Oct 2008)
diff --git a/gnome-extra/file-browser-applet/file-browser-applet-0.6.0.ebuild b/gnome-extra/file-browser-applet/file-browser-applet-0.6.0.ebuild
new file mode 100644
index 000000000000..9c655ee92948
--- /dev/null
+++ b/gnome-extra/file-browser-applet/file-browser-applet-0.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/file-browser-applet/file-browser-applet-0.6.0.ebuild,v 1.1 2008/11/05 18:31:33 serkan Exp $
+
+inherit gnome2 cmake-utils
+
+DESCRIPTION="Browse and open files in your home directory from the GNOME panel."
+HOMEPAGE="http://code.google.com/p/gnome-menu-file-browser-applet/"
+SRC_URI="http://gnome-menu-file-browser-applet.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gtkhotkey"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=gnome-base/gnome-panel-2.0
+ >=gnome-base/libglade-2.0
+ >=dev-libs/glib-2.16
+ gtkhotkey? ( x11-libs/gtkhotkey )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/cmake-2.4.8"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ epatch "${FILESDIR}"/${P}-fixautomagic-gtkhotkey.patch
+ #Move to src_prepare when portage-2.2 is stable.
+}
+
+src_compile() {
+ mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_GCONF_SCHEMA_DIR=/etc/gconf/schemas"
+ use gtkhotkey || mycmakeargs="${mycmakeargs} -DDISABLE_GTK_HOTKEY=true"
+ cmake-utils_src_compile
+}
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ cmake-utils_src_install
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+ dodoc HISTORY README || die "dodoc failed"
+}
diff --git a/gnome-extra/file-browser-applet/files/file-browser-applet-0.6.0-fixautomagic-gtkhotkey.patch b/gnome-extra/file-browser-applet/files/file-browser-applet-0.6.0-fixautomagic-gtkhotkey.patch
new file mode 100644
index 000000000000..047d99b53c6d
--- /dev/null
+++ b/gnome-extra/file-browser-applet/files/file-browser-applet-0.6.0-fixautomagic-gtkhotkey.patch
@@ -0,0 +1,61 @@
+Index: INSTALL
+===================================================================
+--- INSTALL (revision 159)
++++ INSTALL (revision 160)
+@@ -22,13 +22,14 @@
+
+ Configuration
+ *************
+-There are 5 configuration options available:
++There are 6 configuration options available:
+ * CMAKE_INSTALL_PREFIX
+ * CMAKE_INSTALL_LIB_PREFIX
+ * CMAKE_INSTALL_LIB_EXEC_DIR
+ * CMAKE_INSTALL_BONOBO_DIR
+ * CMAKE_INSTALL_GCONF_SCHEMA_DIR
+ * CMAKE_INSTALL_GLADEUI_DIR
++ * DISABLE_GTK_HOTKEY
+
+ CMAKE_INSTALL_PREFIX specifies the base installation prefix. The following
+ other specific installation paths depend on this prefix:
+@@ -56,6 +57,9 @@
+ CMAKE_INSTALL_BONOBO_DIR specifies the installation bonobo Server file. The
+ default is CMAKE_INSTALL_LIB_PREFIX/bonobo/servers
+
++DISABLE_GTK_HOTKEY disables the use of libgtkhotkey even if it found by cmake.
++The default value is false, meaning that if libgtkhotkey is found it will be used.
++
+ To configure using the defaults, run the following command at the project root folder:
+ 'cmake .'
+
+Index: src/CMakeLists.txt
+===================================================================
+--- src/CMakeLists.txt (revision 159)
++++ src/CMakeLists.txt (revision 160)
+@@ -1,8 +1,16 @@
+ INCLUDE (FindPkgConfig)
+
+ PKG_CHECK_MODULES (DEPS REQUIRED gtk+-2.0>=2.14 gio-unix-2.0 libpanelapplet-2.0 libglade-2.0)
+-PKG_CHECK_MODULES (LIBGTKHOTKEY gtkhotkey-1.0)
+
++
++# Clear the cached value of LIBGTKHOTKEY_FOUND
++SET (LIBGTKHOTKEY_FOUND false)
++IF (DISABLE_GTK_HOTKEY)
++ MESSAGE ("\n-- libgtkhotkey disabled.")
++ELSE (DISABLE_GTK_HOTKEY)
++ PKG_CHECK_MODULES (LIBGTKHOTKEY gtkhotkey-1.0)
++ENDIF (DISABLE_GTK_HOTKEY)
++
+ INCLUDE_DIRECTORIES (${DEPS_INCLUDE_DIRS})
+ LINK_DIRECTORIES (${DEPS_LIBRARY_DIRS})
+ SET (LIBS ${DEPS_LIBRARIES})
+@@ -35,3 +43,8 @@
+ TARGET_LINK_LIBRARIES (${EXEC} ${LIBS})
+
+ INSTALL (TARGETS ${EXEC} DESTINATION "${CMAKE_INSTALL_LIB_EXEC_DIR}")
++
++# Clear DISABLE_GTK_HOTKEY in the cache so it is reevaluated every time. Sigh!
++# Have to do it twice or it doesn't work
++SET (DISABLE_GTK_HOTKEY false CACHE INTERNAL "sigh!")
++SET (DISABLE_GTK_HOTKEY false CACHE INTERNAL "sigh!")
diff --git a/gnome-extra/file-browser-applet/metadata.xml b/gnome-extra/file-browser-applet/metadata.xml
index ec0ca90022de..0122d579e030 100644
--- a/gnome-extra/file-browser-applet/metadata.xml
+++ b/gnome-extra/file-browser-applet/metadata.xml
@@ -5,4 +5,7 @@
<maintainer>
<email>serkan@gentoo.org</email>
</maintainer>
+<use>
+ <flag name="gtkhotkey">Enable hotkey support via <pkg>x11-libs/gtkhotkey</pkg></flag>
+</use>
</pkgmetadata>