summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-06-24 08:44:54 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-06-24 08:44:54 +0000
commit439b213b889ba086f247048e86519ed03f80662a (patch)
treed7093bcc8987d17b821420e17d21293f9ac761d5 /gnome-extra/evolution-groupwise
parentBump to 3.4.3 (diff)
downloadgentoo-2-439b213b889ba086f247048e86519ed03f80662a.tar.gz
gentoo-2-439b213b889ba086f247048e86519ed03f80662a.tar.bz2
gentoo-2-439b213b889ba086f247048e86519ed03f80662a.zip
Bump to 3.4.2
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/evolution-groupwise')
-rw-r--r--gnome-extra/evolution-groupwise/ChangeLog8
-rw-r--r--gnome-extra/evolution-groupwise/evolution-groupwise-3.4.2.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/gnome-extra/evolution-groupwise/ChangeLog b/gnome-extra/evolution-groupwise/ChangeLog
index 805216f60d94..bca3d211578b 100644
--- a/gnome-extra/evolution-groupwise/ChangeLog
+++ b/gnome-extra/evolution-groupwise/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-groupwise
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-groupwise/ChangeLog,v 1.4 2012/05/07 05:58:40 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-groupwise/ChangeLog,v 1.5 2012/06/24 08:44:54 nirbheek Exp $
+
+*evolution-groupwise-3.4.2 (24 Jun 2012)
+
+ 24 Jun 2012; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +evolution-groupwise-3.4.2.ebuild:
+ Bump to 3.4.2
*evolution-groupwise-3.4.0 (07 May 2012)
diff --git a/gnome-extra/evolution-groupwise/evolution-groupwise-3.4.2.ebuild b/gnome-extra/evolution-groupwise/evolution-groupwise-3.4.2.ebuild
new file mode 100644
index 000000000000..3c54cda02f07
--- /dev/null
+++ b/gnome-extra/evolution-groupwise/evolution-groupwise-3.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-groupwise/evolution-groupwise-3.4.2.ebuild,v 1.1 2012/06/24 08:44:54 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit db-use eutils flag-o-matic gnome2
+
+DESCRIPTION="Evolution module for connecting to Novell Groupwise"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="" # doc
+
+RDEPEND=">=mail-client/evolution-${PV}:2.0
+ >=gnome-extra/evolution-data-server-${PV}
+ >=dev-libs/glib-2.16
+ >=dev-libs/libxml2-2
+ >=gnome-base/gconf-2:2
+ gnome-extra/gtkhtml:4.0
+ >=net-libs/libsoup-2.3:2.4
+ sys-libs/db
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.90.4:3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+# For now, this package has no gtk-doc documentation to build
+# doc? ( >=dev-util/gtk-doc-1.9 )
+
+pkg_setup() {
+ DOCS="ChangeLog NEWS" # AUTHORS, README are empty
+}
+
+src_prepare() {
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ append-cppflags "-I$(db_includedir)"
+
+ gnome2_src_prepare
+}