summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-23 23:06:13 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-23 23:06:13 +0000
commitde5fd1548ab57b5c723af58acc181cc5e7352ecf (patch)
tree2f848514fd8c7ad7b746cb6556a1b44672657ee8 /gnome-base
parentRemoved old stable versions (diff)
downloadgentoo-2-de5fd1548ab57b5c723af58acc181cc5e7352ecf.tar.gz
gentoo-2-de5fd1548ab57b5c723af58acc181cc5e7352ecf.tar.bz2
gentoo-2-de5fd1548ab57b5c723af58acc181cc5e7352ecf.zip
Add patch to fix parallel make failure when USE=introspection; many thanks to Rafał Mużyło <galtgendo@o2.pl> for the solution (bug #391215). Should also fix bug #391213. Thanks to all for reporting.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/librsvg/ChangeLog8
-rw-r--r--gnome-base/librsvg/files/librsvg-2.34.2-gir-filename.patch39
-rw-r--r--gnome-base/librsvg/librsvg-2.34.2.ebuild5
3 files changed, 50 insertions, 2 deletions
diff --git a/gnome-base/librsvg/ChangeLog b/gnome-base/librsvg/ChangeLog
index cf8900c32440..dac1d9883859 100644
--- a/gnome-base/librsvg/ChangeLog
+++ b/gnome-base/librsvg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/librsvg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.260 2011/11/21 22:26:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.261 2011/11/23 23:06:13 tetromino Exp $
+
+ 23 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ librsvg-2.34.2.ebuild, +files/librsvg-2.34.2-gir-filename.patch:
+ Add patch to fix parallel make failure when USE=introspection; many thanks to
+ Rafał Mużyło <galtgendo@o2.pl> for the solution (bug #391215). Should also
+ fix bug #391213. Thanks to all for reporting.
21 Nov 2011; Pacho Ramos <pacho@gentoo.org> librsvg-2.34.2.ebuild:
Only pull in introspection.m4, not full gobject-introspection.
diff --git a/gnome-base/librsvg/files/librsvg-2.34.2-gir-filename.patch b/gnome-base/librsvg/files/librsvg-2.34.2-gir-filename.patch
new file mode 100644
index 000000000000..044fb7bd5375
--- /dev/null
+++ b/gnome-base/librsvg/files/librsvg-2.34.2-gir-filename.patch
@@ -0,0 +1,39 @@
+From c44813c1abb45467fa9e07bbde01d1fb09cae383 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 23 Nov 2011 17:41:12 -0500
+Subject: [PATCH] Use $RSVG_API_VERSION in the .gir filename
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+$RSVG_API_VERSION == "2.0"
+$RSVG_API_VERSION_U == "2_0"
+
+We want to use 2.0 when referring to the .gir filename, and 2_0 when
+referring to the automake targets derived from the filename. Otherwise,
+parallel make fails.
+
+Thanks to Rafał Mużyło <galtgendo@o2.pl> for pointing this out in
+https://bugs.gentoo.org/show_bug.cgi?id=391215#c10
+
+https://bugzilla.gnome.org/show_bug.cgi?id=664684
+---
+ Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 511df68..5a8dda3 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -235,7 +235,7 @@ INTROSPECTION_GIRS = Rsvg-@RSVG_API_VERSION@.gir
+ INTROSPECTION_SCANNER_ARGS = --add-include-path=$(srcdir)
+ INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir)
+
+-Rsvg-@RSVG_API_VERSION_U@.gir: librsvg-@RSVG_API_MAJOR_VERSION@.la
++Rsvg-@RSVG_API_VERSION@.gir: librsvg-@RSVG_API_MAJOR_VERSION@.la
+
+ Rsvg_@RSVG_API_VERSION_U@_gir_NAMESPACE = Rsvg
+ Rsvg_@RSVG_API_VERSION_U@_gir_EXPORT_PACKAGES = librsvg-$(RSVG_API_VERSION)
+--
+1.7.8.rc3
+
diff --git a/gnome-base/librsvg/librsvg-2.34.2.ebuild b/gnome-base/librsvg/librsvg-2.34.2.ebuild
index f734d27c9157..512724cc6c5b 100644
--- a/gnome-base/librsvg/librsvg-2.34.2.ebuild
+++ b/gnome-base/librsvg/librsvg-2.34.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.34.2.ebuild,v 1.3 2011/11/21 22:26:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.34.2.ebuild,v 1.4 2011/11/23 23:06:13 tetromino Exp $
EAPI="4"
GNOME2_LA_PUNT="yes"
@@ -56,6 +56,9 @@ src_prepare() {
# Fix automagic gtk+ dependency, bug #371290
epatch "${FILESDIR}/${PN}-2.34.0-automagic-gtk.patch"
+ # bug #391215, https://bugzilla.gnome.org/show_bug.cgi?id=664684
+ epatch "${FILESDIR}/${PN}-2.34.2-gir-filename.patch"
+
# introspection.m4 needed for eautoreconf
mv "${WORKDIR}/introspection.m4" "${S}"/ || die