summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-03-06 15:44:51 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-03-06 15:44:51 +0000
commitdab51c65c9f6a6c04a3bae75a7b11e9e415cf0d2 (patch)
tree181dc811b3f461cd8ed33a86b0b706008a4afc77 /gnome-base
parentApparently, I forgot to commit the removal of the ximian-connector mask... (diff)
downloadgentoo-2-dab51c65c9f6a6c04a3bae75a7b11e9e415cf0d2.tar.gz
gentoo-2-dab51c65c9f6a6c04a3bae75a7b11e9e415cf0d2.tar.bz2
gentoo-2-dab51c65c9f6a6c04a3bae75a7b11e9e415cf0d2.zip
Bump to 2.14.4
(Portage version: 2.1.2.1)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/orbit/ChangeLog7
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.14.43
-rw-r--r--gnome-base/orbit/orbit-2.14.4.ebuild44
3 files changed, 53 insertions, 1 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index ff895065e5bd..28fc23a4776c 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.87 2007/01/19 01:29:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.88 2007/03/06 15:44:51 dang Exp $
+
+*orbit-2.14.4 (06 Mar 2007)
+
+ 06 Mar 2007; Daniel Gryniewicz <dang@gentoo.org> +orbit-2.14.4.ebuild:
+ Bump to 2.14.4
19 Jan 2007; Jeroen Roovers <jer@gentoo.org> orbit-2.14.2.ebuild:
Stable for HPPA (bug #147751).
diff --git a/gnome-base/orbit/files/digest-orbit-2.14.4 b/gnome-base/orbit/files/digest-orbit-2.14.4
new file mode 100644
index 000000000000..f41ecea92b4a
--- /dev/null
+++ b/gnome-base/orbit/files/digest-orbit-2.14.4
@@ -0,0 +1,3 @@
+MD5 8379d4dab8cab57c51372ff4facbe5d6 ORBit2-2.14.4.tar.bz2 730450
+RMD160 17438324f8634734ac01d8db3f44a8500076c76e ORBit2-2.14.4.tar.bz2 730450
+SHA256 eb949b19a011fbac39f061df3ddbdfba7a34c1165d605d879705f87cff888089 ORBit2-2.14.4.tar.bz2 730450
diff --git a/gnome-base/orbit/orbit-2.14.4.ebuild b/gnome-base/orbit/orbit-2.14.4.ebuild
new file mode 100644
index 000000000000..0d9f71491933
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.4.ebuild,v 1.1 2007/03/06 15:44:51 dang Exp $
+
+inherit gnome2
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc ssl"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=dev-libs/libIDL-0.8.2
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+# FIXME ssl is optional, but not switchable
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}