summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-09-25 18:29:56 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-09-25 18:29:56 +0000
commit92c73cb3ecfed46f4cc6b937f608860d8310bf16 (patch)
tree85d788405539bf156cfff6b64a04f094ca9843b7 /gnome-base
parentsparc stable wrt #186674 (diff)
downloadgentoo-2-92c73cb3ecfed46f4cc6b937f608860d8310bf16.tar.gz
gentoo-2-92c73cb3ecfed46f4cc6b937f608860d8310bf16.tar.bz2
gentoo-2-92c73cb3ecfed46f4cc6b937f608860d8310bf16.zip
New series for Gnome 2.20
(Portage version: 2.1.3.9)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/ChangeLog5
-rw-r--r--gnome-base/gconf/files/digest-gconf-2.20.03
-rw-r--r--gnome-base/gconf/gconf-2.20.0.ebuild85
3 files changed, 92 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 096298f23f4e..fa8a8ace8414 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.170 2007/09/22 05:26:48 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.171 2007/09/25 18:29:55 dang Exp $
+
+ 25 Sep 2007; Daniel Gryniewicz <dang@gentoo.org> ChangeLog:
+ New series for Gnome 2.20
22 Sep 2007; Tom Gall <tgall@gentoo.org> gconf-2.18.0.1.ebuild:
stable on ppc64
diff --git a/gnome-base/gconf/files/digest-gconf-2.20.0 b/gnome-base/gconf/files/digest-gconf-2.20.0
new file mode 100644
index 000000000000..9d9173c107fa
--- /dev/null
+++ b/gnome-base/gconf/files/digest-gconf-2.20.0
@@ -0,0 +1,3 @@
+MD5 a6d82dee79df11b6e38b19cb42197d32 GConf-2.20.0.tar.bz2 1403455
+RMD160 54948f0df79fa1bd68cebb5aae97cace0c21d642 GConf-2.20.0.tar.bz2 1403455
+SHA256 171b077190db67073379d464fa45ceacfcbe099a5c6c6c80ce5cd31ec665ab06 GConf-2.20.0.tar.bz2 1403455
diff --git a/gnome-base/gconf/gconf-2.20.0.ebuild b/gnome-base/gconf/gconf-2.20.0.ebuild
new file mode 100644
index 000000000000..f52b5f234fb6
--- /dev/null
+++ b/gnome-base/gconf/gconf-2.20.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.20.0.ebuild,v 1.1 2007/09/25 18:29:55 dang Exp $
+
+inherit gnome2
+
+MY_PN=GConf
+MY_P=${MY_PN}-${PV}
+PVP=(${PV//[-\._]/ })
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.8.16
+ >=gnome-base/orbit-2.4
+ >=dev-libs/libxml2-2"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+# FIXME : consider merging the tree (?)
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-gtk $(use_enable debug)"
+ kill_gconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ # hack hack
+ dodir /etc/gconf/gconf.xml.mandatory
+ dodir /etc/gconf/gconf.xml.defaults
+ touch "${D}"/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
+ touch "${D}"/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ doenvd 50gconf || die
+ dodir /root/.gconfd
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ #change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}
+
+kill_gconf() {
+ # this function will kill all running gconfd that could be causing troubles
+ if [ -x /usr/bin/gconftool ]
+ then
+ /usr/bin/gconftool --shutdown
+ fi
+ if [ -x /usr/bin/gconftool-1 ]
+ then
+ /usr/bin/gconftool-1 --shutdown
+ fi
+
+ # and for gconf 2
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+ return 0
+}