summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-02-17 00:49:28 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-02-17 00:49:28 +0000
commit242b0eba2776a38cbba57502f5bde65be02538d7 (patch)
tree65b2e247bc3d40a754a13ec13d84490cd227189f /gnome-base
parentrevbump; convert -> distutils-r1, rm old (diff)
downloadgentoo-2-242b0eba2776a38cbba57502f5bde65be02538d7.tar.gz
gentoo-2-242b0eba2776a38cbba57502f5bde65be02538d7.tar.bz2
gentoo-2-242b0eba2776a38cbba57502f5bde65be02538d7.zip
Fix file collision with new sys-devel/autoconf-archive versions; USE=autoconf-archive pulls in autoconf-archive as a dependency, USE=-autoconf-archive blocks it (bug #540138, thanks to Priit Laes et al).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-common/ChangeLog12
-rw-r--r--gnome-base/gnome-common/gnome-common-3.14.0-r1.ebuild30
-rw-r--r--gnome-base/gnome-common/gnome-common-3.14.0.ebuild7
-rw-r--r--gnome-base/gnome-common/metadata.xml4
4 files changed, 49 insertions, 4 deletions
diff --git a/gnome-base/gnome-common/ChangeLog b/gnome-base/gnome-common/ChangeLog
index 3e4a15d5e802..2e3c7bd5e635 100644
--- a/gnome-base/gnome-common/ChangeLog
+++ b/gnome-base/gnome-common/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gnome-common
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-common/ChangeLog,v 1.143 2014/12/22 21:18:21 eva Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-common/ChangeLog,v 1.144 2015/02/17 00:49:28 tetromino Exp $
+
+*gnome-common-3.14.0-r1 (17 Feb 2015)
+
+ 17 Feb 2015; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gnome-common-3.14.0.ebuild, +gnome-common-3.14.0-r1.ebuild, metadata.xml:
+ Fix file collision with new sys-devel/autoconf-archive versions;
+ USE=autoconf-archive pulls in autoconf-archive as a dependency,
+ USE=-autoconf-archive blocks it (bug #540138, thanks to Priit Laes et al).
*gnome-common-3.14.0 (22 Dec 2014)
diff --git a/gnome-base/gnome-common/gnome-common-3.14.0-r1.ebuild b/gnome-base/gnome-common/gnome-common-3.14.0-r1.ebuild
new file mode 100644
index 000000000000..bebbd8ca8d49
--- /dev/null
+++ b/gnome-base/gnome-common/gnome-common-3.14.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-common/gnome-common-3.14.0-r1.ebuild,v 1.1 2015/02/17 00:49:28 tetromino Exp $
+
+EAPI="5"
+
+inherit gnome.org
+
+DESCRIPTION="Common files for development of Gnome packages"
+HOMEPAGE="http://git.gnome.org/browse/gnome-common"
+
+LICENSE="GPL-3"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+autoconf-archive"
+
+RDEPEND="autoconf-archive? ( >=sys-devel/autoconf-archive-2015.02.04 )
+ !autoconf-archive? ( !>=sys-devel/autoconf-archive-2015.02.04 )
+"
+DEPEND=""
+
+src_install() {
+ default
+ if use autoconf-archive; then
+ # do not install macros owned by autoconf-archive, bug #540138
+ rm "${ED}"/usr/share/aclocal/ax_{check_enable_debug,code_coverage}.m4 || die "removing macros failed"
+ fi
+ mv doc-build/README README.doc-build || die "renaming doc-build/README failed"
+ dodoc ChangeLog README*
+}
diff --git a/gnome-base/gnome-common/gnome-common-3.14.0.ebuild b/gnome-base/gnome-common/gnome-common-3.14.0.ebuild
index 71019d1de8e8..36c037ae9d93 100644
--- a/gnome-base/gnome-common/gnome-common-3.14.0.ebuild
+++ b/gnome-base/gnome-common/gnome-common-3.14.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-common/gnome-common-3.14.0.ebuild,v 1.1 2014/12/22 21:18:21 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-common/gnome-common-3.14.0.ebuild,v 1.2 2015/02/17 00:49:28 tetromino Exp $
EAPI="5"
@@ -14,6 +14,9 @@ SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE=""
+RDEPEND="!>=sys-devel/autoconf-archive-2015.02.04"
+DEPEND=""
+
src_install() {
default
mv doc-build/README README.doc-build || die "renaming doc-build/README failed"
diff --git a/gnome-base/gnome-common/metadata.xml b/gnome-base/gnome-common/metadata.xml
index da6fd63d0085..4a4731d98a3f 100644
--- a/gnome-base/gnome-common/metadata.xml
+++ b/gnome-base/gnome-common/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gnome</herd>
+<use>
+ <flag name="autoconf-archive">Pull in <pkg>sys-devel/autoconf-archive</pkg> for ax_*.m4 files
+ instead of installing them from the gnome-common tarball</flag>
+</use>
</pkgmetadata>