summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2005-04-19 23:18:36 +0000
committerHerbie Hopkins <herbs@gentoo.org>2005-04-19 23:18:36 +0000
commit902b3adc1cf9f5eec0ba0cdc7a853b7458dba81e (patch)
tree800bd6caa7c9337ac6256214249551bc48e569ee /gnome-base/orbit/orbit-0.5.17.ebuild
parentlibcdio-0.70 stable on amd64. (diff)
downloadgentoo-2-902b3adc1cf9f5eec0ba0cdc7a853b7458dba81e.tar.gz
gentoo-2-902b3adc1cf9f5eec0ba0cdc7a853b7458dba81e.tar.bz2
gentoo-2-902b3adc1cf9f5eec0ba0cdc7a853b7458dba81e.zip
Fixed multilib-strict issue.
(Portage version: 2.0.51.19)
Diffstat (limited to 'gnome-base/orbit/orbit-0.5.17.ebuild')
-rw-r--r--gnome-base/orbit/orbit-0.5.17.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnome-base/orbit/orbit-0.5.17.ebuild b/gnome-base/orbit/orbit-0.5.17.ebuild
index 4b4ccb712cbc..9e7b5a3dd8f1 100644
--- a/gnome-base/orbit/orbit-0.5.17.ebuild
+++ b/gnome-base/orbit/orbit-0.5.17.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-0.5.17.ebuild,v 1.5 2005/01/08 23:35:35 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-0.5.17.ebuild,v 1.6 2005/04/19 23:18:36 herbs Exp $
-inherit gnome.org libtool gnuconfig
+inherit gnome.org libtool gnuconfig multilib
MY_P="ORBit-${PV}"
PVP=(${PV//[-\._]/ })
@@ -32,6 +32,7 @@ src_compile() {
./configure --host=${CHOST} \
--prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
--infodir=/usr/share/info \
--sysconfdir=/etc \
--localstatedir=/var/lib \
@@ -42,6 +43,7 @@ src_compile() {
src_install() {
make prefix=${D}/usr \
+ libdir=${D}/usr/$(get_libdir) \
sysconfdir=${D}/etc \
infodir=${D}/usr/share/info \
localstatedir=${D}/var/lib \
@@ -58,6 +60,6 @@ src_install() {
cd ../popt
dodoc CHANGES COPYING README
- cd ${D}/usr/lib
- patch -p0 < ${FILESDIR}/libIDLConf.sh-gentoo.diff
+ sed -i -e 's:-I/usr/include":-I/usr/include/libIDL-1.0":' \
+ ${D}/usr/$(get_libdir)/libIDLConf.sh || die
}