summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-16 21:29:05 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-16 21:29:05 +0000
commit27c3cd43b7f32f2ddc4cc7537437175df8d3cc8e (patch)
treed115c2f8505bef4b2e23a0954ae77f9b5cbdf939 /gnome-base/bonobo
parentadded ebuild from Tod (diff)
downloadgentoo-2-27c3cd43b7f32f2ddc4cc7537437175df8d3cc8e.tar.gz
gentoo-2-27c3cd43b7f32f2ddc4cc7537437175df8d3cc8e.tar.bz2
gentoo-2-27c3cd43b7f32f2ddc4cc7537437175df8d3cc8e.zip
fix permissions on libefs.pc
Diffstat (limited to 'gnome-base/bonobo')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.18-r1.ebuild55
-rw-r--r--gnome-base/bonobo/files/digest-bonobo-1.0.18-r11
2 files changed, 56 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.18-r1.ebuild b/gnome-base/bonobo/bonobo-1.0.18-r1.ebuild
new file mode 100644
index 000000000000..e05b96ac18f4
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.18-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.18-r1.ebuild,v 1.1 2002/01/16 21:29:05 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+
+RDEPEND=">=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/perl
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags print`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # make -j 4 didn't work
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ chmod 644 ${D}/usr/lib/pkgconfig/libefs.pc
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
diff --git a/gnome-base/bonobo/files/digest-bonobo-1.0.18-r1 b/gnome-base/bonobo/files/digest-bonobo-1.0.18-r1
new file mode 100644
index 000000000000..bba5e579cafc
--- /dev/null
+++ b/gnome-base/bonobo/files/digest-bonobo-1.0.18-r1
@@ -0,0 +1 @@
+MD5 40a0328bc525038129b9409861b94c8f bonobo-1.0.18.tar.gz 1282048