summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-02-13 16:56:54 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-02-13 16:56:54 +0000
commitb5a1b37154b402191ef2c9f22dc11154555a3b9e (patch)
treea88545e45e855655bcfc83789ffd67e3ba268f52 /gnome-base/bonobo/bonobo-1.0.19.ebuild
parentNew version. Removed gnome-libs dependency because it really shouldn't be th... (diff)
downloadgentoo-2-b5a1b37154b402191ef2c9f22dc11154555a3b9e.tar.gz
gentoo-2-b5a1b37154b402191ef2c9f22dc11154555a3b9e.tar.bz2
gentoo-2-b5a1b37154b402191ef2c9f22dc11154555a3b9e.zip
New version.
Diffstat (limited to 'gnome-base/bonobo/bonobo-1.0.19.ebuild')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.19.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.19.ebuild b/gnome-base/bonobo/bonobo-1.0.19.ebuild
new file mode 100644
index 000000000000..1eac960a2706
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.19.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.19.ebuild,v 1.1 2002/02/13 16:56:54 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+
+RDEPEND=">=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/perl
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags print`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # make -j 4 didn't work
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ chmod 644 ${D}/usr/lib/pkgconfig/libefs.pc
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+