summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-03-10 13:09:23 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-03-10 13:09:23 +0000
commitca2677338c0e6c2db2414d878ad76057fe24e2e1 (patch)
tree8d821be02a8a2be24278e5d61aa3b5915d55a14e /games-util
parentFix HOMEPAGE, thanks to corsair for noticing this, bug 170236 (diff)
downloadgentoo-2-ca2677338c0e6c2db2414d878ad76057fe24e2e1.tar.gz
gentoo-2-ca2677338c0e6c2db2414d878ad76057fe24e2e1.tar.bz2
gentoo-2-ca2677338c0e6c2db2414d878ad76057fe24e2e1.zip
Version bump to 0.3.1
(Portage version: 2.1.2-r9)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/atlas/ChangeLog9
-rw-r--r--games-util/atlas/atlas-0.3.1.ebuild60
-rw-r--r--games-util/atlas/files/digest-atlas-0.3.13
3 files changed, 70 insertions, 2 deletions
diff --git a/games-util/atlas/ChangeLog b/games-util/atlas/ChangeLog
index e84f0457dc44..a0768f9c357a 100644
--- a/games-util/atlas/ChangeLog
+++ b/games-util/atlas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/atlas
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.11 2006/12/06 21:14:26 wolf31o2 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/ChangeLog,v 1.12 2007/03/10 13:09:23 tupone Exp $
+
+*atlas-0.3.1 (10 Mar 2007)
+
+ 10 Mar 2007; <tupone@gentoo.org> +atlas-0.3.1.ebuild:
+ Version bump to 0.3.1
06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> atlas-0.3.0.ebuild:
Remove old virtual/x11 dependency.
diff --git a/games-util/atlas/atlas-0.3.1.ebuild b/games-util/atlas/atlas-0.3.1.ebuild
new file mode 100644
index 000000000000..ce86bd694898
--- /dev/null
+++ b/games-util/atlas/atlas-0.3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/atlas/atlas-0.3.1.ebuild,v 1.1 2007/03/10 13:09:23 tupone Exp $
+
+inherit eutils games
+
+MY_P="Atlas-${PV}"
+DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
+HOMEPAGE="http://atlas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atlas/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=games-simulation/flightgear-0.9.4
+ >=media-libs/libpng-1.2.5
+ media-libs/jpeg
+ x11-libs/libXi
+ x11-libs/libXmu"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ egamesconf --with-fgbase="${GAMES_DATADIR}/FlightGear" \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ insinto ${GAMES_DATADIR}/FlightGear
+ doins "${S}/src/AtlasPalette" || die "doins failed"
+ keepdir "${GAMES_DATADIR}/FlightGear/Atlas/lowres"
+ dodoc AUTHORS NEWS README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ einfo "You now can make the maps with the following commands:"
+ einfo "${GAMES_BINDIR}/Map --atlas=${GAMES_DATADIR}/FlightGear/Atlas"
+ einfo "${GAMES_BINDIR}/Map --atlas=${GAMES_DATADIR}/FlightGear/Atlas/lowres --size=64"
+ echo
+ einfo "To run Atlas concurrently with FlightGear use the following:"
+ einfo "Atlas --path=[path of map images] --udp=[port number]"
+ einfo "and start fgfs with the following switch (or in .fgfsrc):"
+ einfo "--nmea=socket,out,0.5,[host that you run Atlas on],[port number],udp"
+ echo
+}
+
+pkg_postrm() {
+ einfo "You must manually remove the maps if you don't want them around."
+ einfo "They are found in the following directory:"
+ echo
+ einfo "${GAMES_DATADIR}/FlightGear/Atlas"
+ echo
+}
diff --git a/games-util/atlas/files/digest-atlas-0.3.1 b/games-util/atlas/files/digest-atlas-0.3.1
new file mode 100644
index 000000000000..c221a24f1769
--- /dev/null
+++ b/games-util/atlas/files/digest-atlas-0.3.1
@@ -0,0 +1,3 @@
+MD5 15bba54523a29928a14f17af449f960e Atlas-0.3.1.tar.gz 184857
+RMD160 9f84a2e331ebc6eb7e84f256a13c845007a4679c Atlas-0.3.1.tar.gz 184857
+SHA256 a264edd2b668b96472ca80c0525a2b7ffac33b02a70333bf01fd93714b7f111a Atlas-0.3.1.tar.gz 184857