summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-16 06:25:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-16 06:25:00 +0000
commitc23bea91a66642e025b96330e19c1214c3760196 (patch)
treed76d1d2f188fc06f3ac52f54148c4dbc5d565c71 /games-util
parentAdd ruby22. (diff)
downloadgentoo-2-c23bea91a66642e025b96330e19c1214c3760196.tar.gz
gentoo-2-c23bea91a66642e025b96330e19c1214c3760196.tar.bz2
gentoo-2-c23bea91a66642e025b96330e19c1214c3760196.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/glbsp/ChangeLog7
-rw-r--r--games-util/glbsp/glbsp-2.24.ebuild30
2 files changed, 19 insertions, 18 deletions
diff --git a/games-util/glbsp/ChangeLog b/games-util/glbsp/ChangeLog
index 55289575cb4b..8ccb01ac3aaa 100644
--- a/games-util/glbsp/ChangeLog
+++ b/games-util/glbsp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-util/glbsp
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/glbsp/ChangeLog,v 1.13 2011/03/20 20:15:44 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/glbsp/ChangeLog,v 1.14 2015/02/16 06:25:00 mr_bones_ Exp $
+
+ 16 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> glbsp-2.24.ebuild:
+ EAPI=5
20 Mar 2011; Justin Lecher <jlec@gentoo.org> glbsp-2.24.ebuild:
x11-libs/fltk SLOTMOVE 1.1 -> 1, corrected ebuild accordingly
diff --git a/games-util/glbsp/glbsp-2.24.ebuild b/games-util/glbsp/glbsp-2.24.ebuild
index a6665d620053..91af9679abb9 100644
--- a/games-util/glbsp/glbsp-2.24.ebuild
+++ b/games-util/glbsp/glbsp-2.24.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/glbsp/glbsp-2.24.ebuild,v 1.4 2011/03/20 20:15:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/glbsp/glbsp-2.24.ebuild,v 1.5 2015/02/16 06:25:00 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils toolchain-funcs versionator
MY_PV=$(delete_version_separator 1)
@@ -16,6 +16,7 @@ KEYWORDS="~amd64 ~ppc x86"
IUSE="fltk"
DEPEND="fltk? ( x11-libs/fltk:1 )"
+RDEPEND=${DEPEND}
S=${WORKDIR}/${P}-source
@@ -29,39 +30,36 @@ src_prepare() {
-e "s:-O2:${CFLAGS}:" \
-e "s:-O -g3:${CFLAGS}:" \
Makefile.unx \
- nodeview/Makefile.unx \
- || die "sed failed"
+ nodeview/Makefile.unx || die
}
src_compile() {
- emake -f Makefile.unx || die "emake failed"
+ emake -f Makefile.unx
if use fltk ; then
emake -f Makefile.unx glBSPX \
FLTK_FLAGS="$(fltk-config --cflags)" \
- FLTK_LIBS="$(fltk-config --use-images --ldflags)" \
- || die "emake failed"
+ FLTK_LIBS="$(fltk-config --use-images --ldflags)"
emake -f Makefile.unx -C nodeview \
FLTK_CFLAGS="$(fltk-config --cflags)" \
- FLTK_LIBS="$(fltk-config --use-images --ldflags)" \
- || die "emake failed"
+ FLTK_LIBS="$(fltk-config --use-images --ldflags)"
fi
}
src_install() {
- dobin glbsp || die "dobin failed"
- dolib.a libglbsp.a || die "dolib.a failed"
+ dobin glbsp
+ dolib.a libglbsp.a
doman glbsp.1
dodoc AUTHORS.txt glbsp.txt
insinto "/usr/include"
- doins "src/glbsp.h" || die "doins failed"
+ doins "src/glbsp.h"
if use fltk ; then
- newbin glBSPX glbspx || die "newbin failed"
+ newbin glBSPX glbspx
newicon gui/icon.xpm glbspx.xpm
make_desktop_entry glbspx glBSPX glbspx
- dobin nodeview/nodeview || die "dobin failed"
+ dobin nodeview/nodeview
docinto nodeview
- dodoc nodeview/{README,TODO}.txt || die "dodoc failed"
+ dodoc nodeview/{README,TODO}.txt
fi
}