summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-13 06:11:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-13 06:11:31 +0000
commit8451d21cc8325d0e9d63f789e10b442e2426eebd (patch)
treebd0b78024175f163cf23201a74640a5481964de5 /games-util
parentuse epatch instead of sed (diff)
downloadgentoo-2-8451d21cc8325d0e9d63f789e10b442e2426eebd.tar.gz
gentoo-2-8451d21cc8325d0e9d63f789e10b442e2426eebd.tar.bz2
gentoo-2-8451d21cc8325d0e9d63f789e10b442e2426eebd.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/showeq/ChangeLog8
-rw-r--r--games-util/showeq/showeq-5.12.4.2.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/games-util/showeq/ChangeLog b/games-util/showeq/ChangeLog
index 9d9ef680df05..14eb0e79c48c 100644
--- a/games-util/showeq/ChangeLog
+++ b/games-util/showeq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/showeq
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/ChangeLog,v 1.24 2008/07/27 21:39:23 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/ChangeLog,v 1.25 2008/08/13 06:11:31 mr_bones_ Exp $
+
+*showeq-5.12.4.2 (13 Aug 2008)
+
+ 13 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +showeq-5.12.4.2.ebuild:
+ version bump
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> showeq-5.0.0.18.ebuild,
showeq-5.12.0.0.ebuild, showeq-5.12.1.0.ebuild:
diff --git a/games-util/showeq/showeq-5.12.4.2.ebuild b/games-util/showeq/showeq-5.12.4.2.ebuild
new file mode 100644
index 000000000000..84c516a31699
--- /dev/null
+++ b/games-util/showeq/showeq-5.12.4.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/showeq-5.12.4.2.ebuild,v 1.1 2008/08/13 06:11:31 mr_bones_ Exp $
+
+EAPI=1
+inherit eutils qt3 games
+
+DESCRIPTION="An Everquest monitoring program"
+HOMEPAGE="http://www.showeq.net/"
+SRC_URI="mirror://sourceforge/seq/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/libpcap
+ x11-libs/qt:3"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --disable-optimization \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman showeq.1
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README ROADMAP TODO doc/*.{doc,txt}
+ dohtml doc/map.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "For complete functionality, download and extract the following"
+ elog "files into ${GAMES_DATADIR}/${PN}"
+ elog
+ elog "http://patch.everquest.com:7000/patch/everquest/main/eqstr_us.txt.gz"
+ elog "http://patch.everquest.com:7000/patch/everquest/main/spells_us.txt.gz"
+ elog
+ elog "or simply run the following commands..."
+ elog " cd ${GAMES_DATADIR}/${PN}"
+ elog " for i in eqstr_us.txt spells_us.txt; do"
+ elog " wget --user-agent=SOEPatcher/curl \\"
+ elog " http://patch.everquest.com:7000/patch/everquest/main/\${i}.gz"
+ elog " gunzip \${i}.gz"
+ elog " done"
+ echo
+}