summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-03-06 23:50:22 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-03-06 23:50:22 +0000
commit303b25c183892f020b35b48151f3a6519bed8895 (patch)
tree81bfe4084d072297a00c32e4ca0b2af7a4611cf8 /games-util/mcrcon
parentamd64 stable, bug #540290 (diff)
downloadgentoo-2-303b25c183892f020b35b48151f3a6519bed8895.tar.gz
gentoo-2-303b25c183892f020b35b48151f3a6519bed8895.tar.bz2
gentoo-2-303b25c183892f020b35b48151f3a6519bed8895.zip
Initial import.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'games-util/mcrcon')
-rw-r--r--games-util/mcrcon/ChangeLog9
-rw-r--r--games-util/mcrcon/mcrcon-0.0.5.ebuild27
-rw-r--r--games-util/mcrcon/metadata.xml9
3 files changed, 45 insertions, 0 deletions
diff --git a/games-util/mcrcon/ChangeLog b/games-util/mcrcon/ChangeLog
new file mode 100644
index 000000000000..2dff19ac8346
--- /dev/null
+++ b/games-util/mcrcon/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-util/mcrcon
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/mcrcon/ChangeLog,v 1.1 2015/03/06 23:50:22 chewi Exp $
+
+*mcrcon-0.0.5 (06 Mar 2015)
+
+ 06 Mar 2015; James Le Cuirot <chewi@gentoo.org> +mcrcon-0.0.5.ebuild,
+ +metadata.xml:
+ Initial import.
diff --git a/games-util/mcrcon/mcrcon-0.0.5.ebuild b/games-util/mcrcon/mcrcon-0.0.5.ebuild
new file mode 100644
index 000000000000..ebc21c2995d4
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/mcrcon/mcrcon-0.0.5.ebuild,v 1.1 2015/03/06 23:50:22 chewi Exp $
+
+EAPI=5
+
+inherit toolchain-funcs games
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="http://sourceforge.net/projects/mcrcon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ # Flags taken from COMPILING.txt.
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -std=gnu11 -pedantic -Wall -Wextra -o "${PN}" "${PN}.c" || die
+}
+
+src_install() {
+ dogamesbin "${PN}"
+ dodoc README.txt
+}
diff --git a/games-util/mcrcon/metadata.xml b/games-util/mcrcon/metadata.xml
new file mode 100644
index 000000000000..5ab4da9f2d75
--- /dev/null
+++ b/games-util/mcrcon/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <longdescription>mcrcon is an IPv6 compliant Minecraft rcon client with Bukkit coloring support. It is well suited for remote administration and to be used as part of automated server maintenance scripts. Does not trigger the "IO: Broken pipe" or "IO: Connection reset" spam bug on the server side.</longdescription>
+</pkgmetadata>