summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-12-22 04:22:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-12-22 04:22:38 +0000
commiteb9e592a9fc1d75eafe523661cdea979207d33f6 (patch)
tree3166676b300187faaa1bf41e958abaa7b9c4819d /games-strategy
parentversion bump; also addresses bug #293126 (diff)
downloadgentoo-2-eb9e592a9fc1d75eafe523661cdea979207d33f6.tar.gz
gentoo-2-eb9e592a9fc1d75eafe523661cdea979207d33f6.tar.bz2
gentoo-2-eb9e592a9fc1d75eafe523661cdea979207d33f6.zip
add patch for working around define issues again (bug #297227)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/scorched3d/ChangeLog6
-rw-r--r--games-strategy/scorched3d/files/scorched3d-42.1-win32.patch19
2 files changed, 24 insertions, 1 deletions
diff --git a/games-strategy/scorched3d/ChangeLog b/games-strategy/scorched3d/ChangeLog
index aeafaa971a74..ed5d45c6e99a 100644
--- a/games-strategy/scorched3d/ChangeLog
+++ b/games-strategy/scorched3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/scorched3d
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.65 2009/11/12 17:40:53 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/ChangeLog,v 1.66 2009/12/22 04:22:38 mr_bones_ Exp $
+
+ 22 Dec 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/scorched3d-42.1-win32.patch:
+ add patch for working around define issues again (bug #297227)
12 Nov 2009; Mounir Lamouri <volkmar@gentoo.org> scorched3d-42.1.ebuild:
Stable for ppc, bug 285384
diff --git a/games-strategy/scorched3d/files/scorched3d-42.1-win32.patch b/games-strategy/scorched3d/files/scorched3d-42.1-win32.patch
new file mode 100644
index 000000000000..8b63d509147c
--- /dev/null
+++ b/games-strategy/scorched3d/files/scorched3d-42.1-win32.patch
@@ -0,0 +1,19 @@
+diff -ur scorched.old/src/common/porting/windows.h scorched/src/common/porting/windows.h
+--- scorched.old/src/common/porting/windows.h 2009-12-17 15:18:41.000000000 +0200
++++ scorched/src/common/porting/windows.h 2009-12-17 15:22:20.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include <ctype.h>
+ #include <common/Defines.h>
+
++#ifdef _WIN32
+ typedef char * LPSTR;
+ typedef const char * LPCTSTR;
+ typedef unsigned int DWORD;
+@@ -27,6 +28,7 @@
+ typedef int LRESULT;
+ typedef void * HDC;
+ typedef void * HGLRC;
++#endif /* _WIN32 */
+
+ #define _strnicmp(a,b,c) strncasecmp(a,b,c)
+ #define stricmp(a,b) strcasecmp(a,b)