summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-09-23 07:46:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-09-23 07:46:51 +0000
commite63f49a867bd3e7a9a64e0244b8cb2b7ff2b940b (patch)
tree8e16c4490fb68f7c191dc69f9571cb9989ac799c /games-strategy
parenttypo fix (diff)
downloadgentoo-2-e63f49a867bd3e7a9a64e0244b8cb2b7ff2b940b.tar.gz
gentoo-2-e63f49a867bd3e7a9a64e0244b8cb2b7ff2b940b.tar.bz2
gentoo-2-e63f49a867bd3e7a9a64e0244b8cb2b7ff2b940b.zip
old
(Portage version: 2.1.3.9)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.2.43
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.2.53
-rw-r--r--games-strategy/wesnoth/wesnoth-1.2.4.ebuild96
-rw-r--r--games-strategy/wesnoth/wesnoth-1.2.5.ebuild96
4 files changed, 0 insertions, 198 deletions
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.2.4 b/games-strategy/wesnoth/files/digest-wesnoth-1.2.4
deleted file mode 100644
index 77d0306b1a49..000000000000
--- a/games-strategy/wesnoth/files/digest-wesnoth-1.2.4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e24c9adb2fa6cc25759a0a1baf0585e8 wesnoth-1.2.4.tar.bz2 68604047
-RMD160 a5164efb8918e1f9d06dc868af1a86d294cb82bb wesnoth-1.2.4.tar.bz2 68604047
-SHA256 f87e0716f93da56b4c918a0150e865ed310848d7dc4f893e7fe6bd378f616163 wesnoth-1.2.4.tar.bz2 68604047
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.2.5 b/games-strategy/wesnoth/files/digest-wesnoth-1.2.5
deleted file mode 100644
index a6d03f8d79e3..000000000000
--- a/games-strategy/wesnoth/files/digest-wesnoth-1.2.5
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 40e00ac97680fb69499191c30f130774 wesnoth-1.2.5.tar.bz2 68758427
-RMD160 eeae92b801a3d3885b6647965537ff045d93d4a7 wesnoth-1.2.5.tar.bz2 68758427
-SHA256 8e1bcab7165bd5eaf8c1d2eef0fce03a8c81daf885983dc0fda68998100e8cd0 wesnoth-1.2.5.tar.bz2 68758427
diff --git a/games-strategy/wesnoth/wesnoth-1.2.4.ebuild b/games-strategy/wesnoth/wesnoth-1.2.4.ebuild
deleted file mode 100644
index 4c6ad6d5493e..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.2.4.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.2.4.ebuild,v 1.1 2007/04/16 04:57:17 mr_bones_ Exp $
-
-inherit eutils toolchain-funcs flag-o-matic games
-
-MY_PV=${PV/_/}
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="dedicated editor gnome kde lite nls server tools"
-
-RDEPEND=">=media-libs/libsdl-1.2.7
- !dedicated? (
- x11-libs/libX11
- >=media-libs/freetype-2 )
- >=media-libs/sdl-mixer-1.2
- >=media-libs/sdl-image-1.2
- media-libs/sdl-net
- nls? ( virtual/libintl )"
-# the configure script is broken and checks for freetype even if
-# it won't be used. until it's either patched out or upstream fixes
-# it, just make it a DEPEND.
-# reported by Miika Linnapuomi
-DEPEND="${RDEPEND}
- dedicated? ( >=media-libs/freetype-2 )
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-pkg_setup() {
- if ! built_with_use media-libs/sdl-mixer vorbis ; then
- die "Please emerge media-libs/sdl-mixer with USE=vorbis"
- fi
- if ! built_with_use media-libs/sdl-image png ; then
- die "Please emerge media-libs/sdl-image with USE=png"
- fi
- if ! built_with_use media-libs/libsdl X ; then
- die "Please emerge media-libs/libsdl with USE=X"
- fi
- games_pkg_setup
-}
-
-src_unpack() {
- unpack "${A}"
- if use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd \
- || die "sed failed"
- fi
-}
-
-src_compile() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- egamesconf \
- --disable-dependency-tracking \
- --without-fribidi \
- --with-localedir=/usr/share/locale \
- --with-icondir=/usr/share/icons \
- --with-desktopdir=/usr/share/applications \
- $(use_enable lite) \
- $(use_enable server) \
- $(use_enable server campaign-server) \
- $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
- $(use_enable editor) \
- $(use_enable tools) \
- $(use_enable nls) \
- $(use_enable nls dummy-locales) \
- $(use_enable !dedicated game) \
- $(use_with gnome) \
- $(use_with kde) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc MANUAL changelog
- if use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd || die "doinitd failed"
- fi
- prepgamesdirs
-}
diff --git a/games-strategy/wesnoth/wesnoth-1.2.5.ebuild b/games-strategy/wesnoth/wesnoth-1.2.5.ebuild
deleted file mode 100644
index 3f98a5dc321b..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.2.5.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.2.5.ebuild,v 1.5 2007/07/28 00:34:56 wolf31o2 Exp $
-
-inherit eutils toolchain-funcs flag-o-matic games
-
-MY_PV=${PV/_/}
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org/"
-SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="dedicated editor gnome kde lite nls server tools"
-
-RDEPEND=">=media-libs/libsdl-1.2.7
- !dedicated? (
- x11-libs/libX11
- >=media-libs/freetype-2 )
- >=media-libs/sdl-mixer-1.2
- >=media-libs/sdl-image-1.2
- media-libs/sdl-net
- nls? ( virtual/libintl )"
-# the configure script is broken and checks for freetype even if
-# it won't be used. until it's either patched out or upstream fixes
-# it, just make it a DEPEND.
-# reported by Miika Linnapuomi
-DEPEND="${RDEPEND}
- dedicated? ( >=media-libs/freetype-2 )
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-pkg_setup() {
- if ! built_with_use media-libs/sdl-mixer vorbis ; then
- die "Please emerge media-libs/sdl-mixer with USE=vorbis"
- fi
- if ! built_with_use media-libs/sdl-image png ; then
- die "Please emerge media-libs/sdl-image with USE=png"
- fi
- if ! built_with_use media-libs/libsdl X ; then
- die "Please emerge media-libs/libsdl with USE=X"
- fi
- games_pkg_setup
-}
-
-src_unpack() {
- unpack "${A}"
- if use server ; then
- sed \
- -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
- -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
- -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
- > "${T}"/wesnothd \
- || die "sed failed"
- fi
-}
-
-src_compile() {
- filter-flags -ftracer -fomit-frame-pointer
- if [[ $(gcc-major-version) -eq 3 ]] ; then
- filter-flags -fstack-protector
- append-flags -fno-stack-protector
- fi
- egamesconf \
- --disable-dependency-tracking \
- --without-fribidi \
- --with-localedir=/usr/share/locale \
- --with-icondir=/usr/share/icons \
- --with-desktopdir=/usr/share/applications \
- $(use_enable lite) \
- $(use_enable server) \
- $(use_enable server campaign-server) \
- $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
- $(use_enable editor) \
- $(use_enable tools) \
- $(use_enable nls) \
- $(use_enable nls dummy-locales) \
- $(use_enable !dedicated game) \
- $(use_with gnome) \
- $(use_with kde) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc MANUAL changelog
- if use server; then
- keepdir "${GAMES_STATEDIR}/run/wesnothd"
- doinitd "${T}"/wesnothd || die "doinitd failed"
- fi
- prepgamesdirs
-}