summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-02 15:27:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-02 15:27:10 +0000
commitd7d76481c9a8a7d8b542b633f263ec6abbc8012d (patch)
tree51caa94974303a800e670e8c25a4511fd72a1e46 /games-strategy
parent4.7.0.4 version bump (diff)
downloadgentoo-2-d7d76481c9a8a7d8b542b633f263ec6abbc8012d.tar.gz
gentoo-2-d7d76481c9a8a7d8b542b633f263ec6abbc8012d.tar.bz2
gentoo-2-d7d76481c9a8a7d8b542b633f263ec6abbc8012d.zip
Clamp amd64 to the one version of boost that works for them.
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog5
-rw-r--r--games-strategy/wesnoth/wesnoth-1.8.ebuild16
2 files changed, 15 insertions, 6 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 078f2c4249e2..103c71da7f9e 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.174 2010/03/27 22:34:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.175 2010/04/02 15:27:10 mr_bones_ Exp $
+
+ 02 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.8.ebuild:
+ Clamp amd64 to the one version of boost that works for them.
27 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.8.ebuild:
correct boost:0 handling (bug #311635)
diff --git a/games-strategy/wesnoth/wesnoth-1.8.ebuild b/games-strategy/wesnoth/wesnoth-1.8.ebuild
index 2410d7658ed7..5b4f87c1736b 100644
--- a/games-strategy/wesnoth/wesnoth-1.8.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.8.ebuild,v 1.4 2010/03/27 22:34:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.8.ebuild,v 1.5 2010/04/02 15:27:10 mr_bones_ Exp $
EAPI=2
inherit cmake-utils eutils toolchain-funcs flag-o-matic games
@@ -22,7 +22,8 @@ RDEPEND=">=media-libs/libsdl-1.2.7[video,X]
!dedicated? (
dbus? ( sys-apps/dbus )
)
- || ( dev-libs/boost:1.42 dev-libs/boost:1.41 >=dev-libs/boost-1.35:0 )
+ amd64? ( >=dev-libs/boost-1.35:0 )
+ !amd64? ( || ( dev-libs/boost:1.42 dev-libs/boost:1.41 >=dev-libs/boost-1.35:0 ) )
sys-libs/zlib
x11-libs/pango
dev-lang/lua
@@ -57,9 +58,14 @@ src_prepare() {
|| die "sed failed"
fi
# how do I hate boost? Let me count the ways...
- has_version dev-libs/boost:0 && boost_ver=1_35
- has_version dev-libs/boost:1.41 && boost_ver=1_41
- has_version dev-libs/boost:1.42 && boost_ver=1_42
+ local boost_ver
+ if use amd64 ; then
+ boost_ver=1_35
+ else
+ has_version dev-libs/boost:0 && boost_ver=1_35
+ has_version dev-libs/boost:1.41 && boost_ver=1_41
+ has_version dev-libs/boost:1.42 && boost_ver=1_42
+ fi
append-cxxflags \
-I/usr/include/boost-${boost_ver}
append-ldflags \