summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-16 00:36:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-16 00:36:31 +0000
commit6672b261e2aaa94884b2fc6f551ec36127587f03 (patch)
treed5ecd137027930c037c37b0c95736c71101ed58a /games-strategy
parentBump per bug #516604. (diff)
downloadgentoo-2-6672b261e2aaa94884b2fc6f551ec36127587f03.tar.gz
gentoo-2-6672b261e2aaa94884b2fc6f551ec36127587f03.tar.bz2
gentoo-2-6672b261e2aaa94884b2fc6f551ec36127587f03.zip
EAPI=5; tidy
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/mindrover-demo/ChangeLog7
-rw-r--r--games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild13
2 files changed, 12 insertions, 8 deletions
diff --git a/games-strategy/mindrover-demo/ChangeLog b/games-strategy/mindrover-demo/ChangeLog
index 3cae7f9eac2d..b438c8ccc0aa 100644
--- a/games-strategy/mindrover-demo/ChangeLog
+++ b/games-strategy/mindrover-demo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/mindrover-demo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/mindrover-demo/ChangeLog,v 1.7 2014/05/06 16:06:44 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/mindrover-demo/ChangeLog,v 1.8 2014/07/16 00:36:31 mr_bones_ Exp $
+
+ 16 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ mindrover-demo-1.07b.ebuild:
+ EAPI=5; tidy
06 May 2014; Ulrich Müller <ulm@gentoo.org> mindrover-demo-1.07b.ebuild:
Fix LICENSE, add mirror and bindist restrictions, bug 505772.
@@ -28,4 +32,3 @@
17 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org> +metadata.xml,
+mindrover-demo-1.07b.ebuild:
Initial import. Ebuild by me. Closing bug #70915.
-
diff --git a/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild b/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild
index 9ffd9f590107..3261b18c8303 100644
--- a/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild
+++ b/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild,v 1.7 2014/05/06 16:06:44 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/mindrover-demo/mindrover-demo-1.07b.ebuild,v 1.8 2014/07/16 00:36:31 mr_bones_ Exp $
+EAPI=5
inherit eutils unpacker games
MY_P="mindrover_demo.run"
@@ -26,18 +27,18 @@ src_install() {
dodir "${dir}"
- tar -zxf data.tar.gz -C "${Ddir}"/ || die "untar failed"
- tar -zxf music.tar.gz -C "${Ddir}"/ || die "untar failed"
+ tar -zxf data.tar.gz -C "${Ddir}"/ || die
+ tar -zxf music.tar.gz -C "${Ddir}"/ || die
dodoc README
- newicon icon.xpm ${PN}.xpm || die "doins failed"
+ newicon icon.xpm ${PN}.xpm || die
exeinto "${dir}"
doexe bin/Linux/x86/glibc-2.1/mindrover_demo \
- bin/Linux/x86/glibc-2.1/lib/libopenal.so.0.0.6 || die "doexe failed"
+ bin/Linux/x86/glibc-2.1/lib/libopenal.so.0.0.6 || die
dosym "${dir}"/libopenal.so.0.0.6 "${dir}"/libopenal.so.0
games_make_wrapper ${PN} ./mindrover_demo "${dir}" "${dir}"
+ make_desktop_entry ${PN} "Mindrover: Europa Project (Demo)"
prepgamesdirs
- make_desktop_entry ${PN} "Mindrover: Europa Project (Demo)"
}