summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-30 10:47:38 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-30 10:47:38 +0000
commit0d7542e9adb1bf86a54763b17a2fd8b44b5c38ff (patch)
tree1f5f909adc06abbc3ebf9f124f1a16f5c9c48b2e /games-strategy
parentNew upstream version, remove old one. (diff)
downloadgentoo-2-0d7542e9adb1bf86a54763b17a2fd8b44b5c38ff.tar.gz
gentoo-2-0d7542e9adb1bf86a54763b17a2fd8b44b5c38ff.tar.bz2
gentoo-2-0d7542e9adb1bf86a54763b17a2fd8b44b5c38ff.zip
No exec stack and let portage strip binaries
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/liquidwar/ChangeLog6
-rw-r--r--games-strategy/liquidwar/files/liquidwar-5.6.3-exec-stack.patch27
-rw-r--r--games-strategy/liquidwar/liquidwar-5.6.3.ebuild8
3 files changed, 37 insertions, 4 deletions
diff --git a/games-strategy/liquidwar/ChangeLog b/games-strategy/liquidwar/ChangeLog
index bc26fa67694c..2b687792110c 100644
--- a/games-strategy/liquidwar/ChangeLog
+++ b/games-strategy/liquidwar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/liquidwar
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/liquidwar/ChangeLog,v 1.16 2006/08/30 19:33:04 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/liquidwar/ChangeLog,v 1.17 2006/10/30 10:47:38 nyhm Exp $
+
+ 30 Oct 2006; Tristan Heaven <nyhm@gentoo.org>
+ +files/liquidwar-5.6.3-exec-stack.patch, liquidwar-5.6.3.ebuild:
+ No exec stack and let portage strip binaries
30 Aug 2006; Michael Hanselmann <hansmi@gentoo.org>
liquidwar-5.6.3.ebuild:
diff --git a/games-strategy/liquidwar/files/liquidwar-5.6.3-exec-stack.patch b/games-strategy/liquidwar/files/liquidwar-5.6.3-exec-stack.patch
new file mode 100644
index 000000000000..83e733b28a05
--- /dev/null
+++ b/games-strategy/liquidwar/files/liquidwar-5.6.3-exec-stack.patch
@@ -0,0 +1,27 @@
+--- src/glouglou.s
++++ src/glouglou.s
+@@ -240,3 +240,6 @@
+
+ ret
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/monster.s
++++ src/monster.s
+@@ -972,3 +972,6 @@
+ ret # retour au c
+
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+--- src/spread.s
++++ src/spread.s
+@@ -957,3 +957,6 @@
+
+
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/games-strategy/liquidwar/liquidwar-5.6.3.ebuild b/games-strategy/liquidwar/liquidwar-5.6.3.ebuild
index f818ccb0ccc2..a79dfa28579a 100644
--- a/games-strategy/liquidwar/liquidwar-5.6.3.ebuild
+++ b/games-strategy/liquidwar/liquidwar-5.6.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/liquidwar/liquidwar-5.6.3.ebuild,v 1.7 2006/10/30 01:11:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/liquidwar/liquidwar-5.6.3.ebuild,v 1.8 2006/10/30 10:47:38 nyhm Exp $
-inherit games
+inherit eutils games
DESCRIPTION="unique multiplayer wargame"
HOMEPAGE="http://www.ufoot.org/liquidwar/"
@@ -19,6 +19,7 @@ DEPEND=">=media-libs/allegro-4.2"
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-exec-stack.patch
sed -i \
-e 's:/games::' \
-e '/^MANDIR/ s:=.*:= $(mandir)/man6:' \
@@ -26,6 +27,7 @@ src_unpack() {
-e '/^DESKTOPDIR/ s:=.*:= /usr/share/applnk/Games/:' \
-e '/^INFODIR/ s/=.*/= $(infodir)/' \
-e '/^GAMEDIR/ s/exec_prefix/bindir/' \
+ -e '/install/s:-s ::' \
-e 's:$(DOCDIR)/txt:$(DOCDIR):g' \
-e 's:$(GMAKE):$(MAKE):' \
-e '/^DOCDIR/ s:=.*:= /usr/share/doc/$(PF):' Makefile.in \
@@ -46,7 +48,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install_nolink || die "make install failed"
+ emake DESTDIR="${D}" install_nolink || die "emake install failed"
rm -f "${D}"/usr/share/doc/${PF}/COPYING
use nls || rm -f "${D}"/usr/share/doc/${PF}/README.*
prepalldocs