summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-03-21 17:34:57 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-03-21 17:34:57 +0000
commitc1b8af90b4c93d96a71c134446dab7ed187b53d5 (patch)
treeca63b46d25d48ac1e4dbfbe9a74adba190d2c2fd /games-strategy/wormux
parentVersion bump #310173 by Tim Harder and rename older version to avoid conflicts. (diff)
downloadgentoo-2-c1b8af90b4c93d96a71c134446dab7ed187b53d5.tar.gz
gentoo-2-c1b8af90b4c93d96a71c134446dab7ed187b53d5.tar.bz2
gentoo-2-c1b8af90b4c93d96a71c134446dab7ed187b53d5.zip
Version bump to 0.9.1 Bug #3104830
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-strategy/wormux')
-rw-r--r--games-strategy/wormux/ChangeLog8
-rw-r--r--games-strategy/wormux/files/wormux-0.9.1-gentoo.patch37
-rw-r--r--games-strategy/wormux/wormux-0.9.1.ebuild56
3 files changed, 100 insertions, 1 deletions
diff --git a/games-strategy/wormux/ChangeLog b/games-strategy/wormux/ChangeLog
index bc47f4b0709f..fc27c607dab5 100644
--- a/games-strategy/wormux/ChangeLog
+++ b/games-strategy/wormux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wormux
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/ChangeLog,v 1.38 2010/02/18 17:04:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/ChangeLog,v 1.39 2010/03/21 17:34:55 tupone Exp $
+
+*wormux-0.9.1 (21 Mar 2010)
+
+ 21 Mar 2010; Tupone Alfredo <tupone@gentoo.org> +wormux-0.9.1.ebuild,
+ +files/wormux-0.9.1-gentoo.patch:
+ Version bump to 0.9.1 Bug #3104830 by Doktor Notor
18 Feb 2010; Michael Sterrett <mr_bones_@gentoo.org> wormux-0.9.0.ebuild:
ebuild touchups from bug #305753
diff --git a/games-strategy/wormux/files/wormux-0.9.1-gentoo.patch b/games-strategy/wormux/files/wormux-0.9.1-gentoo.patch
new file mode 100644
index 000000000000..73a1f018f146
--- /dev/null
+++ b/games-strategy/wormux/files/wormux-0.9.1-gentoo.patch
@@ -0,0 +1,37 @@
+diff -ru wormux-0.9.0.orig/configure.ac wormux-0.9.0/configure.ac
+--- wormux-0.9.0.orig/configure.ac 2010-01-26 15:01:12.000000000 -0500
++++ wormux-0.9.0/configure.ac 2010-02-17 14:41:46.953505745 -0500
+@@ -48,8 +48,6 @@
+ dnl === Options for users =
+ dnl =========================================================================
+
+-AX_CFLAGS_WARN_ALL([CXXFLAGS])
+-
+ AC_ARG_ENABLE([servers],
+ [AS_HELP_STRING([--enable-servers],
+ [Enable building the index and game servers @<:@default=no@:>@])],
+@@ -375,12 +373,6 @@
+ CXXFLAGS="$CXXFLAGS $LIBXML_CFLAGS $LIBPNG_CFLAGS"
+ LIBS="$LIBS $LIBXML_LIBS $LIBPNG_LIBS"
+
+-dnl === Add Werror flag for gcc/g++ if debug mode is enabled ==============
+-if test "x${debug}" = "xyes"; then
+- CFLAGS="$CFLAGS -Werror"
+- CXXFLAGS="$CXXFLAGS -Werror"
+-fi
+-
+ dnl ========================================================================
+ dnl == Check for header files =
+ dnl ========================================================================
+diff -ru wormux-0.9.0.orig/data/Makefile.am wormux-0.9.0/data/Makefile.am
+--- wormux-0.9.0.orig/data/Makefile.am 2010-01-10 09:23:32.000000000 -0500
++++ wormux-0.9.0/data/Makefile.am 2010-02-17 14:42:10.353509871 -0500
+@@ -1,8 +1,2 @@
+-xdg_appsdir = $(prefix)/share/applications
+-xdg_apps_DATA = wormux.desktop
+-pixmapsdir = $(prefix)/share/pixmaps
+-pixmaps_DATA = wormux_128x128.png
+-
+ nobase_dist_pkgdata_DATA = @DATA_FILES@
+ pkgdatadir = @DATADIR@
+-EXTRA_DIST = $(pixmaps_DATA)
diff --git a/games-strategy/wormux/wormux-0.9.1.ebuild b/games-strategy/wormux/wormux-0.9.1.ebuild
new file mode 100644
index 000000000000..0897804dc709
--- /dev/null
+++ b/games-strategy/wormux/wormux-0.9.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/wormux-0.9.1.ebuild,v 1.1 2010/03/21 17:34:55 tupone Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="A free Worms clone"
+HOMEPAGE="http://www.wormux.org/"
+SRC_URI="http://download.gna.org/wormux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug nls unicode"
+
+RDEPEND="media-libs/libsdl[joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ media-libs/sdl-gfx
+ net-misc/curl
+ media-fonts/dejavu
+ dev-libs/libxml2
+ x11-libs/libX11
+ nls? ( virtual/libintl )
+ unicode? ( dev-libs/fribidi )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-localedir-name=/usr/share/locale \
+ --with-datadir-name="${GAMES_DATADIR}/${PN}" \
+ --with-font-path=/usr/share/fonts/dejavu/DejaVuSans.ttf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode fribidi)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ rm -f "${D}${GAMES_DATADIR}/${PN}/font/DejaVuSans.ttf"
+ doicon data/wormux.svg
+ make_desktop_entry wormux Wormux
+ prepgamesdirs
+}