summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-09 09:41:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-09 09:41:58 +0000
commit978d938dd1e690b79d83c629082804a13a1844d8 (patch)
tree2c584d30fc669c69e2971ca00de13ab857bacad9 /games-strategy/wesnoth
parentStable on mips (Manifest recommit) (diff)
downloadgentoo-2-978d938dd1e690b79d83c629082804a13a1844d8.tar.gz
gentoo-2-978d938dd1e690b79d83c629082804a13a1844d8.tar.bz2
gentoo-2-978d938dd1e690b79d83c629082804a13a1844d8.zip
version bump
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.7.21
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.2.ebuild39
4 files changed, 48 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index a3a50fe1bb90..7d122ec88cd4 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.18 2004/04/03 23:50:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.19 2004/04/09 09:41:58 mr_bones_ Exp $
+
+*wesnoth-0.7.2 (09 Apr 2004)
+
+ 09 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.2.ebuild:
+ version bump; added gnome and kde USE.
03 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org>
wesnoth-0.6.99.1.ebuild, wesnoth-0.6.99.2.ebuild, wesnoth-0.6.99.3.ebuild,
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index f7a4d2028af8..b7122b3ed724 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,6 +1,8 @@
MD5 4e2b8d7f20404e2ec067f052d1142fba wesnoth-0.7.ebuild 955
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 e8de4e9995d9dcb7db00eafa86dc4095 ChangeLog 2622
+MD5 68343aa5c3c7919a357a99c16b316431 wesnoth-0.7.2.ebuild 957
MD5 68343aa5c3c7919a357a99c16b316431 wesnoth-0.7.1.ebuild 957
MD5 2218dd653ddf591503d9bde5beb4df8c files/digest-wesnoth-0.7 65
+MD5 943fc665866e98d256c99403826c7cbd files/digest-wesnoth-0.7.2 67
MD5 eed8758f69d700eedc02234ae1a428d8 files/digest-wesnoth-0.7.1 67
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.7.2 b/games-strategy/wesnoth/files/digest-wesnoth-0.7.2
new file mode 100644
index 000000000000..c777832e03c2
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.7.2
@@ -0,0 +1 @@
+MD5 efd950457569426ef6292156c741938f wesnoth-0.7.2.tar.gz 20157909
diff --git a/games-strategy/wesnoth/wesnoth-0.7.2.ebuild b/games-strategy/wesnoth/wesnoth-0.7.2.ebuild
new file mode 100644
index 000000000000..a684166e0692
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.7.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.2.ebuild,v 1.1 2004/04/09 09:41:58 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc ~sparc"
+IUSE="server editor tools gnome kde"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ `use_enable server` \
+ `use_enable editor` \
+ `use_enable tools` \
+ `use_enable gnome` \
+ `use_enable kde` \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}