summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-04-11 23:47:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-04-11 23:47:46 +0000
commit0c5604d57e3ae8753758fe5f214df1240b712816 (patch)
tree78add5dc60717c633328fddf79f711490e9b50cb /games-strategy/wesnoth
parentStable on sparc (diff)
downloadgentoo-2-0c5604d57e3ae8753758fe5f214df1240b712816.tar.gz
gentoo-2-0c5604d57e3ae8753758fe5f214df1240b712816.tar.bz2
gentoo-2-0c5604d57e3ae8753758fe5f214df1240b712816.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/Manifest6
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.9.02
-rw-r--r--games-strategy/wesnoth/wesnoth-0.9.0.ebuild62
4 files changed, 75 insertions, 3 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index a26b56910f1a..124fb26fdee9 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.46 2005/02/22 22:32:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.47 2005/04/11 23:47:46 mr_bones_ Exp $
+
+*wesnoth-0.9.0 (11 Apr 2005)
+
+ 11 Apr 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-0.9.0.ebuild:
+ version bump
*wesnoth-0.8.11 (22 Feb 2005)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index ce87152bbc25..17a35a1be0a9 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,6 +1,8 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 5b400546f4bcd68030d896f16fcb54bf ChangeLog 6427
+MD5 c3b7385d21ce32866abc499da8dc32b1 wesnoth-0.9.0.ebuild 1611
MD5 93581e11441f3cd875599dfbea67f87a wesnoth-0.8.10.ebuild 1766
MD5 c3b7385d21ce32866abc499da8dc32b1 wesnoth-0.8.11.ebuild 1611
-MD5 b7e6563ad1ede86d02ff1afcaa76e84e files/digest-wesnoth-0.8.10 141
+MD5 5b400546f4bcd68030d896f16fcb54bf ChangeLog 6427
MD5 3c7adc12b44a2b4b9d788c8f422ba401 files/digest-wesnoth-0.8.11 141
+MD5 b7e6563ad1ede86d02ff1afcaa76e84e files/digest-wesnoth-0.8.10 141
+MD5 7240f4ddb5c9ceeed466ab43a3d97caf files/digest-wesnoth-0.9.0 139
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.9.0 b/games-strategy/wesnoth/files/digest-wesnoth-0.9.0
new file mode 100644
index 000000000000..9ec993ee0904
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.9.0
@@ -0,0 +1,2 @@
+MD5 8dd59719631e0e6329a0a25e1dcbf302 wesnoth-0.9.0.tar.gz 36051074
+MD5 0071202a21a3095e535868f017b1c8f1 wesnoth-lite-0.9.0.tar.gz 20252375
diff --git a/games-strategy/wesnoth/wesnoth-0.9.0.ebuild b/games-strategy/wesnoth/wesnoth-0.9.0.ebuild
new file mode 100644
index 000000000000..59a6ffba8a04
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.9.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.9.0.ebuild,v 1.1 2005/04/11 23:47:46 mr_bones_ Exp $
+
+inherit eutils flag-o-matic gcc games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="!lite? ( mirror://sourceforge/wesnoth/${P}.tar.gz )
+ lite? ( mirror://sourceforge/wesnoth/${PN}-lite-${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/freetype-2
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/x11"
+
+src_unpack() {
+ if use lite ; then
+ unpack ${PN}-lite-${PV}.tar.gz
+ S=${WORKDIR}/${PN}-lite-${PV}
+ else
+ unpack ${P}.tar.gz
+ fi
+}
+
+src_compile() {
+ if use lite ; then
+ S=${WORKDIR}/${PN}-lite-${PV}
+ fi
+ cd "${S}"
+ filter-flags -ftracer -fomit-frame-pointer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ if use lite ; then
+ S=${WORKDIR}/${PN}-lite-${PV}
+ fi
+ cd "${S}"
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ dodoc MANUAL changelog
+ prepgamesdirs
+}