summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-03 14:29:03 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-03 14:29:03 +0000
commit6fb3d40f474e360ebabf80940fced5dd4ae37e1e (patch)
tree613bf6aaaf3b90cd12e0d49bc1d79b3a4bcbb250 /games-strategy/spacehulk/spacehulk-1.4.5.ebuild
parentAdd patch that fixes creating xwd files on 64 bit archs, see bug #158143. (diff)
downloadgentoo-2-6fb3d40f474e360ebabf80940fced5dd4ae37e1e.tar.gz
gentoo-2-6fb3d40f474e360ebabf80940fced5dd4ae37e1e.tar.bz2
gentoo-2-6fb3d40f474e360ebabf80940fced5dd4ae37e1e.zip
Don't use egamesinstall
(Portage version: 2.1.2-r6)
Diffstat (limited to 'games-strategy/spacehulk/spacehulk-1.4.5.ebuild')
-rw-r--r--games-strategy/spacehulk/spacehulk-1.4.5.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/games-strategy/spacehulk/spacehulk-1.4.5.ebuild b/games-strategy/spacehulk/spacehulk-1.4.5.ebuild
index 344735e1ded1..387f02eef91c 100644
--- a/games-strategy/spacehulk/spacehulk-1.4.5.ebuild
+++ b/games-strategy/spacehulk/spacehulk-1.4.5.ebuild
@@ -1,23 +1,23 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/spacehulk/spacehulk-1.4.5.ebuild,v 1.6 2006/01/11 21:34:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/spacehulk/spacehulk-1.4.5.ebuild,v 1.7 2007/02/03 14:29:03 nyhm Exp $
-inherit games
+inherit qt3 games
DESCRIPTION="A boardgame in the world of Warhammer 40k"
-HOMEPAGE="http://perso.enst.fr/~vinot/spacehulk/"
+HOMEPAGE="http://r.vinot.free.fr/spacehulk/"
SRC_URI="http://freesoftware.fsf.org/download/spacehulk/main.pkg/${PV}/${P}.tar.gz
http://freesoftware.fsf.org/download/spacehulk/themespack.pkg/1.0/spacehulk-themespack-1.0.tar.gz"
+
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc"
SLOT="0"
IUSE="xinerama"
-DEPEND="=x11-libs/qt-3*
- sys-libs/zlib
+DEPEND="$(qt_min_version 3.3)
media-libs/libpng
media-libs/jpeg
- media-libs/nas"
+ xinerama? ( x11-libs/libXinerama )"
src_compile() {
egamesconf $(use_with xinerama) || die
@@ -25,8 +25,9 @@ src_compile() {
}
src_install() {
- egamesinstall || die
- cp -R ../themes/* ${D}${GAMES_DATADIR}/${PN}/themes
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto "${GAMES_DATADIR}"/${PN}/themes
+ doins -r ../themes/* || die "doins failed"
dodoc AUTHORS ChangeLog README TODO
prepgamesdirs
}