summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-04-06 09:05:42 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-04-06 09:05:42 +0000
commitb976ea14aee03a023bde854643a4cb295d265f6a (patch)
treec275811c40b8b3ad6fc578791957a5ff6906bcf9 /games-strategy/outerspace
parentBump to EAPI=3, add prefix keywords, many QA fixes (diff)
downloadgentoo-2-b976ea14aee03a023bde854643a4cb295d265f6a.tar.gz
gentoo-2-b976ea14aee03a023bde854643a4cb295d265f6a.tar.bz2
gentoo-2-b976ea14aee03a023bde854643a4cb295d265f6a.zip
Force python 2 version. Bug #312287
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-strategy/outerspace')
-rw-r--r--games-strategy/outerspace/ChangeLog7
-rw-r--r--games-strategy/outerspace/outerspace-0.5.66.ebuild17
2 files changed, 17 insertions, 7 deletions
diff --git a/games-strategy/outerspace/ChangeLog b/games-strategy/outerspace/ChangeLog
index d08233fabef5..bda5aa90d09e 100644
--- a/games-strategy/outerspace/ChangeLog
+++ b/games-strategy/outerspace/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/outerspace
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.11 2009/11/25 22:13:41 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.12 2010/04/06 09:05:42 tupone Exp $
+
+ 06 Apr 2010; Tupone Alfredo <tupone@gentoo.org> outerspace-0.5.66.ebuild:
+ Force python 2 version. Bug #312287 by arfrever@gentoo.org
25 Nov 2009; Markus Meier <maekke@gentoo.org> outerspace-0.5.66.ebuild:
amd64/x86 stable, bug #294449
diff --git a/games-strategy/outerspace/outerspace-0.5.66.ebuild b/games-strategy/outerspace/outerspace-0.5.66.ebuild
index dbc8ad812c5f..4fd8bb0247b0 100644
--- a/games-strategy/outerspace/outerspace-0.5.66.ebuild
+++ b/games-strategy/outerspace/outerspace-0.5.66.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.66.ebuild,v 1.3 2009/11/25 22:13:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.66.ebuild,v 1.4 2010/04/06 09:05:42 tupone Exp $
EAPI=2
-inherit eutils games
+PYTHON_DEPEND="2"
+
+inherit eutils python games
MY_PN=${PN/outerspace/OuterSpace}
MY_P=${MY_PN}-${PV}
@@ -16,14 +18,14 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND=">=dev-python/pygame-1.7
- >=dev-lang/python-2.4"
+RDEPEND=">=dev-python/pygame-1.7"
S=${WORKDIR}/${MY_P}
src_prepare() {
sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
-e "s:@GENTOO_LIBDIR@:$(games_get_libdir)/${PN}:" \
+ -e "s:python:$(PYTHON -a):" \
"${FILESDIR}"/${PN} > ${PN} \
|| die "sed failed"
}
@@ -38,3 +40,8 @@ src_install() {
make_desktop_entry ${PN} ${MY_PN}
prepgamesdirs
}
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}