summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-11-05 20:56:17 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-11-05 20:56:17 +0000
commit819fdf57a459c7d0a8ba8eb4216e02ca1f226b74 (patch)
tree4692d6a09f5b6569f0c5e208bbc7399404503804 /games-strategy/lightyears
parentamd64/x86 stable, bug #245252 (diff)
downloadgentoo-2-819fdf57a459c7d0a8ba8eb4216e02ca1f226b74.tar.gz
gentoo-2-819fdf57a459c7d0a8ba8eb4216e02ca1f226b74.tar.bz2
gentoo-2-819fdf57a459c7d0a8ba8eb4216e02ca1f226b74.zip
Version bump to 1.3a. Bug #233011
(Portage version: 2.1.4.5)
Diffstat (limited to 'games-strategy/lightyears')
-rw-r--r--games-strategy/lightyears/ChangeLog8
-rw-r--r--games-strategy/lightyears/files/lightyears-1.3a-gentoo.patch35
-rw-r--r--games-strategy/lightyears/lightyears-1.3a.ebuild53
3 files changed, 95 insertions, 1 deletions
diff --git a/games-strategy/lightyears/ChangeLog b/games-strategy/lightyears/ChangeLog
index e027be1ee157..130edc442c36 100644
--- a/games-strategy/lightyears/ChangeLog
+++ b/games-strategy/lightyears/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/lightyears
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/lightyears/ChangeLog,v 1.6 2008/05/29 16:55:42 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/lightyears/ChangeLog,v 1.7 2008/11/05 20:56:17 tupone Exp $
+
+*lightyears-1.3a (05 Nov 2008)
+
+ 05 Nov 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/lightyears-1.3a-gentoo.patch, +lightyears-1.3a.ebuild:
+ Version bump to 1.3a. Bug #233011 by chris salch
29 May 2008; Ali Polatel <hawking@gentoo.org> lightyears-1.2a.ebuild:
python_mod_optimize is ROOT aware.
diff --git a/games-strategy/lightyears/files/lightyears-1.3a-gentoo.patch b/games-strategy/lightyears/files/lightyears-1.3a-gentoo.patch
new file mode 100644
index 000000000000..4c38e878914c
--- /dev/null
+++ b/games-strategy/lightyears/files/lightyears-1.3a-gentoo.patch
@@ -0,0 +1,35 @@
+--- lightyears.old 2008-11-03 20:16:40.000000000 +0100
++++ lightyears 2008-11-03 20:18:40.000000000 +0100
+@@ -1,28 +1,16 @@
+ #!/usr/bin/python
+
+ # Set the location of the LightYears .py files here:
+-LIGHTYEARS_DIR = "/usr/share/games/lightyears"
+
+ # Save games and configuration files are stored in the user's
+ # home directory.
+
+-
+ if ( __name__ == "__main__" ):
+ import sys, os
+
+- if (( LIGHTYEARS_DIR == None )
+- or ( not os.path.exists(LIGHTYEARS_DIR) )):
+- # Try current directory
+- LIGHTYEARS_DIR = os.path.abspath(
+- os.path.dirname(sys.argv[ 0 ]))
+-
+- sys.path.insert(0, os.path.join(LIGHTYEARS_DIR, 'code'))
+-
+- try:
+- import startup
+- except:
+- print "Unable to find LightYears code in", LIGHTYEARS_DIR
+- sys.exit(1)
++ sys.path.insert(0, "@GENTOO_LIBDIR@")
++
++ import startup
+
+- startup.Main(os.path.join(LIGHTYEARS_DIR, 'data'))
++ startup.Main("@GENTOO_DATADIR@/data")
+
diff --git a/games-strategy/lightyears/lightyears-1.3a.ebuild b/games-strategy/lightyears/lightyears-1.3a.ebuild
new file mode 100644
index 000000000000..178793f798f9
--- /dev/null
+++ b/games-strategy/lightyears/lightyears-1.3a.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/lightyears/lightyears-1.3a.ebuild,v 1.1 2008/11/05 20:56:17 tupone Exp $
+
+inherit eutils python games
+
+DESCRIPTION="a single-player game with a science-fiction theme"
+HOMEPAGE="http://www.jwhitham.org.uk/20kly/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/python
+ dev-python/pygame"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_LIBDIR@:$(games_get_libdir)/${PN}:" \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ ${PN} || die "Changing library path failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+
+ insinto "$(games_get_libdir)/${PN}"
+ doins code/*.py || die "doins code failed"
+
+ dodoc README.txt
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data audio || die "doins data failed"
+
+ newicon data/32.png ${PN}.png
+ make_desktop_entry ${PN} "Light Years Into Space"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ python_mod_optimize "$(games_get_libdir)/${PN}"
+ games_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup "$(games_get_libdir)/${PN}"
+}