summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-11 12:26:35 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-11 12:26:35 +0000
commit47f8ba0ac8d1440ebaa74200e3af6b6777be5f1b (patch)
treefb3668b891be6dd444a1643d20573e4224e149a3 /games-sports/trophy
parentsimulation games (diff)
downloadgentoo-2-47f8ba0ac8d1440ebaa74200e3af6b6777be5f1b.tar.gz
gentoo-2-47f8ba0ac8d1440ebaa74200e3af6b6777be5f1b.tar.bz2
gentoo-2-47f8ba0ac8d1440ebaa74200e3af6b6777be5f1b.zip
sports games !
Diffstat (limited to 'games-sports/trophy')
-rw-r--r--games-sports/trophy/ChangeLog9
-rw-r--r--games-sports/trophy/Manifest3
-rw-r--r--games-sports/trophy/files/digest-trophy-1.1.31
-rw-r--r--games-sports/trophy/trophy-1.1.3.ebuild45
4 files changed, 58 insertions, 0 deletions
diff --git a/games-sports/trophy/ChangeLog b/games-sports/trophy/ChangeLog
new file mode 100644
index 000000000000..2b1c0af25c07
--- /dev/null
+++ b/games-sports/trophy/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-games/trophy
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/ChangeLog,v 1.1 2003/09/11 12:26:35 vapier Exp $
+
+*trophy-1.1.3 (31 Aug 2003)
+
+ 31 Aug 2003; Michael Sterrett <msterret@gentoo.org> trophy-1.1.3.ebuild:
+ initial commit. I think this ebuild is from Rob Cakebread.
+
diff --git a/games-sports/trophy/Manifest b/games-sports/trophy/Manifest
new file mode 100644
index 000000000000..fbbf5efcbc60
--- /dev/null
+++ b/games-sports/trophy/Manifest
@@ -0,0 +1,3 @@
+MD5 151be9101f56c25215330c6d473bdb51 files/digest-trophy-1.1.3 69
+MD5 3759b811c792b50620f47f70f1ab2783 trophy-1.1.3.ebuild 996
+MD5 8637ccc2ae2ab8c6dfb2355ff43bbddc ChangeLog 383
diff --git a/games-sports/trophy/files/digest-trophy-1.1.3 b/games-sports/trophy/files/digest-trophy-1.1.3
new file mode 100644
index 000000000000..1374be9d805d
--- /dev/null
+++ b/games-sports/trophy/files/digest-trophy-1.1.3
@@ -0,0 +1 @@
+MD5 45a8c6eec9ab5d110660a32416d1ec8f trophy-1.1.3-src.tar.gz 9330835
diff --git a/games-sports/trophy/trophy-1.1.3.ebuild b/games-sports/trophy/trophy-1.1.3.ebuild
new file mode 100644
index 000000000000..29d02accd12c
--- /dev/null
+++ b/games-sports/trophy/trophy-1.1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trophy/trophy-1.1.3.ebuild,v 1.1 2003/09/11 12:26:35 vapier Exp $
+
+inherit games
+
+MY_P="${P}-src"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="2D Racing Game"
+HOMEPAGE="http://trophy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/trophy/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="=clanlib-0.6.5*
+ >=hermes-1.3.2
+ >=zlib-1.1.3"
+
+pkg_setup() {
+ clanlib-config 0.6.5
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ find -name ".cvsignore" -exec rm -f \{\} \;
+}
+
+src_compile() {
+ cd trophy
+ autoconf || die "autoconf failed"
+ egamesconf || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin trophy/trophy
+ dodir ${GAMES_DATADIR}/trophy/resources
+ cp -R trophy/resources/* ${D}${GAMES_DATADIR}/trophy/resources
+ cp trophy/resources.scr ${D}${GAMES_DATADIR}/trophy/
+ dodoc AUTHORS README TODO ChangeLog
+ prepgamesdirs
+}