summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-10-02 06:46:58 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-10-02 06:46:58 +0000
commitd2e5e264dced027f7049e09de68479b9ad6412dc (patch)
treec65c75b874fd099cff36709249d2e231daf2dbe5 /games-simulation
parentVersion bump. (diff)
downloadgentoo-2-d2e5e264dced027f7049e09de68479b9ad6412dc.tar.gz
gentoo-2-d2e5e264dced027f7049e09de68479b9ad6412dc.tar.bz2
gentoo-2-d2e5e264dced027f7049e09de68479b9ad6412dc.zip
Version bump to 0.26a . Bug #193279
(Portage version: 2.1.3.9)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/singularity/ChangeLog9
-rw-r--r--games-simulation/singularity/files/digest-singularity-0.26a6
-rw-r--r--games-simulation/singularity/singularity-0.26a.ebuild36
3 files changed, 49 insertions, 2 deletions
diff --git a/games-simulation/singularity/ChangeLog b/games-simulation/singularity/ChangeLog
index 0a1abe10f634..87eb8ec52532 100644
--- a/games-simulation/singularity/ChangeLog
+++ b/games-simulation/singularity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/singularity
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/ChangeLog,v 1.3 2006/10/08 19:52:54 blubb Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/ChangeLog,v 1.4 2007/10/02 06:46:57 tupone Exp $
+
+*singularity-0.26a (02 Oct 2007)
+
+ 02 Oct 2007; Tupone Alfredo <tupone@gentoo.org> +singularity-0.26a.ebuild:
+ Version bump to 0.26a . Bug #193279 by Arne Babenhauserheide
08 Oct 2006; Simon Stelling <blubb@gentoo.org> singularity-0.25.ebuild:
added ~amd64
diff --git a/games-simulation/singularity/files/digest-singularity-0.26a b/games-simulation/singularity/files/digest-singularity-0.26a
new file mode 100644
index 000000000000..ebe7cc206e13
--- /dev/null
+++ b/games-simulation/singularity/files/digest-singularity-0.26a
@@ -0,0 +1,6 @@
+MD5 cd9ad7fc16464eb2aebfd01cb25d115c endgame-singularity-music-001.zip 23997713
+RMD160 e2ee47d6fde5da48825a6198af8d1a4fc8fcc585 endgame-singularity-music-001.zip 23997713
+SHA256 f0d68beebac597252930fc458d19381b5806226f33b338e495f4af0b9407a8b6 endgame-singularity-music-001.zip 23997713
+MD5 cbe16395c206bd605494423ee085da9c singularity_0.26a.tar.gz 1262046
+RMD160 8241cd5cc8d1ec6e449e351f4f7d06b5a2b243fc singularity_0.26a.tar.gz 1262046
+SHA256 3d457ae793c2dc80387c9f1548c2fb3232aec95c650bb8401d9107dbeeb601d4 singularity_0.26a.tar.gz 1262046
diff --git a/games-simulation/singularity/singularity-0.26a.ebuild b/games-simulation/singularity/singularity-0.26a.ebuild
new file mode 100644
index 000000000000..65cd49f5f663
--- /dev/null
+++ b/games-simulation/singularity/singularity-0.26a.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/singularity-0.26a.ebuild,v 1.1 2007/10/02 06:46:57 tupone Exp $
+
+inherit games
+
+MUSIC=endgame-${PN}-music-001
+
+DESCRIPTION="A simulation of a true AI. Go from computer to computer, pursued by the entire world. Keep hidden, and you might have a chance."
+HOMEPAGE="http://www.emhsoft.com/singularity/"
+SRC_URI="http://www.emhsoft.com/singularity/${PN}_${PV}.tar.gz
+ http://www.emhsoft.com/singularity/${MUSIC}.zip"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygame"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ rm code/*.pyc data/*.html # Remove unecessary files
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r code data ../${MUSIC}/music || die "doins failed"
+ games_make_wrapper singularity "python ./singularity.py" "${GAMES_DATADIR}/${PN}/code"
+ dodoc README.txt TODO Changelog AUTHORS
+ prepgamesdirs
+}