summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-03-07 08:19:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-03-07 08:19:29 +0000
commit66319dd97a5c7e7a5885e745b1a09c43cb3bf0bf (patch)
tree9e63f9fb993ef7eb1cc72472717b27a700506afe /games-simulation
parentDo not depend on unsermake (diff)
downloadgentoo-2-66319dd97a5c7e7a5885e745b1a09c43cb3bf0bf.tar.gz
gentoo-2-66319dd97a5c7e7a5885e745b1a09c43cb3bf0bf.tar.bz2
gentoo-2-66319dd97a5c7e7a5885e745b1a09c43cb3bf0bf.zip
add support for USE=debug from upstream dev Matt Lawrence (bug #168622)
(Portage version: 2.1.2-r9)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/dangerdeep/ChangeLog6
-rw-r--r--games-simulation/dangerdeep/dangerdeep-0.2.0.ebuild10
2 files changed, 13 insertions, 3 deletions
diff --git a/games-simulation/dangerdeep/ChangeLog b/games-simulation/dangerdeep/ChangeLog
index f51de9df059b..04252b67ce7f 100644
--- a/games-simulation/dangerdeep/ChangeLog
+++ b/games-simulation/dangerdeep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/dangerdeep
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.3 2007/02/03 11:25:52 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/ChangeLog,v 1.4 2007/03/07 08:19:29 mr_bones_ Exp $
+
+ 07 Mar 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ dangerdeep-0.2.0.ebuild:
+ add support for USE=debug from upstream dev Matt Lawrence (bug #168622)
03 Feb 2007; Tristan Heaven <nyhm@gentoo.org> dangerdeep-0.2.0.ebuild:
Add app-arch/unzip to DEPEND
diff --git a/games-simulation/dangerdeep/dangerdeep-0.2.0.ebuild b/games-simulation/dangerdeep/dangerdeep-0.2.0.ebuild
index 919320b4dcdc..322c3f9e8f58 100644
--- a/games-simulation/dangerdeep/dangerdeep-0.2.0.ebuild
+++ b/games-simulation/dangerdeep/dangerdeep-0.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.2.0.ebuild,v 1.4 2007/02/03 11:25:52 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.2.0.ebuild,v 1.5 2007/03/07 08:19:29 mr_bones_ Exp $
inherit eutils toolchain-funcs games
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
LICENSE="GPL-2 CCPL-Attribution-NonCommercial-NoDerivs-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="sse"
+IUSE="sse debug"
RDEPEND="virtual/opengl
virtual/glu
@@ -37,14 +37,20 @@ src_unpack() {
src_compile() {
local sse=-1
+ local use_debug=0
if use sse ; then
use amd64 && sse=3 || sse=1
fi
+ if use debug ; then
+ use_debug=1
+ fi
+
scons \
usex86sse=${sse} \
datadir="${GAMES_DATADIR}"/${PN} \
+ debug=${use_debug} \
|| die "scons failed"
}