summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-29 03:16:37 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-29 03:16:37 +0000
commit04f482ed7f2167310f855bd948003cb708c4afb0 (patch)
treee40642ec663f8d11a02b9625b93e0aec587da46e /games-simulation
parentversion bump, thanks to Elias Pipping in bug #182470. Thanks to Thomas Dickey... (diff)
downloadgentoo-2-04f482ed7f2167310f855bd948003cb708c4afb0.tar.gz
gentoo-2-04f482ed7f2167310f855bd948003cb708c4afb0.tar.bz2
gentoo-2-04f482ed7f2167310f855bd948003cb708c4afb0.zip
Version bump
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/planets/ChangeLog9
-rw-r--r--games-simulation/planets/files/digest-planets-0.1.133
-rw-r--r--games-simulation/planets/planets-0.1.13.ebuild39
3 files changed, 49 insertions, 2 deletions
diff --git a/games-simulation/planets/ChangeLog b/games-simulation/planets/ChangeLog
index 9b6e7448dd3d..14633722d7de 100644
--- a/games-simulation/planets/ChangeLog
+++ b/games-simulation/planets/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/planets
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/ChangeLog,v 1.11 2006/11/04 19:26:10 nyhm Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/ChangeLog,v 1.12 2007/06/29 03:16:37 nyhm Exp $
+
+*planets-0.1.13 (29 Jun 2007)
+
+ 29 Jun 2007; Tristan Heaven <nyhm@gentoo.org> +planets-0.1.13.ebuild:
+ Version bump
04 Nov 2006; Tristan Heaven <nyhm@gentoo.org> planets-0.1.10.ebuild,
planets-0.1.12.ebuild:
diff --git a/games-simulation/planets/files/digest-planets-0.1.13 b/games-simulation/planets/files/digest-planets-0.1.13
new file mode 100644
index 000000000000..ee7224b21f11
--- /dev/null
+++ b/games-simulation/planets/files/digest-planets-0.1.13
@@ -0,0 +1,3 @@
+MD5 2c72f2469ee0413bd470a2ad84f2f0f8 planets-0.1.13.tgz 49732
+RMD160 aca43156b191f221f257ab1738d33621d2277016 planets-0.1.13.tgz 49732
+SHA256 cd4be19dc1e16cc3d5bb20fdfa2af025b50cd21dbce5d1e8b3041c4e786c3624 planets-0.1.13.tgz 49732
diff --git a/games-simulation/planets/planets-0.1.13.ebuild b/games-simulation/planets/planets-0.1.13.ebuild
new file mode 100644
index 000000000000..27a0d97a8869
--- /dev/null
+++ b/games-simulation/planets/planets-0.1.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/planets-0.1.13.ebuild,v 1.1 2007/06/29 03:16:37 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="a simple interactive planetary system simulator"
+SRC_URI="http://planets.homedns.org/dist/${P}.tgz"
+HOMEPAGE="http://planets.homedns.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/tcl
+ dev-lang/tk"
+DEPEND="${RDEPEND}
+ dev-lang/ocaml"
+
+pkg_setup() {
+ # response to bug #134257
+ if ! built_with_use dev-lang/ocaml tk ; then
+ eerror "${PN} doesn't build properly if"
+ eerror "dev-lang/ocaml is built without tk support."
+ die "Please emerge dev-lang/ocaml with USE=tk"
+ fi
+ games_pkg_setup
+}
+
+src_install() {
+ dogamesbin planets || die "dogamesbin failed"
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+ dohtml getting_started.html
+ dodoc CHANGES CREDITS KEYBINDINGS.txt README TODO
+ prepgamesdirs
+}