summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-01-01 18:58:17 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-01-01 18:58:17 +0000
commit32d08bcd817d33e993e39576ff15a3d70312ed05 (patch)
tree99b625b44ae74a94e7d4a382bb6c71594c4752bd /games-simulation/fgrun
parentUse new eselect-news for 0.26.0_alpha4 and the old one for the rest. (diff)
downloadgentoo-2-32d08bcd817d33e993e39576ff15a3d70312ed05.tar.gz
gentoo-2-32d08bcd817d33e993e39576ff15a3d70312ed05.tar.bz2
gentoo-2-32d08bcd817d33e993e39576ff15a3d70312ed05.zip
Version bump
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'games-simulation/fgrun')
-rw-r--r--games-simulation/fgrun/ChangeLog10
-rw-r--r--games-simulation/fgrun/fgrun-1.0.0.ebuild41
-rw-r--r--games-simulation/fgrun/files/digest-fgrun-1.0.03
-rw-r--r--games-simulation/fgrun/files/fgrun-1.0.0-fltk.patch12
4 files changed, 64 insertions, 2 deletions
diff --git a/games-simulation/fgrun/ChangeLog b/games-simulation/fgrun/ChangeLog
index 296e238e2549..cfbe4f8739f1 100644
--- a/games-simulation/fgrun/ChangeLog
+++ b/games-simulation/fgrun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/fgrun
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.2 2007/07/25 09:27:29 opfer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/ChangeLog,v 1.3 2008/01/01 18:58:16 nyhm Exp $
+
+*fgrun-1.0.0 (01 Jan 2008)
+
+ 01 Jan 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/fgrun-1.0.0-fltk.patch, +fgrun-1.0.0.ebuild:
+ Version bump
25 Jul 2007; Christian Faulhammer <opfer@gentoo.org> fgrun-0.4.8.ebuild:
keyworded ~x86, bug 186379; fixed detection of media-libs/plib
diff --git a/games-simulation/fgrun/fgrun-1.0.0.ebuild b/games-simulation/fgrun/fgrun-1.0.0.ebuild
new file mode 100644
index 000000000000..bd698d3c71ae
--- /dev/null
+++ b/games-simulation/fgrun/fgrun-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-1.0.0.ebuild,v 1.1 2008/01/01 18:58:16 nyhm Exp $
+
+inherit autotools eutils multilib games
+
+DESCRIPTION="A graphical frontend for the FlightGear Flight Simulator"
+HOMEPAGE="http://sourceforge.net/projects/fgrun"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-games/simgear
+ x11-libs/fltk
+ games-simulation/flightgear
+ x11-libs/libXi
+ x11-libs/libXmu"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-fltk.patch
+ AT_M4DIR=. eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --with-plib-libraries=/usr/$(get_libdir) \
+ --with-plib-includes=/usr/include \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS
+ prepgamesdirs
+}
diff --git a/games-simulation/fgrun/files/digest-fgrun-1.0.0 b/games-simulation/fgrun/files/digest-fgrun-1.0.0
new file mode 100644
index 000000000000..0973d1d7eda5
--- /dev/null
+++ b/games-simulation/fgrun/files/digest-fgrun-1.0.0
@@ -0,0 +1,3 @@
+MD5 1ba8401ddf5cb155ac7ab26c67705e06 fgrun-1.0.0.tar.gz 196526
+RMD160 54290845d43000a5cb040a6f48628453bc14a41c fgrun-1.0.0.tar.gz 196526
+SHA256 55cdaedcf91217808374fa6e4f6ae32a80fdcaea3d6d9e8056b0afa0aa88933c fgrun-1.0.0.tar.gz 196526
diff --git a/games-simulation/fgrun/files/fgrun-1.0.0-fltk.patch b/games-simulation/fgrun/files/fgrun-1.0.0-fltk.patch
new file mode 100644
index 000000000000..359b9c811b52
--- /dev/null
+++ b/games-simulation/fgrun/files/fgrun-1.0.0-fltk.patch
@@ -0,0 +1,12 @@
+--- configure.ac.old 2007-04-25 22:26:19.000000000 +0200
++++ configure.ac 2007-04-25 22:27:41.000000000 +0200
+@@ -194,6 +194,9 @@
+ FLUID="$fltk_prefix/bin/fluid"
+ CPPFLAGS="-I$fltk_prefix/include $CPPFLAGS"
+ LDFLAGS="-L$fltk_prefix/lib $LDFLAGS"
++else
++ CPPFLAGS="$(fltk-config --cxxflags) $CPPFLAGS"
++ LDFLAGS="$(fltk-config --ldflags) $LDFLAGS"
+ fi
+
+ AC_SUBST(FLUID)