summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-19 23:21:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-19 23:21:47 +0000
commit56b803ade47da9757847099f4e815eac8836729f (patch)
tree368d62635879c825e5d49230c0842e8aa7bafc30 /games-simulation/cannonsmash
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-56b803ade47da9757847099f4e815eac8836729f.tar.gz
gentoo-2-56b803ade47da9757847099f4e815eac8836729f.tar.bz2
gentoo-2-56b803ade47da9757847099f4e815eac8836729f.zip
Fix datadir issue (bug #60933)
Diffstat (limited to 'games-simulation/cannonsmash')
-rw-r--r--games-simulation/cannonsmash/ChangeLog6
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild18
2 files changed, 14 insertions, 10 deletions
diff --git a/games-simulation/cannonsmash/ChangeLog b/games-simulation/cannonsmash/ChangeLog
index 00bc26a9fbc7..a75c6f67b74b 100644
--- a/games-simulation/cannonsmash/ChangeLog
+++ b/games-simulation/cannonsmash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/cannonsmash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.7 2004/07/01 11:23:39 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.8 2004/08/19 23:21:47 mr_bones_ Exp $
+
+ 19 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ cannonsmash-0.6.6.ebuild:
+ Fix datadir issue (bug #60933)
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
cannonsmash-0.6.5.ebuild, cannonsmash-0.6.6.ebuild:
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
index 7b879de643bd..86f732d9977c 100644
--- a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.4 2004/07/01 11:23:39 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.5 2004/08/19 23:21:47 mr_bones_ Exp $
inherit games
@@ -29,27 +29,27 @@ S="${WORKDIR}/csmash-${PV}"
src_unpack() {
unpack csmash-${PV}.tar.gz
- cd ${S}
+ cd "${S}"
if use oggvorbis ; then
- cp ${DISTDIR}/${MY_OGG} ${S}/ || die "cp failed"
+ cp "${DISTDIR}/${MY_OGG}" "${S}/" || die "cp failed"
sed -i \
-e "s:${MY_OGG}:${GAMES_DATADIR}/csmash/${MY_OGG}:" ttinc.h \
- || die "setting ogg loc"
+ || die "setting ogg loc"
fi
}
src_compile() {
egamesconf \
- `use_enable nls` \
+ $(use_enable nls) \
--datadir="${GAMES_DATADIR_BASE}" \
|| die
- emake || die "emake failed"
+ emake \
+ localedir="/usr/share" \
+ || die "emake failed"
}
src_install() {
- egamesinstall \
- datadir="${D}/${GAMES_DATADIR_BASE}" \
- || die
+ make DESTDIR="${D}" install || die "make install failed"
if use oggvorbis ; then
insinto "${GAMES_DATADIR}/csmash"
doins "${MY_OGG}"