summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-12-14 11:27:31 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-12-14 11:27:31 +0000
commit01a804f5b3772a5eecf704c715c7c2a8ae51975e (patch)
treec75e3afcf7701200a573d41feb279c527bc92b62 /games-server
parentVersion bump. (diff)
downloadgentoo-2-01a804f5b3772a5eecf704c715c7c2a8ae51975e.tar.gz
gentoo-2-01a804f5b3772a5eecf704c715c7c2a8ae51975e.tar.bz2
gentoo-2-01a804f5b3772a5eecf704c715c7c2a8ae51975e.zip
Version bump to 0.5.15
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/cyphesis/ChangeLog8
-rw-r--r--games-server/cyphesis/cyphesis-0.5.15.ebuild40
-rw-r--r--games-server/cyphesis/files/cyphesis-0.5.15-gentoo.patch40
-rw-r--r--games-server/cyphesis/files/digest-cyphesis-0.5.153
4 files changed, 90 insertions, 1 deletions
diff --git a/games-server/cyphesis/ChangeLog b/games-server/cyphesis/ChangeLog
index 1d6048b19e44..24d91a0a967b 100644
--- a/games-server/cyphesis/ChangeLog
+++ b/games-server/cyphesis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-server/cyphesis
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.4 2007/11/03 11:10:45 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/ChangeLog,v 1.5 2007/12/14 11:27:31 tupone Exp $
+
+*cyphesis-0.5.15 (14 Dec 2007)
+
+ 14 Dec 2007; Tupone Alfredo <tupone@gentoo.org>
+ +files/cyphesis-0.5.15-gentoo.patch, +cyphesis-0.5.15.ebuild:
+ Version bump to 0.5.15
*cyphesis-0.5.14 (03 Nov 2007)
diff --git a/games-server/cyphesis/cyphesis-0.5.15.ebuild b/games-server/cyphesis/cyphesis-0.5.15.ebuild
new file mode 100644
index 000000000000..53958a167c58
--- /dev/null
+++ b/games-server/cyphesis/cyphesis-0.5.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/cyphesis-0.5.15.ebuild,v 1.1 2007/12/14 11:27:31 tupone Exp $
+
+inherit eutils autotools games
+
+DESCRIPTION="WorldForge server running small games"
+HOMEPAGE="http://worldforge.org/dev/eng/servers/cyphesis"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/skstream-0.3.6
+ sys-libs/readline
+ >=dev-games/wfmath-0.3
+ =dev-games/mercator-0.2*
+ dev-libs/libgcrypt
+ =dev-libs/libsigc++-2.0*
+ =media-libs/atlas-c++-0.6*
+ >=media-libs/varconf-0.6.4
+ dev-db/libpq"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Patching to disable howl and avahi discovery
+ # To be removed when upstream will provide a way to selectively
+ # enable/disable supoort for it
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
+ prepgamesdirs
+}
diff --git a/games-server/cyphesis/files/cyphesis-0.5.15-gentoo.patch b/games-server/cyphesis/files/cyphesis-0.5.15-gentoo.patch
new file mode 100644
index 000000000000..b7b4fa543e60
--- /dev/null
+++ b/games-server/cyphesis/files/cyphesis-0.5.15-gentoo.patch
@@ -0,0 +1,40 @@
+--- configure.ac.old 2007-01-31 23:22:11.000000000 +0100
++++ configure.ac 2007-01-31 23:22:40.000000000 +0100
+@@ -258,26 +258,6 @@
+ AC_MSG_ERROR([Cannot find valid versions of required WorldForge maths library, wfmath. Please see http://worldforge.org/dev/eng/servers/cyphesis for details of the libraries required and where to obtain them.])
+ ])
+
+-PKG_CHECK_MODULES(AVAHI, avahi-client,
+- [
+- CPPFLAGS="$CPPFLAGS $AVAHI_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $AVAHI_LIBS"
+- AC_DEFINE(HAVE_AVAHI, 1, [Define to 1 if you have avahi libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- PKG_CHECK_MODULES(HOWL, howl,
+- [
+- CPPFLAGS="$CPPFLAGS $HOWL_CFLAGS"
+- MDNS_LIBS="$MDNS_LIBS $HOWL_LIBS"
+- AC_DEFINE(HAVE_LIBHOWL, 1, [Define to 1 if you have howl libs.])
+- ],
+- [
+- AC_MSG_RESULT([no])
+- AC_MSG_NOTICE([Ommiting DNS-SD functionality.])
+- ])
+- ])
+-
+ AM_PATH_PSQL(7.1.0,
+ [
+ if test "$PG_CFLAGS" != "-I/usr/include"; then
+--- rulesets/Makefile.am.old 2007-11-03 11:56:49.000000000 +0100
++++ rulesets/Makefile.am 2007-11-03 11:57:10.000000000 +0100
+@@ -4,7 +4,7 @@
+
+ RULESETS = basic/mind mason
+
+-moduledir = $(DESTDIR)$(datadir)/cyphesis/scripts/cyphesis
++moduledir = $(datadir)/cyphesis/scripts/cyphesis
+ dist_module_DATA = basic/__init__.py \
+ basic/world/objects/Thing.py \
+ basic/world/probability.py \
diff --git a/games-server/cyphesis/files/digest-cyphesis-0.5.15 b/games-server/cyphesis/files/digest-cyphesis-0.5.15
new file mode 100644
index 000000000000..724b3e240c6f
--- /dev/null
+++ b/games-server/cyphesis/files/digest-cyphesis-0.5.15
@@ -0,0 +1,3 @@
+MD5 15a430ce941b30bff55e475facb48b95 cyphesis-0.5.15.tar.bz2 549050
+RMD160 26680668ec2f0523560112fce0ff63cefca87a17 cyphesis-0.5.15.tar.bz2 549050
+SHA256 c1220e222d7588c27b1cd0a1ac6605a0c26d13fedaecc5469129d32448cc2767 cyphesis-0.5.15.tar.bz2 549050