summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-02 23:49:37 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-02 23:49:37 +0000
commit90a23fefc5d5855337b83ccb69fd7fc8bec8f155 (patch)
treea11e22e4cc2cc56aea6d2a196d13bb81d16fd2a6 /games-rpg
parentMigrate to python-any-r1 (strictly build-time dependency on Python). (diff)
downloadgentoo-2-90a23fefc5d5855337b83ccb69fd7fc8bec8f155.tar.gz
gentoo-2-90a23fefc5d5855337b83ccb69fd7fc8bec8f155.tar.bz2
gentoo-2-90a23fefc5d5855337b83ccb69fd7fc8bec8f155.zip
version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/drascula/ChangeLog9
-rw-r--r--games-rpg/drascula/drascula-1.0-r2.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/games-rpg/drascula/ChangeLog b/games-rpg/drascula/ChangeLog
index 5fba80a1c295..01d804daae6f 100644
--- a/games-rpg/drascula/ChangeLog
+++ b/games-rpg/drascula/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/drascula
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/drascula/ChangeLog,v 1.6 2011/03/14 11:21:01 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/drascula/ChangeLog,v 1.7 2013/02/02 23:49:37 hasufell Exp $
+
+*drascula-1.0-r2 (02 Feb 2013)
+
+ 02 Feb 2013; Julian Ospald <hasufell@gentoo.org> +drascula-1.0-r2.ebuild:
+ version bump
14 Mar 2011; Alfredo Tupone <tupone@gentoo.org> drascula-1.0-r1.ebuild,
metadata.xml:
diff --git a/games-rpg/drascula/drascula-1.0-r2.ebuild b/games-rpg/drascula/drascula-1.0-r2.ebuild
new file mode 100644
index 000000000000..14c3392ed878
--- /dev/null
+++ b/games-rpg/drascula/drascula-1.0-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/drascula/drascula-1.0-r2.ebuild,v 1.1 2013/02/02 23:49:37 hasufell Exp $
+
+EAPI=5
+inherit eutils games
+
+INT_PV=1.1
+INT_URI="mirror://sourceforge/scummvm/drascula-int-${INT_PV}.zip"
+DAT_PV=1.5.0
+AUD_PV=2.0
+DESCRIPTION="Drascula: The Vampire Strikes Back"
+HOMEPAGE="http://www.alcachofasoft.com/"
+SRC_URI="mirror://sourceforge/scummvm/drascula-${PV}.zip
+ https://github.com/scummvm/scummvm/raw/v1.5.0/dists/engine-data/drascula.dat -> drascula-${DAT_PV}.dat
+ sound? ( mirror://sourceforge/scummvm/drascula-audio-${AUD_PV}.zip )
+ linguas_es? ( ${INT_URI} )
+ linguas_de? ( ${INT_URI} )
+ linguas_fr? ( ${INT_URI} )
+ linguas_it? ( ${INT_URI} )"
+
+LICENSE="drascula"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_es linguas_de linguas_fr linguas_it +sound"
+RESTRICT="mirror"
+
+RDEPEND=">=games-engines/scummvm-0.13.1"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ if use linguas_es || use linguas_de || use linguas_fr || use linguas_it; then
+ unpack drascula-int-${INT_PV}.zip
+ fi
+ if use sound; then
+ unpack drascula-audio-${AUD_PV}.zip
+ fi
+ unpack drascula-${PV}.zip
+}
+
+src_install() {
+ local lang
+
+ games_make_wrapper ${PN} "scummvm -f -p \"${GAMES_DATADIR}/${PN}\" drascula" .
+ for lang in es de fr it
+ do
+ if use linguas_${lang} ; then
+ games_make_wrapper ${PN}-${lang} "scummvm -q ${lang} -f -p \"${GAMES_DATADIR}/${PN}\" drascula" .
+ make_desktop_entry ${PN}-${lang} "Drascula: The Vampire Strikes Back (${lang})" ${PN}
+ fi
+ done
+ insinto "${GAMES_DATADIR}"/${PN}
+ find . -name "P*.*" -execdir doins '{}' +
+ newins "${DISTDIR}"/drascula-${DAT_PV}.dat drascula.dat
+ if use sound; then
+ doins audio/*
+ fi
+ dodoc readme.txt drascula.doc
+ make_desktop_entry ${PN} "Drascula: The Vampire Strikes Back"
+ prepgamesdirs
+}