summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-28 09:21:45 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-28 09:21:45 +0000
commit74870bff91a629e6debd5a1a78fb0e4331d3c739 (patch)
tree92741f1b6d33fa95c014d70c1476180ce354522d /games-rpg
parentVersion bumps (Manifest recommit) (diff)
downloadgentoo-2-74870bff91a629e6debd5a1a78fb0e4331d3c739.tar.gz
gentoo-2-74870bff91a629e6debd5a1a78fb0e4331d3c739.tar.bz2
gentoo-2-74870bff91a629e6debd5a1a78fb0e4331d3c739.zip
ver bump #43033
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/nwn/ChangeLog7
-rw-r--r--games-rpg/nwn/files/digest-nwn-1.622
-rw-r--r--games-rpg/nwn/files/nwn-1.62-fixinstall93
-rw-r--r--games-rpg/nwn/nwn-1.62.ebuild85
4 files changed, 186 insertions, 1 deletions
diff --git a/games-rpg/nwn/ChangeLog b/games-rpg/nwn/ChangeLog
index 5fc01fc424fc..0e8190db9384 100644
--- a/games-rpg/nwn/ChangeLog
+++ b/games-rpg/nwn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/nwn
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/ChangeLog,v 1.6 2004/01/16 00:17:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/ChangeLog,v 1.7 2004/02/28 09:21:45 vapier Exp $
+
+*nwn-1.62 (28 Feb 2004)
+
+ 28 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #43033 by Luca Santarelli.
*nwn-1.61-r1 (14 Jan 2004)
diff --git a/games-rpg/nwn/files/digest-nwn-1.62 b/games-rpg/nwn/files/digest-nwn-1.62
new file mode 100644
index 000000000000..ce176aaa41e8
--- /dev/null
+++ b/games-rpg/nwn/files/digest-nwn-1.62
@@ -0,0 +1,2 @@
+MD5 73c6515fd6aa5f860802098a55000ae8 nwclient129.tar.gz 5504342
+MD5 89f373e0a5e0042912a3a214ebf4436b linuxclientupdate129to162eng.tar.gz 71917130
diff --git a/games-rpg/nwn/files/nwn-1.62-fixinstall b/games-rpg/nwn/files/nwn-1.62-fixinstall
new file mode 100644
index 000000000000..a1e6063df9b6
--- /dev/null
+++ b/games-rpg/nwn/files/nwn-1.62-fixinstall
@@ -0,0 +1,93 @@
+#!/bin/bash
+# Initial version by Bioware
+# Modified to match the gentoo setup
+# 03/27/2003 phoen][x <phoenix@gentoo.org>
+
+cd GENTOO_DIR/nwn
+
+FaRequiredDirs=(ambient data music override miles nwm)
+aRequiredFiles=(chitin.key dialog.tlk nwmain patch.key)
+aLCDirs=(ambient data dmvault hak localvault music override portraits)
+aProblemFiles=()
+
+printf "\nFixing case\n\n"
+
+if [ -f dialog.TLK ]
+then
+ mv dialog.TLK dialog.tlk
+fi
+
+if [ -f dialogF.TLK ]
+then
+ mv dialogF.TLK dialogf.tlk
+fi
+
+printf "Checking for required files\n\n"
+
+for d in ${aRequiredDirs[@]}
+do
+ if [ -d $d ]
+ then
+ printf "PASSED: $d directory exists\n"
+ else
+ printf "FAILED: $d directory missing\n"
+ exit
+ fi
+done
+
+for f in ${aRequiredFiles[@]}
+do
+ if [ -f $f ]
+ then
+ printf "PASSED: $f exists\n"
+ else
+ printf "FAILED: $f missing\n"
+ exit
+ fi
+done
+
+printf "\nFixing case\n\n"
+
+for d in ${aLCDirs[@]}
+do
+ if [ -d $d ]
+ then
+ printf "$d\n"
+
+ cd $d
+
+ for f in $(find *.*)
+ do
+ lcf=$(echo $f | tr [:upper:] [:lower:])
+ if [ $f != $lcf ]
+ then
+ if [ -f $f ]
+ then
+ mv $f $(echo $f | tr [:upper:] [:lower:])
+ fi
+ fi
+ printf .
+ done
+
+ cd ..
+
+ printf "\n"
+ fi
+done
+
+printf "\nChecking for problem files\n\n"
+
+for f in ${aProblemFiles[@]}
+do
+ if [ -f $f ]
+ then
+ printf "WARNING: $f exists, deleting this file is recommended\n"
+ fi
+done
+
+printf "\nFixing permissions\n\n"
+
+chown GENTOO_USER:GENTOO_GROUP GENTOO_DIR/nwn/ -R
+chmod g+rwX GENTOO_DIR/nwn/ -R
+
+printf "\nYou are ready to run Neverwinter Nights.\n\n"
diff --git a/games-rpg/nwn/nwn-1.62.ebuild b/games-rpg/nwn/nwn-1.62.ebuild
new file mode 100644
index 000000000000..8de4a70b5792
--- /dev/null
+++ b/games-rpg/nwn/nwn-1.62.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/nwn-1.62.ebuild,v 1.1 2004/02/28 09:21:45 vapier Exp $
+
+inherit games
+
+UPDATEVER=${PV//.}
+DESCRIPTION="Never Winter Nights"
+HOMEPAGE="http://nwn.bioware.com/downloads/linuxclient.html"
+SRC_URI="http://nwdownloads.bioware.com/neverwinternights/linux/129/nwclient129.tar.gz
+ nowin? ( ftp://jeuxlinux.com/bioware/Neverwinter_Nights/nwresources129.tar.gz )
+ http://nwdownloads.bioware.com/neverwinternights/linux/${UPDATEVER}/linuxclientupdate129to${UPDATEVER}eng.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="nowin"
+RESTRICT="nostrip nomirror"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=media-libs/libsdl-1.2.5"
+
+S=${WORKDIR}/nwn
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack nwclient129.tar.gz
+ cd ${WORKDIR}
+ use nowin && unpack nwresources129.tar.gz
+ cd ${S}
+ unpack linuxclientupdate129to${UPDATEVER}eng.tar.gz
+}
+
+src_install() {
+ dodir ${GAMES_PREFIX_OPT}
+ sed \
+ -e "s:GENTOO_USER:${GAMES_USER}:" \
+ -e "s:GENTOO_GROUP:${GAMES_GROUP}:" \
+ -e "s:GENTOO_DIR:${GAMES_PREFIX_OPT}:" \
+ ${FILESDIR}/${P}-fixinstall > ${WORKDIR}/nwn/fixinstall
+ mv ${WORKDIR}/nwn ${D}/${GAMES_PREFIX_OPT}
+ dogamesbin ${FILESDIR}/nwn
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if [ ! `use nowin` ] ; then
+ einfo "The NWN linux client is now installed."
+ einfo "Proceed with the following steps in order to get it working:"
+ einfo "1) Copy the following directories/files from your installed and"
+ einfo " patched (${PV}) Never Winter Nights to ${GAMES_PREFIX_OPT}/nwn:"
+ einfo " ambient/"
+ einfo " data/"
+ einfo " dmvault/"
+ einfo " hak/"
+ einfo " localvault/"
+ einfo " modules/"
+ einfo " music/"
+ einfo " nwm/"
+ einfo " override/"
+ einfo " portraits/"
+ einfo " saves/"
+ einfo " servervault/"
+ einfo " texturepacks/"
+ einfo " chitin.key"
+ einfo " patch.key"
+ einfo " dialog.tlk"
+ einfo " dialogF.tlk (French, German, Italian, and Spanish)"
+ einfo "2) Chown and chmod the files with the following commands"
+ einfo " chown -R ${GAMES_USER}:${GAMES_GROUP} ${GAMES_PREFIX_OPT}/nwn"
+ einfo " chmod -R g+rwX ${GAMES_PREFIX_OPT}/nwn"
+ einfo "3) Run ${GAMES_PREFIX_OPT}/nwn/fixinstall as root"
+ einfo "4) Make sure that you are in group ${GAMES_GROUP}"
+ einfo "5) Use ${GAMES_PREFIX_OPT}/nwn/nwn to run the game"
+ echo
+ einfo "Or try emerging with USE=nowin"
+ else
+ einfo "The NWN linux client is now installed."
+ einfo "Proceed with the following step in order to get it working:"
+ einfo "Run ${GAMES_PREFIX_OPT}/nwn/fixinstall as root"
+ fi
+}