summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-17 01:47:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-17 01:47:44 +0000
commitcbed61aeaf392723cea6fdc7bab2ee47f99f7a55 (patch)
tree4f2bd086f51ba2ad695def9d09d2d78257573c9a /games-roguelike
parentAdd bug number to dev-cpp/libwefts mask comment (diff)
downloadgentoo-2-cbed61aeaf392723cea6fdc7bab2ee47f99f7a55.tar.gz
gentoo-2-cbed61aeaf392723cea6fdc7bab2ee47f99f7a55.tar.bz2
gentoo-2-cbed61aeaf392723cea6fdc7bab2ee47f99f7a55.zip
patch for building with gcc-4.3 from Marek Miller via bug #227063
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/ivan/ChangeLog8
-rw-r--r--games-roguelike/ivan/files/ivan-0.50-gcc43.patch12
-rw-r--r--games-roguelike/ivan/ivan-0.50.ebuild7
3 files changed, 22 insertions, 5 deletions
diff --git a/games-roguelike/ivan/ChangeLog b/games-roguelike/ivan/ChangeLog
index f3d944bf1e8c..80c5478a24fc 100644
--- a/games-roguelike/ivan/ChangeLog
+++ b/games-roguelike/ivan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/ivan
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ChangeLog,v 1.11 2007/02/03 10:56:23 nyhm Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ChangeLog,v 1.12 2008/06/17 01:47:44 mr_bones_ Exp $
+
+ 17 Jun 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/ivan-0.50-gcc43.patch, ivan-0.50.ebuild:
+ patch for building with gcc-4.3 from Marek Miller via bug #227063
03 Feb 2007; Tristan Heaven <nyhm@gentoo.org>
+files/ivan-0.50-install.patch, ivan-0.50.ebuild:
diff --git a/games-roguelike/ivan/files/ivan-0.50-gcc43.patch b/games-roguelike/ivan/files/ivan-0.50-gcc43.patch
new file mode 100644
index 000000000000..4a4a867a8245
--- /dev/null
+++ b/games-roguelike/ivan/files/ivan-0.50-gcc43.patch
@@ -0,0 +1,12 @@
+--- FeLib/Source/festring.cpp.orig 2008-06-15 14:30:51.000000000 +0000
++++ FeLib/Source/festring.cpp 2008-06-15 14:31:01.000000000 +0000
+@@ -11,6 +11,8 @@
+ */
+
+ #include <cctype>
++#include <cstdlib>
++
+
+ #include "festring.h"
+ #include "allocate.h"
+
diff --git a/games-roguelike/ivan/ivan-0.50.ebuild b/games-roguelike/ivan/ivan-0.50.ebuild
index ec470450f152..06a98a6e7912 100644
--- a/games-roguelike/ivan/ivan-0.50.ebuild
+++ b/games-roguelike/ivan/ivan-0.50.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ivan-0.50.ebuild,v 1.7 2007/02/03 10:56:23 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/ivan/ivan-0.50.ebuild,v 1.8 2008/06/17 01:47:44 mr_bones_ Exp $
inherit eutils flag-o-matic games
@@ -20,7 +20,8 @@ src_unpack() {
cd "${S}"
epatch \
"${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}"/${P}-install.patch
+ "${FILESDIR}"/${P}-install.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {