summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-07-04 02:23:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-07-04 02:23:52 +0000
commit8c9f019294cc94fc526fee1aca4aa28e50ecd16a (patch)
tree2bac2b449816f35bdfa2587bbdef47f432af29a2 /games-roguelike
parentBug #138199 - fix for using autoconf-2.60. (diff)
downloadgentoo-2-8c9f019294cc94fc526fee1aca4aa28e50ecd16a.tar.gz
gentoo-2-8c9f019294cc94fc526fee1aca4aa28e50ecd16a.tar.bz2
gentoo-2-8c9f019294cc94fc526fee1aca4aa28e50ecd16a.zip
version bump
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog8
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild59
-rw-r--r--games-roguelike/crossfire-client/files/digest-crossfire-client-1.9.13
3 files changed, 69 insertions, 1 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index ab4565c7dfc2..043d40f78b61 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/crossfire-client
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.15 2006/04/13 22:07:04 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.16 2006/07/04 02:23:52 mr_bones_ Exp $
+
+*crossfire-client-1.9.1 (04 Jul 2006)
+
+ 04 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +crossfire-client-1.9.1.ebuild:
+ version bump
13 Apr 2006; <Tupone@gentoo.org> crossfire-client-1.9.0.ebuild:
Added ~amd64 keyword, request #129768 by Chris Torske
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild
new file mode 100644
index 000000000000..71ff49f5e40c
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.9.1.ebuild,v 1.1 2006/07/04 02:23:52 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="alsa gtk oss sdl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ gtk? ( >=x11-libs/gtk+-2
+ sdl? ( media-libs/libsdl
+ media-libs/sdl-image ) )
+ virtual/glut
+ media-libs/libpng
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -r 's:TH (g?)cfclient:TH \1cfclient 6:' \
+ {gtk,x11}/*cfclient.man \
+ || die "sed failed"
+}
+
+src_compile() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf="--disable-dependency-tracking"
+
+ if use gtk ; then
+ use sdl || myconf="${myconf} --disable-sdl"
+ else
+ myconf="${myconf} --disable-gtk"
+ fi
+ if ! use alsa ; then
+ myconf="${myconf} --disable-alsa9 --disable-alsa"
+ fi
+ if ! use alsa && ! use oss ; then
+ myconf="${myconf} --disable-sound"
+ fi
+ egamesconf ${myconf} || die
+ emake -j1 -C sound-src || die "sound building failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ prepgamesdirs
+}
diff --git a/games-roguelike/crossfire-client/files/digest-crossfire-client-1.9.1 b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.9.1
new file mode 100644
index 000000000000..fd3d42ad1444
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.9.1
@@ -0,0 +1,3 @@
+MD5 e7084c22c1f2074c95fe34331ac2ceae crossfire-client-1.9.1.tar.gz 753757
+RMD160 0a63410fc85db825c2de1407e308b0e7ca84527e crossfire-client-1.9.1.tar.gz 753757
+SHA256 8c505bcb1031da18866747d8fc4dc5ab8c67aa28387eb761794ab0672b49e6bc crossfire-client-1.9.1.tar.gz 753757