summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-12-30 15:27:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-12-30 15:27:41 +0000
commit53ff3d52897cb3b8df1d554d6f49b39d4a2e63ff (patch)
tree94fb2b9400cffe5610d5d9b02da2ea1e6ce0fb3b /games-roguelike
parentversion bump (diff)
downloadgentoo-2-53ff3d52897cb3b8df1d554d6f49b39d4a2e63ff.tar.gz
gentoo-2-53ff3d52897cb3b8df1d554d6f49b39d4a2e63ff.tar.bz2
gentoo-2-53ff3d52897cb3b8df1d554d6f49b39d4a2e63ff.zip
old
(Portage version: 2.1.4.5)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/scourge/files/scourge-0.20-gcc43.patch150
-rw-r--r--games-roguelike/scourge/scourge-0.20.ebuild55
-rw-r--r--games-roguelike/scourge/scourge-0.21.ebuild48
3 files changed, 0 insertions, 253 deletions
diff --git a/games-roguelike/scourge/files/scourge-0.20-gcc43.patch b/games-roguelike/scourge/files/scourge-0.20-gcc43.patch
deleted file mode 100644
index ad2a7aafeddd..000000000000
--- a/games-roguelike/scourge/files/scourge-0.20-gcc43.patch
+++ /dev/null
@@ -1,150 +0,0 @@
---- src/userconfiguration.cpp.old 2008-08-27 20:11:29.000000000 +0200
-+++ src/userconfiguration.cpp 2008-08-27 20:16:05.000000000 +0200
-@@ -1055,7 +1055,7 @@
- }
-
- void UserConfiguration::replaceSpaces(string& s) {
-- replace(s.begin(), s.end(), ' ', '_');
-+ s.replace(s.begin(), s.end(), ' ', '_');
- }
-
- UserConfiguration::~UserConfiguration(){
---- src/tools/dfbooks.cpp.old 2008-08-28 20:59:56.000000000 +0200
-+++ src/tools/dfbooks.cpp 2008-08-28 21:00:27.000000000 +0200
-@@ -49,7 +49,7 @@
- generalBooks.push_back(data[i]);
- }
-
-- std::ofstream fout( GetDataPath("%s/world/booksTEST"), std::ios::binary);
-+ std::ofstream fout( GetDataPath("%s/world/booksTEST").c_str(), std::ios::binary);
-
- fout << "# Random texts found in books and notes.\n#\n# Key:\n# B: Book Name, rareness"
- << "# M: Mission name (optional: from missions.txt)\n# T: multi-line text\n# \n\n"
---- src/tools/dfcreatures.cpp.old 2008-08-28 21:01:14.000000000 +0200
-+++ src/tools/dfcreatures.cpp 2008-08-28 21:01:36.000000000 +0200
-@@ -67,7 +67,7 @@
-
- void DFCreatures::Save()
- {
-- std::ofstream fout( GetDataPath("%s/world/creaturesTEST"), std::ios::binary );
-+ std::ofstream fout( GetDataPath("%s/world/creaturesTEST").c_str(), std::ios::binary );
-
- fout << "# Creatures\n"
- << "# \n"
---- src/tools/dfgui.cpp.old 2008-08-28 21:02:13.000000000 +0200
-+++ src/tools/dfgui.cpp 2008-08-28 21:02:31.000000000 +0200
-@@ -167,7 +167,7 @@
-
- void DFGui::Save()
- {
-- std::ofstream fout( GetDataPath("%s/world/guiTEST"), std::ios::binary);
-+ std::ofstream fout( GetDataPath("%s/world/guiTEST").c_str(), std::ios::binary);
-
- fout << "# gui themes key:\n# (non-existing textures will appear as pure color)"
- << "\n#\n# T:theme name\n# each row is either an \"element\" (like window background) or a \"color\" like a text color."
---- src/tools/dfmissions.cpp.old 2008-08-28 21:03:00.000000000 +0200
-+++ src/tools/dfmissions.cpp 2008-08-28 21:03:13.000000000 +0200
-@@ -124,7 +124,7 @@
- else
- generalMissions.push_back( *itr );
- }
-- std::ofstream fout( GetDataPath("%s/world/missionsTEST"), std::ios::binary);
-+ std::ofstream fout( GetDataPath("%s/world/missionsTEST").c_str(), std::ios::binary);
-
- fout << "##########################################################\n"
- << "# Templated missions\n# Key:\n# M:type,mission template name\n"
---- src/tools/dfskills.cpp.old 2008-08-28 21:03:48.000000000 +0200
-+++ src/tools/dfskills.cpp 2008-08-28 21:04:01.000000000 +0200
-@@ -44,7 +44,7 @@
-
- void DFSkills::Save()
- {
-- std::ofstream fout( GetDataPath("%s/world/skillsTEST"), std::ios::binary);
-+ std::ofstream fout( GetDataPath("%s/world/skillsTEST").c_str(), std::ios::binary);
-
- /**
- * Possible improvement: set out skills in class sections as already done in skills.txt
---- src/tools/dfspells.cpp.old 2008-08-28 21:04:28.000000000 +0200
-+++ src/tools/dfspells.cpp 2008-08-28 21:04:40.000000000 +0200
-@@ -111,7 +111,7 @@
-
- void DFSpells::Save()
- {
-- std::ofstream fout( GetDataPath("%s/world/spellsTEST"), std::ios::binary );
-+ std::ofstream fout( GetDataPath("%s/world/spellsTEST").c_str(), std::ios::binary );
-
- fout << "#\n"
- "# key: \n"
---- src/tools/dflocations.cpp.old 2008-08-28 21:05:14.000000000 +0200
-+++ src/tools/dflocations.cpp 2008-08-28 21:05:27.000000000 +0200
-@@ -28,7 +28,7 @@
-
- void DFLocations::Save()
- {
-- std::ofstream fout( GetDataPath("%s/world/locationsTEST"), std::ios::binary);
-+ std::ofstream fout( GetDataPath("%s/world/locationsTEST").c_str(), std::ios::binary);
-
- fout << "# Locations of relevant places on the scourge map.\n"
- << "# Key:\n"
---- src/tools/dfrpg.cpp.old 2008-08-28 21:05:53.000000000 +0200
-+++ src/tools/dfrpg.cpp 2008-08-28 21:06:10.000000000 +0200
-@@ -150,7 +150,7 @@
-
- void DFRpg::Save()
- {
-- std::ofstream fout( GetDataPath("%s/world/rpgTEST"), std::ios::binary );
-+ std::ofstream fout( GetDataPath("%s/world/rpgTEST").c_str(), std::ios::binary );
-
- fout << "# Key:\n"
- << "# G: group name, descriptive name\n"
---- src/tools/Makefile.am.old 2008-08-28 21:08:30.000000000 +0200
-+++ src/tools/Makefile.am 2008-08-28 21:08:56.000000000 +0200
-@@ -56,6 +56,8 @@
- subpageitemtags.cpp\
- subpageitemtags.h\
- subpagenames.cpp\
-- subpagenames.h
-+ subpagenames.h\
-+ ../util.cpp\
-+ ../util.h
-
-
---- src/tools/main.cpp.old 2008-08-28 21:34:28.000000000 +0200
-+++ src/tools/main.cpp 2008-08-28 21:35:03.000000000 +0200
-@@ -96,28 +96,28 @@
- bool MyApp::OnInit()
- {
- DFBooks *dfBooks = new DFBooks;
-- dfBooks->Load( GetDataPath("%s/world/books.txt"), "B");
-+ dfBooks->Load( GetDataPath("/world/books.txt"), "B");
-
- DFMissions *dfMissions = new DFMissions;
-- dfMissions->Load( GetDataPath("%s/world/missions.txt"), "MT");
-+ dfMissions->Load( GetDataPath("/world/missions.txt"), "MT");
-
- DFGui *dfGui = new DFGui;
-- dfGui->Load( GetDataPath("%s/world/gui.txt"), "T");
-+ dfGui->Load( GetDataPath("/world/gui.txt"), "T");
-
- DFSkills *dfSkills = new DFSkills;
-- dfSkills->Load( GetDataPath("%s/world/skills.txt"), "S");
-+ dfSkills->Load( GetDataPath("/world/skills.txt"), "S");
-
- DFSpells *dfSpells = new DFSpells;
-- dfSpells->Load( GetDataPath("%s/world/spells.txt"), "S");
-+ dfSpells->Load( GetDataPath("/world/spells.txt"), "S");
-
- DFCreatures *dfCreatures = new DFCreatures;
-- dfCreatures->Load( GetDataPath("%s/world/creatures.txt"), "M");
-+ dfCreatures->Load( GetDataPath("/world/creatures.txt"), "M");
-
- DFLocations *dfLocations = new DFLocations;
-- dfLocations->Load( GetDataPath("%s/world/locations.txt"), "L");
-+ dfLocations->Load( GetDataPath("/world/locations.txt"), "L");
-
- DFRpg *dfRpg = new DFRpg;
-- dfRpg->Load( GetDataPath("%s/world/rpg.txt"), "GTF");
-+ dfRpg->Load( GetDataPath("/world/rpg.txt"), "GTF");
-
-
- g_DFList["Books"] = dfBooks;
diff --git a/games-roguelike/scourge/scourge-0.20.ebuild b/games-roguelike/scourge/scourge-0.20.ebuild
deleted file mode 100644
index 4889a6fa9a5b..000000000000
--- a/games-roguelike/scourge/scourge-0.20.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.20.ebuild,v 1.1 2008/08/29 06:25:33 tupone Exp $
-
-inherit autotools eutils wxwidgets games
-
-DESCRIPTION="A graphical rogue-like adventure game"
-HOMEPAGE="http://scourgeweb.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz
- mirror://sourceforge/${PN}/${P}.data.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="virtual/glu
- virtual/opengl
- >=media-libs/freetype-2
- media-libs/libsdl
- media-libs/sdl-net
- media-libs/sdl-mixer
- media-libs/sdl-ttf
- virtual/libintl
- "
-DEPEND="${RDEPEND}
- sys-devel/gettext"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
- eautoreconf
-}
-
-src_compile() {
- egamesconf \
- --disable-dependency-tracking \
- --with-data-dir="${GAMES_DATADIR}"/${PN} \
- --localedir=/usr/share/locale \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r ../scourge_data/* || die "doins failed"
- doicon assets/scourge.png
- make_desktop_entry scourge S.C.O.U.R.G.E.
- dodoc AUTHORS README
- prepgamesdirs
-}
diff --git a/games-roguelike/scourge/scourge-0.21.ebuild b/games-roguelike/scourge/scourge-0.21.ebuild
deleted file mode 100644
index 1985c8f41086..000000000000
--- a/games-roguelike/scourge/scourge-0.21.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.21.ebuild,v 1.1 2008/12/20 05:30:38 mr_bones_ Exp $
-
-inherit eutils wxwidgets games
-
-DESCRIPTION="A graphical rogue-like adventure game"
-HOMEPAGE="http://scourgeweb.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz
- mirror://sourceforge/${PN}/${P}.data.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="virtual/glu
- virtual/opengl
- >=media-libs/freetype-2
- media-libs/libsdl
- media-libs/sdl-net
- media-libs/sdl-mixer
- media-libs/sdl-ttf
- virtual/libintl
- "
-DEPEND="${RDEPEND}
- sys-devel/gettext"
-
-S=${WORKDIR}/${PN}
-
-src_compile() {
- egamesconf \
- --disable-dependency-tracking \
- --with-data-dir="${GAMES_DATADIR}"/${PN} \
- --localedir=/usr/share/locale \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r ../scourge_data/* || die "doins failed"
- doicon assets/scourge.png
- make_desktop_entry scourge S.C.O.U.R.G.E.
- dodoc AUTHORS README
- prepgamesdirs
-}