summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-10-30 17:06:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-10-30 17:06:07 +0000
commitd777e4145f4e1b13746b3eea8fa150907bd15c7a (patch)
treeee57e28b518f9d3aea2d355ce88723ee7bdf2d14 /games-puzzle
parentAdd ifunc checks for arm/hppa/ppc/s390. (diff)
downloadgentoo-2-d777e4145f4e1b13746b3eea8fa150907bd15c7a.tar.gz
gentoo-2-d777e4145f4e1b13746b3eea8fa150907bd15c7a.tar.bz2
gentoo-2-d777e4145f4e1b13746b3eea8fa150907bd15c7a.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ltris/ChangeLog8
-rw-r--r--games-puzzle/ltris/files/ltris-1.0.19-gentoo.patch51
-rw-r--r--games-puzzle/ltris/ltris-1.0.19.ebuild52
3 files changed, 110 insertions, 1 deletions
diff --git a/games-puzzle/ltris/ChangeLog b/games-puzzle/ltris/ChangeLog
index ad9b6b899e2f..42277de0caf2 100644
--- a/games-puzzle/ltris/ChangeLog
+++ b/games-puzzle/ltris/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/ltris
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ChangeLog,v 1.52 2013/01/22 20:15:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ChangeLog,v 1.53 2013/10/30 17:06:06 mr_bones_ Exp $
+
+*ltris-1.0.19 (30 Oct 2013)
+
+ 30 Oct 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/ltris-1.0.19-gentoo.patch, +ltris-1.0.19.ebuild:
+ version bump
22 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
-files/ltris-1.0.16-gentoo.patch, -files/ltris-1.0.17-gentoo.patch,
diff --git a/games-puzzle/ltris/files/ltris-1.0.19-gentoo.patch b/games-puzzle/ltris/files/ltris-1.0.19-gentoo.patch
new file mode 100644
index 000000000000..82acee7d33bc
--- /dev/null
+++ b/games-puzzle/ltris/files/ltris-1.0.19-gentoo.patch
@@ -0,0 +1,51 @@
+diff -ru ltris-1.0.15.orig/Makefile.am ltris-1.0.15/Makefile.am
+--- ltris-1.0.15.orig/Makefile.am 2010-09-20 13:26:05.000000000 -0400
++++ ltris-1.0.15/Makefile.am 2010-09-21 02:01:52.680858712 -0400
+@@ -1,21 +1,9 @@
+-SUBDIRS = intl m4 po src icons
++SUBDIRS = intl m4 po src
+
+ EXTRA_DIST = config.rpath AUTHORS COPYING ChangeLog INSTALL \
+ README TODO touchall ABOUT-NLS po/tr.po_full po/pt.po_full \
+-po/nonascii.pl ltris32.gif ltris48.gif ltris.desktop.in
+-
+-desktopdir = $(datadir)/applications
+-desktop_DATA = ltris.desktop
+-icondir = $(datadir)/icons
+-icon_DATA = ltris48.gif
++po/nonascii.pl
+
+ AUTOMAKE_OPTIONS = foreign
+
+-# We can't use static desktop file because of icon location. Is this
+-# the right way to handle it? At least it works... as long as $datadir
+-# does not contain plus signs. :-)
+-ltris.desktop:
+- @sed -e "s+Icon=+Icon=$(datadir)/icons/ltris48.gif+" \
+- < ltris.desktop.in > ltris.desktop
+-
+ ACLOCAL_AMFLAGS = -I m4
+diff -ru ltris-1.0.15.orig/configure.in ltris-1.0.15/configure.in
+--- ltris-1.0.15.orig/configure.in 2010-09-20 13:23:17.000000000 -0400
++++ ltris-1.0.15/configure.in 2010-09-21 02:02:22.418843746 -0400
+@@ -55,7 +55,7 @@
+ AC_SUBST(buf_flag)
+
+ dnl set localedir
+-localedir=$datadir/locale
++localedir=/usr/share/locale
+ locdir_flag="-DLOCALEDIR=\\\"$localedir\\\""
+
+ dnl installation path
+diff -ru ltris-1.0.15.orig/po/Makefile.in.in ltris-1.0.15/po/Makefile.in.in
+--- ltris-1.0.15.orig/po/Makefile.in.in 2005-10-04 14:41:03.000000000 -0400
++++ ltris-1.0.15/po/Makefile.in.in 2010-09-21 02:02:40.464207966 -0400
+@@ -23,7 +23,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = /usr/share/locale
+ gettextsrcdir = $(datadir)/gettext/po
+
+ INSTALL = @INSTALL@
diff --git a/games-puzzle/ltris/ltris-1.0.19.ebuild b/games-puzzle/ltris/ltris-1.0.19.ebuild
new file mode 100644
index 000000000000..23dd5e6b2528
--- /dev/null
+++ b/games-puzzle/ltris/ltris-1.0.19.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ltris-1.0.19.ebuild,v 1.1 2013/10/30 17:06:06 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools gnome2-utils eutils games
+
+DESCRIPTION="very polished Tetris clone"
+HOMEPAGE="http://lgames.sourceforge.net/index.php?project=LTris"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ egamesconf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README TODO
+ newicon icons/ltris48.xpm ${PN}.xpm
+ make_desktop_entry ltris LTris
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ games_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ games_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}