summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-24 08:39:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-24 08:39:46 +0000
commitd026daf72d8b3ea1a366470fe2684944a76ba459 (patch)
treeaf1c98a27d9384253661f36c3496489c13501ff3 /games-puzzle
parentversion bump (diff)
downloadgentoo-2-d026daf72d8b3ea1a366470fe2684944a76ba459.tar.gz
gentoo-2-d026daf72d8b3ea1a366470fe2684944a76ba459.tar.bz2
gentoo-2-d026daf72d8b3ea1a366470fe2684944a76ba459.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/groundhog/ChangeLog7
-rw-r--r--games-puzzle/groundhog/groundhog-1.4.ebuild22
2 files changed, 15 insertions, 14 deletions
diff --git a/games-puzzle/groundhog/ChangeLog b/games-puzzle/groundhog/ChangeLog
index cd57c87ece1b..8d37982fcaf6 100644
--- a/games-puzzle/groundhog/ChangeLog
+++ b/games-puzzle/groundhog/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/groundhog
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/ChangeLog,v 1.18 2012/07/29 20:49:21 hasufell Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/ChangeLog,v 1.19 2015/01/24 08:39:46 mr_bones_ Exp $
+
+ 24 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> groundhog-1.4.ebuild:
+ EAPI=5
29 Jul 2012; Julian Ospald <hasufell@gentoo.org> groundhog-1.4.ebuild,
+files/groundhog-1.4-flags.patch:
diff --git a/games-puzzle/groundhog/groundhog-1.4.ebuild b/games-puzzle/groundhog/groundhog-1.4.ebuild
index 5f6376a84e6e..257bceeb632a 100644
--- a/games-puzzle/groundhog/groundhog-1.4.ebuild
+++ b/games-puzzle/groundhog/groundhog-1.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/groundhog-1.4.ebuild,v 1.25 2012/07/29 20:49:21 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/groundhog-1.4.ebuild,v 1.26 2015/01/24 08:39:46 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils autotools games
DEB_VER="9"
@@ -27,23 +27,21 @@ src_prepare() {
epatch groundhog_${PV}-${DEB_VER}.diff
cd "${S}"
sed -e "s:groundhog-1.4/::" -i \
- debian/patches/sv.po.patch \
- || die "sed failed"
- epatch $(sed -e 's:^:debian/patches/:' debian/patches/series)
- epatch "${FILESDIR}"/${P}-flags.patch
+ debian/patches/sv.po.patch || die
+ epatch \
+ $(sed -e 's:^:debian/patches/:' debian/patches/series) \
+ "${FILESDIR}"/${P}-flags.patch
mv configure.in configure.ac || die
AT_M4DIR="m4" eautoreconf
sed -i 's:$(localedir):/usr/share/locale:' \
- $(find . -name 'Makefile.in*') \
- || die "sed failed"
+ $(find . -name 'Makefile.in*') || die
}
src_configure() {
- egamesconf $(use_enable nls) || die
+ egamesconf $(use_enable nls)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README NEWS AUTHORS TODO
+ default
prepgamesdirs
}