summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-07-07 03:28:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-07-07 03:28:03 +0000
commitce1a229f4771857fd9f9b6219082ca78d50db8c1 (patch)
treeae9ecc3d50db2927756529390367b294a7f61c36 /games-puzzle
parentMore syncing with older hardened profiles (diff)
downloadgentoo-2-ce1a229f4771857fd9f9b6219082ca78d50db8c1.tar.gz
gentoo-2-ce1a229f4771857fd9f9b6219082ca78d50db8c1.tar.bz2
gentoo-2-ce1a229f4771857fd9f9b6219082ca78d50db8c1.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/fish-fillets/ChangeLog9
-rw-r--r--games-puzzle/fish-fillets/files/fish-fillets-0.9.1-fribidi.patch21
-rw-r--r--games-puzzle/fish-fillets/files/fish-fillets-0.9.1-gcc43.patch38
-rw-r--r--games-puzzle/fish-fillets/fish-fillets-0.9.1.ebuild61
4 files changed, 128 insertions, 1 deletions
diff --git a/games-puzzle/fish-fillets/ChangeLog b/games-puzzle/fish-fillets/ChangeLog
index c29e084c6555..28f00165714a 100644
--- a/games-puzzle/fish-fillets/ChangeLog
+++ b/games-puzzle/fish-fillets/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-puzzle/fish-fillets
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/ChangeLog,v 1.39 2009/06/15 07:02:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/ChangeLog,v 1.40 2009/07/07 03:28:03 mr_bones_ Exp $
+
+*fish-fillets-0.9.1 (07 Jul 2009)
+
+ 07 Jul 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/fish-fillets-0.9.1-fribidi.patch,
+ +files/fish-fillets-0.9.1-gcc43.patch, +fish-fillets-0.9.1.ebuild:
+ version bump
*fish-fillets-0.9.0 (15 Jun 2009)
diff --git a/games-puzzle/fish-fillets/files/fish-fillets-0.9.1-fribidi.patch b/games-puzzle/fish-fillets/files/fish-fillets-0.9.1-fribidi.patch
new file mode 100644
index 000000000000..2e490ebe0014
--- /dev/null
+++ b/games-puzzle/fish-fillets/files/fish-fillets-0.9.1-fribidi.patch
@@ -0,0 +1,21 @@
+diff -ru fillets-ng-0.8.1.orig/src/effect/Font.cpp fillets-ng-0.8.1/src/effect/Font.cpp
+--- fillets-ng-0.8.1.orig/src/effect/Font.cpp 2006-01-05 23:31:18.000000000 +0100
++++ fillets-ng-0.8.1/src/effect/Font.cpp 2009-03-02 21:20:23.000000000 +0100
+@@ -26,7 +26,7 @@
+ FriBidiChar *logicalString = new FriBidiChar[text.length() + 1];
+ FriBidiChar *visualString = new FriBidiChar[text.length() + 1];
+
+- int ucsLength = fribidi_utf8_to_unicode(const_cast<char*>(text.c_str()),
++ int ucsLength = fribidi_charset_to_unicode(FRIBIDI_CHAR_SET_UTF8, const_cast<char*>(text.c_str()),
+ text.length(), logicalString);
+ fribidi_boolean ok = fribidi_log2vis(logicalString, ucsLength, &base,
+ visualString, NULL, NULL, NULL);
+@@ -37,7 +37,7 @@
+ }
+
+ char *buffer = new char[text.length() + 1];
+- int length = fribidi_unicode_to_utf8(visualString, ucsLength, buffer);
++ int length = fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_UTF8, visualString, ucsLength, buffer);
+ std::string result = std::string(buffer, length);
+ delete[] buffer;
+ delete[] visualString;
diff --git a/games-puzzle/fish-fillets/files/fish-fillets-0.9.1-gcc43.patch b/games-puzzle/fish-fillets/files/fish-fillets-0.9.1-gcc43.patch
new file mode 100644
index 000000000000..19b7ab86c895
--- /dev/null
+++ b/games-puzzle/fish-fillets/files/fish-fillets-0.9.1-gcc43.patch
@@ -0,0 +1,38 @@
+diff -ru fillets-ng-0.8.1.orig/src/gengine/OptionAgent.cpp fillets-ng-0.8.1/src/gengine/OptionAgent.cpp
+--- fillets-ng-0.8.1.orig/src/gengine/OptionAgent.cpp 2008-12-29 05:43:40.000000000 -0500
++++ fillets-ng-0.8.1/src/gengine/OptionAgent.cpp 2009-02-13 13:35:13.000000000 -0500
+@@ -23,8 +23,8 @@
+ #include "UnknownMsgException.h"
+ #include "minmax.h"
+
+-#include <stdlib.h> //getenv
+-#include <string.h> //strlen
++#include <cstdlib> //getenv
++#include <cstring> //strlen
+ #include <locale.h> //setlocale
+
+ #ifndef LC_MESSAGES
+diff -ru fillets-ng-0.8.1.orig/src/gengine/StringTool.cpp fillets-ng-0.8.1/src/gengine/StringTool.cpp
+--- fillets-ng-0.8.1.orig/src/gengine/StringTool.cpp 2008-08-10 06:00:15.000000000 -0400
++++ fillets-ng-0.8.1/src/gengine/StringTool.cpp 2009-02-13 13:35:29.000000000 -0500
+@@ -8,7 +8,7 @@
+ */
+ #include "StringTool.h"
+
+-#include <stdlib.h>
++#include <cstdlib>
+ #include <sstream>
+
+ //-----------------------------------------------------------------
+diff -ru fillets-ng-0.8.1.orig/src/level/Landslip.cpp fillets-ng-0.8.1/src/level/Landslip.cpp
+--- fillets-ng-0.8.1.orig/src/level/Landslip.cpp 2008-08-10 06:00:29.000000000 -0400
++++ fillets-ng-0.8.1/src/level/Landslip.cpp 2009-02-13 13:36:06.000000000 -0500
+@@ -11,7 +11,7 @@
+ #include "Rules.h"
+ #include "minmax.h"
+
+-#include <string.h>
++#include <cstring>
+
+ //-----------------------------------------------------------------
+ Landslip::Landslip(const ModelList &models)
diff --git a/games-puzzle/fish-fillets/fish-fillets-0.9.1.ebuild b/games-puzzle/fish-fillets/fish-fillets-0.9.1.ebuild
new file mode 100644
index 000000000000..9e9adf4d93b3
--- /dev/null
+++ b/games-puzzle/fish-fillets/fish-fillets-0.9.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/fish-fillets-0.9.1.ebuild,v 1.1 2009/07/07 03:28:03 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DATA_PV="0.9.0"
+DESCRIPTION="Underwater puzzle game - find a safe way out"
+HOMEPAGE="http://fillets.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fillets/fillets-ng-${PV}.tar.gz
+ mirror://sourceforge/fillets/fillets-ng-data-${DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsdl-1.2[video]
+ >=media-libs/sdl-mixer-1.2.5[vorbis]
+ >=media-libs/sdl-image-1.2.2[png]
+ x11-libs/libX11
+ media-libs/sdl-ttf
+ dev-libs/fribidi
+ >=dev-lang/lua-5"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/fillets-ng-${PV}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-gcc43.patch" \
+ "${FILESDIR}/${P}-fribidi.patch"
+
+ #.mod was renamed to .fmod in lua 5.1.3 - bug #223271
+ sed -i \
+ -e 's/\.mod(/.fmod(/' \
+ $(grep -rl "\.mod\>" "${WORKDIR}"/fillets-ng-data-${DATA_PV}) \
+ || die "sed failed"
+ rm -f missing
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --datadir="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}"/fillets-ng-data-${DATA_PV} || die
+ rm -f COPYING
+ doins -r * || die "doins failed"
+ newicon images/icon.png fillets.png
+ make_desktop_entry fillets FishFillets fillets
+ prepgamesdirs
+}