summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-12-22 01:29:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-12-22 01:29:22 +0000
commit817e29df64cd943f4c4e95f69af17bcc6c46ffd2 (patch)
tree181c978ddbfabbf40ffe3ce7f667d3b5666859f8 /games-puzzle
parentversion bump with patch from Michael (kensington) (bug #395583) (diff)
downloadgentoo-2-817e29df64cd943f4c4e95f69af17bcc6c46ffd2.tar.gz
gentoo-2-817e29df64cd943f4c4e95f69af17bcc6c46ffd2.tar.bz2
gentoo-2-817e29df64cd943f4c4e95f69af17bcc6c46ffd2.zip
version bump with patch reroll from Michael (kensington) (bug #395577)
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/sgt-puzzles/ChangeLog9
-rw-r--r--games-puzzle/sgt-puzzles/files/sgt-puzzles-9023-gentoo.patch4
-rw-r--r--games-puzzle/sgt-puzzles/files/sgt-puzzles-9306-gentoo.patch22
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-9306.ebuild74
4 files changed, 106 insertions, 3 deletions
diff --git a/games-puzzle/sgt-puzzles/ChangeLog b/games-puzzle/sgt-puzzles/ChangeLog
index 799508e94a36..1bb477faba15 100644
--- a/games-puzzle/sgt-puzzles/ChangeLog
+++ b/games-puzzle/sgt-puzzles/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-puzzle/sgt-puzzles
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.10 2011/01/04 22:53:18 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.11 2011/12/22 01:29:21 mr_bones_ Exp $
+
+*sgt-puzzles-9306 (22 Dec 2011)
+
+ 22 Dec 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ files/sgt-puzzles-9023-gentoo.patch, +sgt-puzzles-9306.ebuild,
+ +files/sgt-puzzles-9306-gentoo.patch:
+ version bump with patch reroll from Michael (kensington) (bug #395577)
04 Jan 2011; Markos Chandras <hwoarang@gentoo.org> sgt-puzzles-9023.ebuild:
Stable on amd64 wrt bug #350438
diff --git a/games-puzzle/sgt-puzzles/files/sgt-puzzles-9023-gentoo.patch b/games-puzzle/sgt-puzzles/files/sgt-puzzles-9023-gentoo.patch
index 31e7f796a611..f43d155f44dc 100644
--- a/games-puzzle/sgt-puzzles/files/sgt-puzzles-9023-gentoo.patch
+++ b/games-puzzle/sgt-puzzles/files/sgt-puzzles-9023-gentoo.patch
@@ -1,5 +1,5 @@
---- mkfiles.pl.old 2010-03-07 11:14:11.000000000 -0300
-+++ mkfiles.pl 2010-03-07 11:24:20.000000000 -0300
+--- mkfiles.pl.old
++++ mkfiles.pl
@@ -1110,8 +1110,8 @@
"\n".
&splitline("CFLAGS := -O2 -Wall -Werror -ansi -pedantic -g " .
diff --git a/games-puzzle/sgt-puzzles/files/sgt-puzzles-9306-gentoo.patch b/games-puzzle/sgt-puzzles/files/sgt-puzzles-9306-gentoo.patch
new file mode 100644
index 000000000000..49ee58d01af0
--- /dev/null
+++ b/games-puzzle/sgt-puzzles/files/sgt-puzzles-9306-gentoo.patch
@@ -0,0 +1,22 @@
+--- mkfiles.pl
++++ mkfiles.pl
+@@ -1117,8 +1117,8 @@
+ "\n".
+ &splitline("CFLAGS := -O2 -Wall -Werror -ansi -pedantic -g " .
+ (join " ", map {"-I$dirpfx$_"} @srcdirs) .
+- " `\$(GTK_CONFIG) --cflags` \$(CFLAGS)")."\n".
+- "XLIBS = `\$(GTK_CONFIG) --libs`\n".
++ " `pkg-config gtk+-2.0 --cflags` \$(CFLAGS)")."\n".
++ "XLIBS = `pkg-config gtk+-2.0 --libs` -lm\n".
+ "ULIBS =#\n".
+ "INSTALL=install\n",
+ "INSTALL_PROGRAM=\$(INSTALL)\n",
+@@ -1137,7 +1137,7 @@
+ $objstr = &objects($p, "X.o", undef, undef);
+ print &splitline($prog . ": " . $objstr), "\n";
+ $libstr = &objects($p, undef, undef, "-lX");
+- print &splitline("\t\$(CC) -o \$@ $objstr $libstr \$(XLFLAGS) \$(${type}LIBS)", 69),
++ print &splitline("\t\$(CC) \$(LDFLAGS) -o \$@ $objstr $libstr \$(XLFLAGS) \$(${type}LIBS)", 69),
+ "\n\n";
+ }
+ foreach $d (&deps("X.o", undef, $dirpfx, "/")) {
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-9306.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-9306.ebuild
new file mode 100644
index 000000000000..47d48a26880b
--- /dev/null
+++ b/games-puzzle/sgt-puzzles/sgt-puzzles-9306.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-9306.ebuild,v 1.1 2011/12/22 01:29:22 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs games
+if [[ ${PV} == "99999999" ]] ; then
+ ESVN_REPO_URI="svn://svn.tartarus.org/sgt/puzzles"
+ inherit subversion
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-r${PV}.tar.gz"
+ S=${WORKDIR}/puzzles-r${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/pkgconfig
+ doc? ( >=app-doc/halibut-1.0 )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ ./mkfiles.pl
+ sed -i \
+ -e 's:= -O2 -Wall -Werror -ansi -pedantic -g:= $(CPPFLAGS):' \
+ -e '/LDFLAGS/s:=:=$(LDFLAGS) :' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+ if use doc ; then
+ halibut --text --html --info --pdf --ps puzzles.but
+ fi
+}
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ emake DESTDIR="${D}" gamesdir="${GAMES_BINDIR}" install || die
+ dodoc README HACKING
+
+ local file name
+ for file in *.R ; do
+ [[ ${file} == "nullgame.R" ]] && continue
+ name=$(sed -n 's/^[a-z]*\.exe://p' "${file}")
+ file=${file%.R}
+ if [[ ${PV} -lt 99999999 ]] ; then
+ newicon icons/${file}-48d24.png ${PN}-${file}.png || die
+ make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
+ else
+ # No icons with the live version
+ make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}"
+ fi
+ done
+
+ dodoc puzzles.txt puzzles.chm
+ if use doc ; then
+ dohtml *.html
+ doinfo puzzles.info
+ dodoc puzzles.pdf puzzles.ps
+ fi
+
+ prepgamesdirs
+}