summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-20 03:56:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-20 03:56:17 +0000
commit65bf1cc8ce482ab3ac1916aa882d4c4315e30798 (patch)
tree9e83db3a15a94ddfc6e0e9e98e4616227a2b4e69 /games-puzzle
parentOld. (diff)
downloadgentoo-2-65bf1cc8ce482ab3ac1916aa882d4c4315e30798.tar.gz
gentoo-2-65bf1cc8ce482ab3ac1916aa882d4c4315e30798.tar.bz2
gentoo-2-65bf1cc8ce482ab3ac1916aa882d4c4315e30798.zip
convert to git; also fixes bug #532604
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/sgt-puzzles/ChangeLog8
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild57
2 files changed, 43 insertions, 22 deletions
diff --git a/games-puzzle/sgt-puzzles/ChangeLog b/games-puzzle/sgt-puzzles/ChangeLog
index a94316e8e189..ad91df107b20 100644
--- a/games-puzzle/sgt-puzzles/ChangeLog
+++ b/games-puzzle/sgt-puzzles/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/sgt-puzzles
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.16 2013/06/13 04:12:11 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.17 2015/04/20 03:56:17 mr_bones_ Exp $
+
+ 20 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ sgt-puzzles-99999999.ebuild:
+ convert to git; also fixes bug #532604
*sgt-puzzles-9861 (13 Jun 2013)
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
index 7c92810b1d0a..5c80d79ecae2 100644
--- a/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
+++ b/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild,v 1.5 2012/05/04 04:45:28 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild,v 1.6 2015/04/20 03:56:17 mr_bones_ Exp $
-EAPI=2
-inherit eutils toolchain-funcs games
+EAPI=5
+inherit eutils gnome2-utils toolchain-funcs games
if [[ ${PV} == "99999999" ]] ; then
- ESVN_REPO_URI="svn://svn.tartarus.org/sgt/puzzles"
- inherit subversion
+ EGIT_REPO_URI="git://git.tartarus.org/simon/puzzles.git"
+ inherit autotools git-r3
SRC_URI=""
KEYWORDS=""
else
@@ -29,28 +29,31 @@ DEPEND="${RDEPEND}
doc? ( >=app-doc/halibut-1.0 )"
src_prepare() {
- sed -i \
- -e 's/-O2 -Wall -Werror -ansi -pedantic -g//' \
- -e "s/libstr =/libstr = '\$(LDFLAGS) ' ./" \
- mkfiles.pl \
- || die
- ./mkfiles.pl
- sed -i \
- -e '1iPKG_CONFIG ?= pkg-config' \
- -e '/^GTK_CONFIG/s:=.*:= $(PKG_CONFIG) gtk+-2.0:' \
- Makefile || die
+ if [[ ${PV} == "99999999" ]] ; then
+ sed -i \
+ -e 's/-O2 -Wall -Werror -ansi -pedantic -g//' \
+ -e "s/libstr =/libstr = '\$(LDFLAGS) ' ./" \
+ mkfiles.pl || die
+ ./mkfiles.pl || die
+ eautoreconf
+ else
+ sed -i \
+ -e 's:= -O2 -Wall -Werror -ansi -pedantic -g:= $(CPPFLAGS):' \
+ -e '/LDFLAGS/s:=:=$(LDFLAGS) :' \
+ Makefile || die
+ fi
}
src_compile() {
- emake CC="$(tc-getCC)" || die
+ emake CC="$(tc-getCC)"
if use doc ; then
- halibut --text --html --info --pdf --ps puzzles.but
+ halibut --text --html --info --pdf --ps puzzles.but || die
fi
}
src_install() {
dodir "${GAMES_BINDIR}"
- emake DESTDIR="${D}" gamesdir="${GAMES_BINDIR}" install || die
+ emake DESTDIR="${D}" gamesdir="${GAMES_BINDIR}" install
dodoc README
local file name
@@ -59,7 +62,7 @@ src_install() {
name=$(sed -n 's/^[a-z]*\.exe://p' "${file}")
file=${file%.R}
if [[ ${PV} -lt 99999999 ]] ; then
- newicon icons/${file}-48d24.png ${PN}-${file}.png || die
+ newicon -s 48 icons/${file}-48d24.png ${PN}-${file}.png
make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
else
# No icons with the live version
@@ -75,3 +78,17 @@ src_install() {
prepgamesdirs
}
+
+pkg_preinst() {
+ games_pkg_preinst
+ [[ ${PV} -lt 99999999 ]] && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ [[ ${PV} -lt 99999999 ]] && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ [[ ${PV} -lt 99999999 ]] && gnome2_icon_cache_update
+}