summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-06-13 04:12:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-06-13 04:12:11 +0000
commit53a8afd8a69eec9c3e385052665ea48b6e635a68 (patch)
treef75ec0707b2b04848b7a1198f5700cc025996770 /games-puzzle
parentVersion bump (bug #473118). (diff)
downloadgentoo-2-53a8afd8a69eec9c3e385052665ea48b6e635a68.tar.gz
gentoo-2-53a8afd8a69eec9c3e385052665ea48b6e635a68.tar.bz2
gentoo-2-53a8afd8a69eec9c3e385052665ea48b6e635a68.zip
version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/sgt-puzzles/ChangeLog8
-rw-r--r--games-puzzle/sgt-puzzles/files/sgt-puzzles-9861-gentoo.patch23
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-9861.ebuild88
3 files changed, 118 insertions, 1 deletions
diff --git a/games-puzzle/sgt-puzzles/ChangeLog b/games-puzzle/sgt-puzzles/ChangeLog
index 436593cf0a32..a94316e8e189 100644
--- a/games-puzzle/sgt-puzzles/ChangeLog
+++ b/games-puzzle/sgt-puzzles/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/sgt-puzzles
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.15 2013/01/24 05:13:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/ChangeLog,v 1.16 2013/06/13 04:12:11 mr_bones_ Exp $
+
+*sgt-puzzles-9861 (13 Jun 2013)
+
+ 13 Jun 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/sgt-puzzles-9861-gentoo.patch, +sgt-puzzles-9861.ebuild:
+ version bump
24 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
-files/sgt-puzzles-9023-gentoo.patch, -sgt-puzzles-9023.ebuild:
diff --git a/games-puzzle/sgt-puzzles/files/sgt-puzzles-9861-gentoo.patch b/games-puzzle/sgt-puzzles/files/sgt-puzzles-9861-gentoo.patch
new file mode 100644
index 000000000000..c4ac19eed57e
--- /dev/null
+++ b/games-puzzle/sgt-puzzles/files/sgt-puzzles-9861-gentoo.patch
@@ -0,0 +1,23 @@
+diff -ru puzzles-r9861.orig/mkfiles.pl puzzles-r9861/mkfiles.pl
+--- puzzles-r9861.orig/mkfiles.pl 2013-03-30 16:16:21.000000000 -0400
++++ puzzles-r9861/mkfiles.pl 2013-06-11 17:59:54.255885226 -0400
+@@ -1117,8 +1117,8 @@
+ "\n".
+ &splitline("CFLAGS := -O2 -Wall -Werror -ansi -pedantic -g " .
+ (join " ", map {"-I$dirpfx$_"} @srcdirs) .
+- " `\$(GTK_CONFIG) --cflags` \$(CFLAGS)")."\n".
+- "XLIBS = `\$(GTK_CONFIG) --libs` -lm\n".
++ " `pkg-config gtk+-2.0 --cflags` \$(CFLAGS)")."\n".
++ "XLIBS = `pkg-config gtk+-2.0 --libs` -lm\n".
+ "ULIBS = -lm#\n".
+ "INSTALL=install\n",
+ "INSTALL_PROGRAM=\$(INSTALL)\n",
+@@ -1138,7 +1138,7 @@
+ $objstr = &objects($p, "X.o", undef, undef);
+ print &splitline("\$(BINPREFIX)" . $prog . ": " . $objstr), "\n";
+ $libstr = &objects($p, undef, undef, "-lX");
+- print &splitline("\t\$(CC) -o \$@ $objstr $libstr \$(XLFLAGS) \$(${type}LIBS)", 69),
++ print &splitline("\t\$(CC) \$(LDFLAGS) -o \$@ $objstr $libstr \$(XLFLAGS) \$(${type}LIBS)", 69),
+ "\n\n";
+ }
+ foreach $d (&deps("X.o", undef, $dirpfx, "/")) {
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-9861.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-9861.ebuild
new file mode 100644
index 000000000000..6809f54c6ab8
--- /dev/null
+++ b/games-puzzle/sgt-puzzles/sgt-puzzles-9861.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/sgt-puzzles/sgt-puzzles-9861.ebuild,v 1.1 2013/06/13 04:12:11 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils gnome2-utils toolchain-funcs games
+if [[ ${PV} == "99999999" ]] ; then
+ ESVN_REPO_URI="svn://svn.tartarus.org/sgt/puzzles"
+ inherit subversion
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-r${PV}.tar.gz"
+ S=${WORKDIR}/puzzles-r${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ doc? ( >=app-doc/halibut-1.0 )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ ./mkfiles.pl
+ sed -i \
+ -e 's:= -O2 -Wall -Werror -ansi -pedantic -g:= $(CPPFLAGS):' \
+ -e '/LDFLAGS/s:=:=$(LDFLAGS) :' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+ if use doc ; then
+ halibut --text --html --info --pdf --ps puzzles.but
+ fi
+}
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ emake DESTDIR="${D}" gamesdir="${GAMES_BINDIR}" install
+ dodoc README HACKING
+
+ local file name
+ for file in *.R ; do
+ [[ ${file} == "nullgame.R" ]] && continue
+ name=$(awk -F: '/exe:/ { print $3 }' "${file}")
+ file=${file%.R}
+ if [[ ${PV} -lt 99999999 ]] ; then
+ newicon -s 48 icons/${file}-48d24.png ${PN}-${file}.png
+ make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
+ else
+ # No icons with the live version
+ make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}"
+ fi
+ done
+
+ dodoc puzzles.txt puzzles.chm
+ if use doc ; then
+ dohtml *.html
+ doinfo puzzles.info
+ dodoc puzzles.pdf puzzles.ps
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ [[ ${PV} -lt 99999999 ]] && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ [[ ${PV} -lt 99999999 ]] && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ [[ ${PV} -lt 99999999 ]] && gnome2_icon_cache_update
+}