summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-20 13:33:42 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-20 13:33:42 +0000
commit0ed606c87a87d390b545d70531ecd8a3d152b5e9 (patch)
tree07dd63516236202172eac0a3f6b7fb1d7f0ce5ef /games-puzzle
parentRemove unaccessable directories from env file (diff)
downloadgentoo-2-0ed606c87a87d390b545d70531ecd8a3d152b5e9.tar.gz
gentoo-2-0ed606c87a87d390b545d70531ecd8a3d152b5e9.tar.bz2
gentoo-2-0ed606c87a87d390b545d70531ecd8a3d152b5e9.zip
Build with gcc-4.6 Bug #362591
(Portage version: 2.1.9.46/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/kiki/ChangeLog8
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-gcc46.patch22
-rw-r--r--games-puzzle/kiki/kiki-1.0.2-r2.ebuild5
3 files changed, 31 insertions, 4 deletions
diff --git a/games-puzzle/kiki/ChangeLog b/games-puzzle/kiki/ChangeLog
index fd163ffdf367..6b806159ea24 100644
--- a/games-puzzle/kiki/ChangeLog
+++ b/games-puzzle/kiki/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/kiki
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.17 2010/09/16 16:56:17 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.18 2011/04/20 13:33:42 tupone Exp $
+
+ 20 Apr 2011; Tupone Alfredo <tupone@gentoo.org> kiki-1.0.2-r2.ebuild,
+ +files/kiki-1.0.2-gcc46.patch:
+ Build with gcc-4.6 Bug #362591 by Diego Elio Pettenò
16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org> kiki-1.0.2-r2.ebuild:
virtual/glut -> media-libs/glut
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-gcc46.patch b/games-puzzle/kiki/files/kiki-1.0.2-gcc46.patch
new file mode 100644
index 000000000000..457c6d68ae02
--- /dev/null
+++ b/games-puzzle/kiki/files/kiki-1.0.2-gcc46.patch
@@ -0,0 +1,22 @@
+--- SWIG/KikiPy_wrap.cpp.old 2011-04-20 14:48:38.000000000 +0200
++++ SWIG/KikiPy_wrap.cpp 2011-04-20 15:15:08.000000000 +0200
+@@ -12968,7 +12968,7 @@
+ void *argp1 = 0 ;
+ int res1 = 0 ;
+ PyObject * obj0 = 0 ;
+- std::string *result = 0 ;
++ std::string result ;
+
+ if (!PyArg_ParseTuple(args,(char *)"O:KikiText_getText",&obj0)) SWIG_fail;
+ res1 = SWIG_ConvertPtr(obj0, &argp1,SWIGTYPE_p_KikiText, 0 | 0 );
+@@ -12976,8 +12976,8 @@
+ SWIG_exception_fail(SWIG_ArgError(res1), "in method '" "KikiText_getText" "', argument " "1"" of type '" "KikiText const *""'");
+ }
+ arg1 = reinterpret_cast< KikiText * >(argp1);
+- result = (std::string *) &((KikiText const *)arg1)->getText();
+- resultobj = SWIG_From_std_string(static_cast< std::string >(*result));
++ result = ((KikiText const *)arg1)->getText();
++ resultobj = SWIG_From_std_string(static_cast< std::string >(result));
+ return resultobj;
+ fail:
+ return NULL;
diff --git a/games-puzzle/kiki/kiki-1.0.2-r2.ebuild b/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
index 426713403270..8a1be696d595 100644
--- a/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
+++ b/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-1.0.2-r2.ebuild,v 1.6 2010/09/16 16:56:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-1.0.2-r2.ebuild,v 1.7 2011/04/20 13:33:42 tupone Exp $
PYTHON_DEPEND="2"
EAPI=2
inherit eutils python toolchain-funcs games
@@ -46,6 +46,7 @@ src_prepare() {
cd SWIG
swig -c++ -python -globals kiki -o KikiPy_wrap.cpp KikiPy.i || die
cp -f kiki.py ../py
+ epatch "${FILESDIR}"/${P}-gcc46.patch
}
src_compile() {