summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-07 10:53:26 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-07 10:53:26 +0000
commitb1573fb63c37b04922fc610eed51c72559d631c4 (patch)
tree48509726513d043c0fc12738d801553349bbee4e /games-mud
parentFixed depend on qt-4.1, bug #132543 (diff)
downloadgentoo-2-b1573fb63c37b04922fc610eed51c72559d631c4.tar.gz
gentoo-2-b1573fb63c37b04922fc610eed51c72559d631c4.tar.bz2
gentoo-2-b1573fb63c37b04922fc610eed51c72559d631c4.zip
Fix for gcc-4.1
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/xpertmud/ChangeLog6
-rw-r--r--games-mud/xpertmud/files/xpertmud-3.1_pre1-gcc41.patch10
-rw-r--r--games-mud/xpertmud/xpertmud-3.1_pre1.ebuild5
3 files changed, 18 insertions, 3 deletions
diff --git a/games-mud/xpertmud/ChangeLog b/games-mud/xpertmud/ChangeLog
index 5fc86ac7dda1..4cfee9bc6e11 100644
--- a/games-mud/xpertmud/ChangeLog
+++ b/games-mud/xpertmud/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-mud/xpertmud
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/ChangeLog,v 1.6 2006/03/30 17:28:22 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/ChangeLog,v 1.7 2006/05/07 10:53:26 tupone Exp $
+
+ 07 May 2006; <Tupone@gentoo.org> +files/xpertmud-3.1_pre1-gcc41.patch,
+ xpertmud-3.1_pre1.ebuild:
+ Fix fox gcc-4.1
30 Mar 2006; <Tupone@gentoo.org> +files/xpertmud-3.1_pre1-gcc34.patch,
xpertmud-3.1_pre1.ebuild:
diff --git a/games-mud/xpertmud/files/xpertmud-3.1_pre1-gcc41.patch b/games-mud/xpertmud/files/xpertmud-3.1_pre1-gcc41.patch
new file mode 100644
index 000000000000..6dc3bd219daf
--- /dev/null
+++ b/games-mud/xpertmud/files/xpertmud-3.1_pre1-gcc41.patch
@@ -0,0 +1,10 @@
+--- xpertmud/BookmarkEditor.h.old 2006-05-07 12:29:50.000000000 +0200
++++ xpertmud/BookmarkEditor.h 2006-05-07 12:31:23.000000000 +0200
+@@ -27,6 +27,7 @@
+ class QLineEdit;
+ class QSpinBox;
+ class QPushButton;
++class QComboBox;
+
+ class BookmarkEditor: public KDialogBase {
+ Q_OBJECT
diff --git a/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild b/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
index 554019f81c02..c655008bdd0d 100644
--- a/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
+++ b/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild,v 1.7 2006/03/30 17:28:22 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/xpertmud/xpertmud-3.1_pre1.ebuild,v 1.8 2006/05/07 10:53:26 tupone Exp $
inherit eutils kde
@@ -25,7 +25,8 @@ S=${WORKDIR}/xpertmud-${MY_PV}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}"-gcc34.patch
+ epatch "${FILESDIR}/${P}"-gcc34.patch \
+ "${FILESDIR}/${P}"-gcc41.patch
}
src_compile() {