summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-11-08 04:04:24 +0000
committerMichael Weber <xmw@gentoo.org>2010-11-08 04:04:24 +0000
commitde7011c31a37e8c7e55961f948eda18789827603 (patch)
tree79516fa6f1e2333839504124ed3ff662f83e372f /games-misc
parentRemove docdir sed from src_prepare because it was fixed upstream. (diff)
downloadgentoo-2-de7011c31a37e8c7e55961f948eda18789827603.tar.gz
gentoo-2-de7011c31a37e8c7e55961f948eda18789827603.tar.bz2
gentoo-2-de7011c31a37e8c7e55961f948eda18789827603.zip
remove gnome-vfs and fix ebuild issues
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/lucidlife/ChangeLog7
-rw-r--r--games-misc/lucidlife/files/lucidlife-0.9.2-gnome-vfs.patch70
-rw-r--r--games-misc/lucidlife/lucidlife-0.9.2.ebuild22
-rw-r--r--games-misc/lucidlife/metadata.xml2
4 files changed, 93 insertions, 8 deletions
diff --git a/games-misc/lucidlife/ChangeLog b/games-misc/lucidlife/ChangeLog
index 32122aefedf0..f26c0a4b8963 100644
--- a/games-misc/lucidlife/ChangeLog
+++ b/games-misc/lucidlife/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-misc/lucidlife
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/lucidlife/ChangeLog,v 1.1 2010/11/08 01:32:44 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/lucidlife/ChangeLog,v 1.2 2010/11/08 04:04:24 xmw Exp $
+
+ 08 Nov 2010; Michael Weber <xmw@gentoo.org> lucidlife-0.9.2.ebuild,
+ +files/lucidlife-0.9.2-gnome-vfs.patch, metadata.xml:
+ Removing gnome-base/gnome-vfs dependency and fix ebuild/metadata/.desktop
+ issues, thanks Mr_Bones_ and ssuominen.
*lucidlife-0.9.2 (08 Nov 2010)
diff --git a/games-misc/lucidlife/files/lucidlife-0.9.2-gnome-vfs.patch b/games-misc/lucidlife/files/lucidlife-0.9.2-gnome-vfs.patch
new file mode 100644
index 000000000000..49918b62146a
--- /dev/null
+++ b/games-misc/lucidlife/files/lucidlife-0.9.2-gnome-vfs.patch
@@ -0,0 +1,70 @@
+--- lucidlife-0.9.2/configure.ac
++++ lucidlife-0.9.2/configure.ac
+@@ -23,7 +23,7 @@
+ AC_SUBST(CFLAGS)
+ AC_SUBST(LDFLAGS)
+
+-GNOME_MODULES="[gtk+-2.0 >= 2.6.0 gnome-vfs-2.0 >= 2.0.0]"
++GNOME_MODULES="[gtk+-2.0 >= 2.6.0]"
+ PKG_CHECK_MODULES(GNOME, $GNOME_MODULES)
+ AC_SUBST(GNOME_CFLAGS)
+ AC_SUBST(GNOME_LIBS)
+--- lucidlife-0.9.2/src/lucidlife.c
++++ lucidlife-0.9.2/src/lucidlife.c
+@@ -35,8 +35,6 @@
+
+ #include <gtk/gtk.h>
+ #include <glib.h>
+-#include <libgnomevfs/gnome-vfs-init.h>
+-#include <libgnomevfs/gnome-vfs-utils.h>
+
+ #include <libintl.h>
+ #define _(String) gettext (String)
+@@ -418,7 +416,6 @@
+ state_from_config();
+ load_recent_files_list();
+
+- gnome_vfs_init();
+ gtk_init(&argc, &argv);
+ init_gui();
+
+@@ -445,8 +442,6 @@
+
+ main_loop();
+
+- gnome_vfs_shutdown();
+-
+ return 0;
+ }
+
+@@ -1635,7 +1630,7 @@
+
+ void activate_url(GtkAboutDialog *about, const gchar *url, gpointer data)
+ {
+- gnome_vfs_url_show (url);
++ gtk_show_uri (NULL, url, GDK_CURRENT_TIME, NULL );
+ }
+
+ /*** Bound Function Helpers ***/
+@@ -1859,7 +1856,7 @@
+ char* url;
+
+ url = dsprintf("file://%s/%s", DOCDIR, filename);
+- gnome_vfs_url_show(url);
++ gtk_show_uri (NULL, url, GDK_CURRENT_TIME, NULL );
+ free(url);
+ }
+
+--- lucidlife-0.9.2/lucidlife.desktop.in
++++ lucidlife-0.9.2/lucidlife.desktop.in
+@@ -2,8 +2,7 @@
+ Name=LucidLife
+ Comment=A user-friendly version of Conway's game of life
+ Exec=lucidlife
+-Icon=lucidlife.png
++Icon=lucidlife
+ Terminal=false
+ Type=Application
+-Categories=GNOME;Application;Game;
+-Encoding=UTF-8
++Categories=GNOME;GTK;Game;
diff --git a/games-misc/lucidlife/lucidlife-0.9.2.ebuild b/games-misc/lucidlife/lucidlife-0.9.2.ebuild
index 24756cebd500..e22388ce3238 100644
--- a/games-misc/lucidlife/lucidlife-0.9.2.ebuild
+++ b/games-misc/lucidlife/lucidlife-0.9.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/lucidlife/lucidlife-0.9.2.ebuild,v 1.1 2010/11/08 01:32:44 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/lucidlife/lucidlife-0.9.2.ebuild,v 1.2 2010/11/08 04:04:24 xmw Exp $
EAPI=2
-inherit games
+inherit autotools eutils games
DESCRIPTION="A Conway's Life simulator written in GTK+2 - fork from Gtklife"
HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Simulation/LucidLife-26633.shtml"
@@ -15,15 +15,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="gnome-base/gnome-vfs
- x11-libs/gtk+:2"
-RDEPEND="${DEPEND}"
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gnome-vfs.patch
+ eautoreconf
+ intltoolize --force --copy --automake || die
+}
src_install() {
emake install \
desktopdir=/usr/share/applications \
pixmapdir=/usr/share/pixmaps \
DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die
+
prepgamesdirs
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
}
diff --git a/games-misc/lucidlife/metadata.xml b/games-misc/lucidlife/metadata.xml
index 02b909e46b7e..a562c4775bb2 100644
--- a/games-misc/lucidlife/metadata.xml
+++ b/games-misc/lucidlife/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
+<herd>games</herd>
<maintainer>
<email>xmw@gentoo.org</email>
<name>Michael Weber</name>