summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-08-30 21:59:09 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-08-30 21:59:09 +0000
commit073c991c8b65c6f61b0d5745d13026be58793ee2 (patch)
tree3376af1e430dbc85c3072053593bf2f8fc64a373 /games-misc/katawa-shoujo
parentClean up old revision. Add missing PYTHON_USEDEP on cairo. (diff)
downloadgentoo-2-073c991c8b65c6f61b0d5745d13026be58793ee2.tar.gz
gentoo-2-073c991c8b65c6f61b0d5745d13026be58793ee2.tar.bz2
gentoo-2-073c991c8b65c6f61b0d5745d13026be58793ee2.zip
version bump wrt #469598
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-misc/katawa-shoujo')
-rw-r--r--games-misc/katawa-shoujo/ChangeLog7
-rw-r--r--games-misc/katawa-shoujo/katawa-shoujo-1.1.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/games-misc/katawa-shoujo/ChangeLog b/games-misc/katawa-shoujo/ChangeLog
index 45c7bf116dbf..7d158ba51ddb 100644
--- a/games-misc/katawa-shoujo/ChangeLog
+++ b/games-misc/katawa-shoujo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-misc/katawa-shoujo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/katawa-shoujo/ChangeLog,v 1.4 2013/05/23 14:24:43 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/katawa-shoujo/ChangeLog,v 1.5 2013/08/30 21:59:09 hasufell Exp $
+
+*katawa-shoujo-1.1 (30 Aug 2013)
+
+ 30 Aug 2013; Julian Ospald <hasufell@gentoo.org> +katawa-shoujo-1.1.ebuild:
+ version bump wrt #469598
23 May 2013; Sergey Popov <pinkbyte@gentoo.org> katawa-shoujo-1.0-r1.ebuild:
Non-maintainer commit: fix SRC_URI wrt bug #469710
diff --git a/games-misc/katawa-shoujo/katawa-shoujo-1.1.ebuild b/games-misc/katawa-shoujo/katawa-shoujo-1.1.ebuild
new file mode 100644
index 000000000000..a15642a23ea2
--- /dev/null
+++ b/games-misc/katawa-shoujo/katawa-shoujo-1.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/katawa-shoujo/katawa-shoujo-1.1.ebuild,v 1.1 2013/08/30 21:59:09 hasufell Exp $
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Bishoujo-style visual novel set in the fictional Yamaku High School for disabled children"
+HOMEPAGE="http://katawa-shoujo.com/"
+SRC_URI="http://dl.katawa-shoujo.com/gold_1.1/%5B4ls%5D_katawa_shoujo_1.1-%5Blinux-x86%5D%5BB5C707D5%5D.tar.bz2 -> ${P}.tar.bz2
+ http://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-48.png
+ http://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-256.png"
+
+LICENSE="CC-BY-NC-ND-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc system-renpy"
+
+# make system-renpy optional due to #459742 :(
+RDEPEND="system-renpy? ( games-engines/renpy )"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/lib/*"
+
+S="${WORKDIR}/Katawa Shoujo-linux-x86"
+
+src_install() {
+ if use system-renpy ; then
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r game/.
+ games_make_wrapper ${PN} "renpy '${GAMES_DATADIR}/${PN}'"
+ else
+ insinto "${GAMES_PREFIX_OPT}"/${PN}
+ doins -r common game lib renpy "Katawa Shoujo.py" "Katawa Shoujo.sh"
+ games_make_wrapper ${PN} "./Katawa\ Shoujo.sh" "${GAMES_PREFIX_OPT}/${PN}"
+ fperms +x "${GAMES_PREFIX_OPT}/${PN}"/lib/{python,linux-x86/python.real} \
+ "${GAMES_PREFIX_OPT}/${PN}/Katawa Shoujo.sh" \
+ "${GAMES_PREFIX_OPT}/${PN}/Katawa Shoujo.py"
+ fi
+
+ local i
+ for i in 48 256; do
+ newicon -s ${i} "${DISTDIR}"/${PN}-${i}.png ${PN}.png
+ done
+
+ make_desktop_entry ${PN} "Katawa Shoujo"
+
+ if use doc ; then
+ newdoc "Game Manual.pdf" manual.pdf
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "Savegames from system-renpy and the bundled version are incompatible"
+
+ if use system-renpy; then
+ ewarn "system-renpy is unstable and not supported upstream"
+ fi
+
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}