summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-31 05:02:30 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-31 05:02:30 +0000
commita46568560cf1b0f77ed0c355be54f57284d9964f (patch)
tree4a235b3f13dece746dcf6a0da3efeeeb2fb3b7b3 /games-misc/fortune-mod-slackware/fortune-mod-slackware-1.13.ebuild
parentMask net-im/aim for removal. (diff)
downloadgentoo-2-a46568560cf1b0f77ed0c355be54f57284d9964f.tar.gz
gentoo-2-a46568560cf1b0f77ed0c355be54f57284d9964f.tar.bz2
gentoo-2-a46568560cf1b0f77ed0c355be54f57284d9964f.zip
Version bump #134151 by Peter Hyman.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'games-misc/fortune-mod-slackware/fortune-mod-slackware-1.13.ebuild')
-rw-r--r--games-misc/fortune-mod-slackware/fortune-mod-slackware-1.13.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-misc/fortune-mod-slackware/fortune-mod-slackware-1.13.ebuild b/games-misc/fortune-mod-slackware/fortune-mod-slackware-1.13.ebuild
new file mode 100644
index 000000000000..39b3c1b45411
--- /dev/null
+++ b/games-misc/fortune-mod-slackware/fortune-mod-slackware-1.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod-slackware/fortune-mod-slackware-1.13.ebuild,v 1.1 2006/07/31 05:02:30 vapier Exp $
+
+# this ebuild now uses the offensive flag since AOLS
+# is not exactly 'G' rated :)
+
+MY_PN=slack-fortunes-all
+DESCRIPTION="This fortune mod is a collection of quotes seen on AOLS (Slackware)"
+HOMEPAGE="http://fauxascii.com/linux/mod_quotes.html"
+SRC_URI="http://fauxascii.com/linux/data/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="offensive"
+
+RDEPEND="games-misc/fortune-mod"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ if ! use offensive ; then
+ einfo "These fortunes have offensive content. Enable offensive USE Flag"
+ einfo "ex: USE=\"offensive\" emerge ${PN}"
+ einfo " or add to package.use file: games-misc/fortune-mod-slackware offensive"
+ exit 1
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ # get rid of md5 checks and extraneous files and backups
+ rm -f index.* *.md5 *~
+}
+
+src_install() {
+ insinto /usr/share/fortune
+ doins * || die "doins failed"
+}